Project

General

Profile

Bug #11070

Easy import/export of state file.

Added by Tonda over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
-
Start date:
02/07/2016
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
User interface design
Blueprint:
Starter:
Yes
Affected tool:

Description

Users of tails that do not use persistence are at greater risk of correlation attacks due to fast node cycling. This could be prevented by creating a VERY simple mechanism that allows a user to import and subsequently export their state file. A little GUI that allows the user to browse for their state file and apply it to tor's data directory. When the user presses the power icon with the intent of shitting down or restarting, an option to export is displayed.

This is purely speculation but I believe at least half of tails users use it in an amnesic way as originally intended and supported by the acronyms' translation. Safeguarding these people is IMO reason enough to implement this.


Related issues

Related to Tails - Feature #5462: Persistence preset: Tor state Confirmed 08/26/2016

History

#1 Updated by sajolida over 3 years ago

  • Assignee set to Tonda
  • QA Check set to Info Needed

Can you clarify what you mean by "fast node cycling" and "state file"?

#2 Updated by Tonda over 3 years ago

Fast node cycling = being assigned a new guard every time you boot up tails unless persistence is enabled.
State file = the file that holds the data about your selected guard node among other config info.

I propose that a simple import/export mechanism be created to allow users to keep their guard nodes for extended periods. For usb users, Tails could read the state file from the root of the usb drive and report to the user that it has been imported. Otherwise it could prompt/suggest to import the state file during the greeter or before Tor attempts to bootstrap.

Hope this helps! :)

#3 Updated by sajolida over 3 years ago

  • Status changed from New to Rejected
  • Assignee deleted (Tonda)
  • Target version deleted (Tails_2.2)
  • QA Check deleted (Info Needed)

We have a plan to solve this properly in #5462. I'd rather work on this than on partial workarounds like this.

#4 Updated by sajolida over 3 years ago

Also available in: Atom PDF