Project

General

Profile

Bug #11061

Make it easier to access WhisperBack from the Applications menu

Added by muri over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
02/05/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
No
Affected tool:

Description

on some small screens its hard to reach whisperback, because users are not able to navigate there. i think we should add whisperback to the favorite section of the menu.


Related issues

Related to Tails - Bug #11074: Cannot use "Laptop Mode Tools Configuration" menu entry Resolved 02/07/2016
Related to Tails - Bug #11075: Remove "Power Off" and "Reboot" from Applications → System Tools Resolved 03/27/2016

History

#1 Updated by intrigeri over 3 years ago

  • Type of work changed from Code to Discuss

on some small screens its hard to reach whisperback, because users are not able to navigate there. i think we should add whisperback to the favorite section of the menu.

This feels like it's maybe too much of a corner case for warranting the status of Favorite: we receive 50-200 WhisperBack bug reports every month, among 500k+ Tails boots.

Maybe we should instead document how to start WhisperBack from the Activities overview? This way it would work regardless of the screen resolution.

#2 Updated by sajolida over 3 years ago

  • Subject changed from Add whisperback to Favorites to Make it easier to access WhisperBack from the Applications menu
  • Status changed from New to Confirmed

I'm also not happy with moving it to "Favorites" as I don't think it deserves a "Favorites" status: it's probably used less often than "Tails Installer" for example.

The problem we're trying to solve here is different: making it easier to start WhisperBack from the Applications menu, for people on smaller screens and also in general.

It's currently at the botton of the System Tools menu which is the only one that requires scrolling.

I didn't know where it was myself at first and had to go through all the menus carefully to find it. I first looked for it in Tails, as it's a Tails-specific application. It's also on the desktop along "Tails documentation" which is as well in the Tails menu.

So I propose we move it to the "Tails" menu. These are not strong arguments but I don't see any counterarguments either (apart from change in itself).

intrigeri: The current menu path is already documented in https://tails.boum.org/doc/first_steps/bug_reporting#index3h1.

#3 Updated by intrigeri over 3 years ago

intrigeri: The current menu path is already documented in https://tails.boum.org/doc/first_steps/bug_reporting#index3h1

FYI I've no idea what I'm supposed to do with this information (that I already had in mind when proposing another solution earlier).

Regarding the proposed solution: I'm not convinced that "it's Tails-specific" is a good criterion to put stuff in the "Tails" submenu: I bet users care about their use cases, not about where software comes from. I think it's actually a bug that we have a "Tails" submenu at all: I would nowadays be in favour of moving everything from there to submenus that match the action the user wants to do. But I won't throw my weight around on this topic, and I can live with the solution proposed by sajolida. Submenus will anyway become obsolete if/when we move to the regular GNOME Shell interface, which will fix all such categorization problems and avoid the need for "this submenu has grown too large, let's move something from it to another submenu" -style kludges.

#4 Updated by sajolida over 3 years ago

  • Related to Bug #11074: Cannot use "Laptop Mode Tools Configuration" menu entry added

#5 Updated by sajolida over 3 years ago

  • Related to Bug #11075: Remove "Power Off" and "Reboot" from Applications → System Tools added

#6 Updated by sajolida over 3 years ago

FYI I've no idea what I'm supposed to do with this information (that
I already had in mind when proposing another solution earlier).

Sorry I misread your proposal. You meant from the Activities overview
and not from the Applications menu.

So far I've always relied on menu path to explain how to start
applications. This would be a first time. I'm not against the idea but
I'm not excited about doing this myself...

I quite like the idea of getting rid of the Tails menu, and especially
since we have Tails Installer and Persistence wizard duplicated in two
different menus (for some obscure technical reason if I remember well).

Also, I said earlier that you had to scroll to see WhisperBack in the
System Tools menu which is not true. I need to scroll here because I'm
installing deja-dup on my setup :)

Regarding menu categories, honestly, quite often these categories look
arbitrary to me. For example, the distinction between Accessories,
System Tools, and Universal Access is super blurry and I wouldn't able
to tell by heart in which menu an application belongs. So I'm not
convinced by the "use case" argument here.

But yeah, maybe we should instead work on making the System Tools menu
less crowded, this could be through #11074 and #11075.

#7 Updated by anonym over 3 years ago

intrigeri wrote:

Regarding the proposed solution: I'm not convinced that "it's Tails-specific" is a good criterion to put stuff in the "Tails" submenu: I bet users care about their use cases, not about where software comes from. I think it's actually a bug that we have a "Tails" submenu at all: I would nowadays be in favour of moving everything from there to submenus that match the action the user wants to do.

FWIW, I'm not convinced that the human-mind works with such clearly defined categories. Case in point: every time I look for WhisperBack, I first look in the Tails category, because it is what looks most relevant to me among the ones I see (I want to report a bug about Tails). However, I may not be the typical user so I grabbed a person that never has used Tails before, essentially, and said "please look in this menu for a tool called WhisperBack, which is used to send bug reports to the Tails team". The person first looked in the Utilities menu, then Tails, and then System Tools, wondering what the system == computer used had to do with this.

#8 Updated by intrigeri about 3 years ago

  • Starter changed from Yes to No

The problem reported initially was "on some small screens its hard to reach whisperback, because users are not able to navigate there". Since then we've cleaned up the System submenu, and on a 648x431 display I could navigate there without scrolling, in the exact same way as I would have done on a bigger screen. I doubt that Tails is usable on a smaller screen anyway, so it looks like we've already fixed the reported problem to me => I'm proposing we simply change nothing and close this ticket as resolved.

For the record, the proposals we had earlier on this ticket were:

  • move to the Favorites section, as proposed by muri: intrigeri & sajolida disagree
  • move to the Tails submenu, as proposed by sajolida: anonym likes it, intrigeri is unconvinced; conflicts with the idea of removing the Tails submenu entirely, that intrigeri proposed and sajolida quite likes
  • document to run WhisperBack from the Activities overview, as proposed by intrigeri: sajolida is fine with the idea but prefers not doing it himself

=> are there other problems, that these proposals would solve, and that we want to track? If yes, let's create a ticket for those other problems.

#9 Updated by muri about 3 years ago

  • Status changed from Confirmed to Resolved

We discussed this at the monthly meeting and agree that this ticket is already resolved by cleaning up the systems submenu.
The request about documenting how to run WhisperBack from the Activities menu is now #11621

Also available in: Atom PDF