Project

General

Profile

Bug #11056

Bug #7161: Support more than 24 HTTP mirrors

Feature #8635: Make each mirror provide a unique virtualhost name

Wait for most mirrors to implement new virtual hostname

Added by u almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
02/04/2016
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:

Description

..and remove the ones who did not from the pool.


Related issues

Blocked by Tails - Bug #11055: Ask all mirror operators to implement new virtual hostname Resolved 02/04/2016

History

#1 Updated by intrigeri over 2 years ago

  • Status changed from New to Confirmed

#2 Updated by intrigeri over 2 years ago

  • Category set to Infrastructure

#3 Updated by intrigeri over 2 years ago

  • Blocked by Bug #11055: Ask all mirror operators to implement new virtual hostname added

#4 Updated by intrigeri over 2 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#11055 is done, so there you go. I'll handle the fallout of my email to mirror operators when it comes to 1. allocating unique hostnames; 2. taking note of their answers; 3. adjusting the doc as needed. So basically what you need to do is to check in our mirrors.mdwn if they all provided a unique URL prefix (last column in the list of mirrors), ping them again in a week and again until we have enough updated mirrors to do the switch to the new setup.

#5 Updated by intrigeri over 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 30

So, all active mirrors but 5 now have a unique URI, 5 of our spare mirrors also have a unique URI, and on top of that we have another mirror that we can enable only once we've switched to the new setup. In short, if we switched to the new setup right now, we would have one more mirror than previously. Which means that this ticket is not really blocking anything anymore, and we can go ahead :) I'll reflect that in Redmine-speak right now.

Still, please ping the remaining mirrors at least once or twice in a week or two, because our goal (and success metrics!) here is to have more mirrors in the end.

#6 Updated by intrigeri over 2 years ago

  • Assignee changed from u to intrigeri

Given I handled the rest of the communication process, maybe it makes sense that I lead it to its end. If you prefer doing it yourself, just take it back :)

#7 Updated by intrigeri over 2 years ago

  • Priority changed from Normal to High

#8 Updated by u over 2 years ago

I think it makes sense to let you do the remaining bits of work indeed. If you don't want to, please give the ticket back to me :)

#9 Updated by intrigeri over 2 years ago

  • % Done changed from 30 to 80

Sent one last ping to the remaining 4 (2 active + 2 spare) mirrors that still haven't adjusted to the new setup. Then I'll give up, because mirror operators being unresponsive is a problem in itself.

#10 Updated by intrigeri over 2 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 80 to 100

Done.

#11 Updated by BitingBird over 2 years ago

  • Priority changed from High to Normal

Also available in: Atom PDF