Project

General

Profile

Bug #11055

Bug #7161: Support more than 24 HTTP mirrors

Feature #8635: Make each mirror provide a unique virtualhost name

Ask all mirror operators to implement new virtual hostname

Added by u over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
02/04/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:

Description

The idea would be to ask them to, for a short transition time, make their mirror reply to the new virtual hostname and dl.a.b.o, as they do now.


Related issues

Blocked by Tails - Feature #11054: Update contribute/how/mirror documentation with examples for the web servers we support Resolved 02/04/2016
Blocks Tails - Bug #11056: Wait for most mirrors to implement new virtual hostname Resolved 02/04/2016
Blocked by Tails - Feature #11334: Document how HTTP mirrors get a unique virtualhost name Resolved 04/08/2016

History

#2 Updated by sajolida over 3 years ago

For the record, last time I asked all operators to change their config (to disable ETag) it took me two months between the initial email and the disabling of mirrors who didn't do the upgrade. Then one more month of pinging and late fixes.

#3 Updated by u over 3 years ago

  • Assignee changed from u to sajolida
  • QA Check set to Info Needed

Thanks for mentioning this.

I suppose that there is a list of all mirror operators? Please tell me where I can find this so that we can anticipate. (By email if you prefer.)

Is there anything else I should know about communicating with the mirror operators?
Just because they might wonder about me writing the email.

Please reassign this ticket to me when done. Cheers!

#4 Updated by intrigeri over 3 years ago

  • Assignee changed from sajolida to u
  • QA Check changed from Info Needed to Dev Needed

I suppose that there is a list of all mirror operators? Please tell me where I can find this so that we can anticipate. (By email if you prefer.)

I think the next step is to get access to the mirror team repo.
Ask this level of access on tails@ and then -sysadmins@ will give you access.

Is there anything else I should know about communicating with the mirror operators?
Just because they might wonder about me writing the email.

You'll need to communicate with them as tails@.

#5 Updated by intrigeri over 3 years ago

  • Status changed from New to Confirmed

#6 Updated by intrigeri over 3 years ago

  • Category set to Infrastructure

#7 Updated by intrigeri over 3 years ago

  • Blocked by Feature #11054: Update contribute/how/mirror documentation with examples for the web servers we support added

#8 Updated by intrigeri over 3 years ago

  • Blocks Bug #11056: Wait for most mirrors to implement new virtual hostname added

#9 Updated by intrigeri over 3 years ago

I've just finished (hopefully) getting all the blockers done so you can get this one started. Once they are fully done (waiting for your review), please check if there's any info you lack, or lack access to, in order to do this.

#10 Updated by intrigeri over 3 years ago

  • Priority changed from Normal to Elevated

(Reflecting the fact that we need to ask soon, in order to get #11056 done in a month.)

#11 Updated by intrigeri over 3 years ago

  • Blocked by Feature #11334: Document how HTTP mirrors get a unique virtualhost name added

#12 Updated by intrigeri over 3 years ago

  • Assignee changed from u to intrigeri

#13 Updated by intrigeri over 3 years ago

  • Priority changed from Elevated to High

#14 Updated by intrigeri over 3 years ago

Note to myself: even though that's not strictly required, I'd like to finish the changes mentioned on #11335#note-2 before sending that email. But it's not worth marking that other ticket as a blocker, since I won't block on sajolida's review there before making progress here.

#15 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100
  • QA Check deleted (Dev Needed)

Email+doc tested by one mirror operator => email sent.

#16 Updated by BitingBird about 3 years ago

  • Priority changed from High to Normal

Also available in: Atom PDF