Project

General

Profile

Bug #11028

DSL missing from network-manager connection options

Added by muri almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Hardware support
Target version:
-
Start date:
01/29/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Wait
Blueprint:
Starter:
Affected tool:

Description

apparently under 1.x it was possible to establish a dsl connection via network manager. that options seems to be gone. there was one report by a user in #tails and one on the torproject.org in a comment:

In Tails 1.8.2 and prior versions I connected to the internet by adding a username and password to a dsl connection in the network connections. In Tails 2.0 I can't find a dsl or equivalent where I can introduce a username and password to connect to the internet.

(from https://blog.torproject.org/blog/tor-browser-55-released)


Related issues

Related to Tails - Bug #11267: Add nm-connection-editor to the network setup instructions Confirmed

History

#1 Updated by mercedes508 almost 4 years ago

  • Status changed from New to Confirmed

#2 Updated by muri almost 4 years ago

  • Assignee set to intrigeri
  • Type of work changed from Debian to Code

oke, so i had a look: apparently network-manager is able to do dsl connections, but there are now two gui-dialogs for connections, the one of gnome3 and nm-connection-editor. nm-connection-editor has all the options, while the gnome3 settings dialog is missing some (this is also the case in debian/stretch). so tails defaults to the settings dialog with less (and missing) options. the problem, i think, is that its not that easy to make nm-connection-editor the default gui in gnome3.
(this is also the case in standard debian live)
assigning to intrigeri, i hope thats oke

#3 Updated by intrigeri almost 4 years ago

  • Assignee changed from intrigeri to muri
  • QA Check set to Info Needed

oke, so i had a look: apparently network-manager is able to do dsl connections, but there are now two gui-dialogs for connections, the one of gnome3 and nm-connection-editor. nm-connection-editor has all the options, while the gnome3 settings dialog is missing some (this is also the case in debian/stretch). so tails defaults to the settings dialog with less (and missing) options. the problem, i think, is that its not that easy to make nm-connection-editor the default gui in gnome3.

Thanks for doing the research!

I think we should:

  1. for Tails 2.x: cheaply document how to configure a DSL connection, that is really: point to how to run nm-connection-editor; nm-connection-editor is not listed in the Applications menu nor in the overview, so one has to start it from the command-line; it's just one command to run, so I guess it's acceptable, compared to user confusion that would be created if we added another network connection manager to the menus
  2. for Tails 3.x: make sure that GNOME upstream is aware of the missing support in the default NM config interface

muri, what do you think?

Are you up to doing any of those?

#4 Updated by muri almost 4 years ago

  • Status changed from Confirmed to In Progress
  • Type of work changed from Code to Wait

intrigeri wrote:

  1. for Tails 2.x: cheaply document how to configure a DSL connection, that is really: point to how to run nm-connection-editor; nm-connection-editor is not listed in the Applications menu nor in the overview, so one has to start it from the command-line; it's just one command to run, so I guess it's acceptable, compared to user confusion that would be created if we added another network connection manager to the menus

added #11267 to track that

  1. for Tails 3.x: make sure that GNOME upstream is aware of the missing support in the default NM config interface

there is https://bugzilla.gnome.org/show_bug.cgi?id=724945 which seems to be about that, but its from 2014, so maybe someone with contacts to gnome-devs can point them to this issue (actually i'm surprised that its not fixed with the rise of LTE). i've added the AffectsTails keyword to the bugreport and i'm setting this one to wait

#5 Updated by muri almost 4 years ago

  • Related to Bug #11267: Add nm-connection-editor to the network setup instructions added

#6 Updated by muri over 3 years ago

  • Status changed from In Progress to Resolved

we cannot do much more, so marking as resolved

Also available in: Atom PDF