Project

General

Profile

Bug #11025

Known issues on browser fingerprinting don't mention uBlockOrigin

Added by cypherpunks over 3 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

QA Check:
Feature Branch:
doc/11025-browser-fingerprint
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

I left this as a comment in #11000 but maybe it should be its own issue? (That one is already closed so maybe nobody sees it?)

The Known Issues page has an inaccurate statement on it:

There are currently no known differences between the fingerprints of Tor Browser inside and outside of Tails.

https://tails.boum.org/support/known_issues/index.en.html#index4h1

In truth, AdBlock Plus (and also the font issue in #11000) make it quite easy to distinguish TBB from TBB-on-Tails.

After the next release with the fix for the font issue, would it be accurate to say "AdBlock Plus is enabled by default. If you disable it, there are currently no known differences between the fingerprints of Tor Browser inside and outside of Tails."? (I hope that would be accurate but I don't know.)

Meanwhile this statement should be corrected so that it is accurate for Tails 2.0.


Related issues

Related to Tails - Bug #11665: Clean up known issues page Confirmed 08/19/2016
Blocks Tails - Feature #14758: Core work 2017Q4 → 2018Q1: Technical writing Resolved 09/17/2017

Associated revisions

Revision cee5f821
Added by intrigeri about 1 year ago

Merge remote-tracking branch 'origin/doc/11025-browser-fingerprint' (Closes: #11025)

History

#1 Updated by mercedes508 over 3 years ago

  • Status changed from New to Confirmed

#2 Updated by intrigeri over 3 years ago

@sajolida: is this because we're only considering fingerprinting from the PoV of an isolated web site administrator, without collusion with ad networks?

#3 Updated by sajolida over 3 years ago

  • Subject changed from Known Issues: browser fingerprinting to Known issues on browser fingerprinting don't mention AdBlock

We're documenting AdBlock pretty well in /doc/about/fingerprint, so the point here is that we're not mentioning AdBlock in /support/known_issues#fingerprint.

Maybe pointing to /doc/about/fingerprint from /support/known_issues#fingerprint, in order to clarify what's the scope of this list would make sense?

#4 Updated by intrigeri over 3 years ago

Maybe pointing to /doc/about/fingerprint from /support/known_issues#fingerprint, in order to clarify what's the scope of this list would make sense?

I think so :)

#5 Updated by sajolida over 3 years ago

  • Starter set to Yes

Then this should be "easy".

#6 Updated by emmapeel about 3 years ago

  • Assignee set to emmapeel

#7 Updated by emmapeel about 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from emmapeel to sajolida
  • Estimated time set to 2.00 h
  • QA Check set to Ready for QA
  • Feature Branch set to emmapeel:doc/11025-browser_fingerprint

please review the branch with the changes...

#8 Updated by sajolida about 3 years ago

  • Assignee changed from sajolida to emmapeel
  • Feature Branch changed from emmapeel:doc/11025-browser_fingerprint to doc/11025-browser_fingerprint

I pushed a different and shorter version on doc/11025-browser_fingerprint. I'm not really convinced either but I feel lazy spending more time on this... What do you think?

#9 Updated by BitingBird almost 3 years ago

  • Start date deleted (01/29/2016)
  • % Done changed from 0 to 20
  • Estimated time deleted (2.00 h)

#10 Updated by emmapeel almost 3 years ago

  • Assignee changed from emmapeel to sajolida
  • QA Check changed from Ready for QA to Info Needed

sajolida wrote:

I pushed a different and shorter version on doc/11025-browser_fingerprint. I'm not really convinced either but I feel lazy spending more time on this... What do you think?

Well... you just deleted all the information I added! :D

After interaction with the users I thought I had to add the phrase about Tails being just as "Tor Browser if you install and enable AdBlock".

Maybe we can make that phrase shorter, but I think just pointing to the other document will not solve the issue raised by the user. Or maybe we can delete the whole fingerprint section on wiki/src/support/known_issues.mdwn so we don't say two different things (in known_bugs, 'there is no difference' and in fingerprint, 'there is a difference' - of course I'm being simplistic as in KISS)

What do you think about that?

#11 Updated by sajolida over 2 years ago

  • Assignee changed from sajolida to emmapeel
  • QA Check changed from Info Needed to Ready for QA

Our communication is a bit messy on this one, sorry!

So, taking a step back, I think that we are both right:

  • I removed your second sentence "Read our documentation..." because we're not explaining this in the doc. Did I miss something?
  • I removed your first sentence about AdBlock because, as explained in #11025#note-3 and intrigeri acked, the known issue should point to the doc and not duplicate its content.
  • Still, you are perfectly right, in the sense that my last version of the known issue pretends that "There are currently no known differences" while we're explaining in the doc that AbBlock is a difference. I didn't realize this when I submitted my last branch.

We spent too much time on this already and here is more radical proposal: what about getting rid of this section all the way when there are no difference (on top of the ones who are already explain very well in the doc) and only have one when there are differences? We could keep the anchor and a commented template but nothing visible when there's actually nothing to explain.

I'm doing this in 5315965. Please have a look.

#12 Updated by emmapeel almost 2 years ago

  • Assignee deleted (emmapeel)
  • QA Check changed from Ready for QA to Pass

Yeah whatever

#13 Updated by emmapeel almost 2 years ago

  • Status changed from In Progress to Resolved

#14 Updated by intrigeri almost 2 years ago

  • Status changed from Resolved to In Progress
  • Assignee set to sajolida
  • % Done changed from 20 to 90

It seems to me that we should not close this ticket before the corresponding branch is merged.

#15 Updated by sajolida almost 2 years ago

#16 Updated by sajolida almost 2 years ago

#17 Updated by sajolida almost 2 years ago

#18 Updated by BitingBird over 1 year ago

  • Related to Bug #11665: Clean up known issues page added

#19 Updated by BitingBird over 1 year ago

  • Target version set to Tails_3.2

#20 Updated by sajolida over 1 year ago

  • Target version deleted (Tails_3.2)

#21 Updated by sajolida over 1 year ago

  • Blocks deleted (Feature #13423: Core work 2017Q3: Technical writing)

#22 Updated by sajolida over 1 year ago

  • Blocks Feature #14758: Core work 2017Q4 → 2018Q1: Technical writing added

#23 Updated by u over 1 year ago

  • Subject changed from Known issues on browser fingerprinting don't mention AdBlock to Known issues on browser fingerprinting don't mention uBlockOrigin

We nowadays ship uBlockOrigin, not AdBlock.

#24 Updated by u over 1 year ago

This ticket is marked "Pass" but has not been merged since 8 months.

#25 Updated by sajolida over 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Pass)

#26 Updated by intrigeri over 1 year ago

  • Status changed from Resolved to In Progress
  • Assignee set to sajolida
  • Target version set to Tails_3.6
  • QA Check set to Dev Needed

53159657257b4486711bc3e0d30ed10037b7a648 broke existing links (git grep 'known_issues#fingerprint' -- wiki/src/**/*.{mdwn,html}) => reopening.

#27 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA
  • Feature Branch changed from doc/11025-browser_fingerprint to doc/11025-browser-fingerprint

Oops... What about now?

#28 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Dev Needed

sajolida wrote:

Oops... What about now?

That's better! I'm not convinced by the chosen implementation (having a section that can eithe exist or not be there at all) but whatever, it's your turf and we'll see how it fares in practice.

Now, the command I provided shows at least another link (in wiki/src/contribute/release_process/test.mdwn) that your branch does not fix yet.

#29 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to intrigeri
  • QA Check changed from Dev Needed to Ready for QA
  • Starter deleted (Yes)

I removed the broken link with b9516b03dc.

I also studied our Git history a bit and since December 2013 this section changed twice:

  • 06027f4912: Dec 21, when we removed a previous fingerprinting issue.
  • f942b674f6: Feb 1, when we added a fingerprint issue. It was valid from 2.0 to 2.4 (4 months).

So this section was useful only 4 months in the past 4+ years (8%). That's why I don't want to spend more time trying to improve it and would rather spend a bit more time on it next time it becomes useful.

#30 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

#31 Updated by intrigeri about 1 year ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

sajolida wrote:

So this section was useful only 4 months in the past 4+ years (8%). That's why I don't want to spend more time trying to improve it and would rather spend a bit more time on it next time it becomes useful.

Makes sense to me!

#32 Updated by sajolida about 1 year ago

  • QA Check deleted (Pass)

Also available in: Atom PDF