Project

General

Profile

Bug #11007

32-bit UEFI broken in Tails 2.0

Added by intrigeri over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Hardware support
Target version:
Start date:
01/27/2016
Due date:
% Done:

100%

Feature Branch:
bugfix/11007-32-bit-uefi
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Tails 2.0 includes GRUB2 2.02~beta2-22+deb8u1, that hasn't our patches (Tails 1.8.2 had 2.02~beta2-22tails1). As a result, 32-bit UEFI boot is broken. Regression against 1.8.2.

Associated revisions

Revision 0171052d (diff)
Added by intrigeri over 3 years ago

Enable the bugfix-11007-32-bit-uefi APT overlay.

Will-fix: #11007

Revision b9a791d8
Added by anonym over 3 years ago

Merge remote-tracking branch 'origin/bugfix/11007-32-bit-uefi' into stable

Fix-committed: #11007

History

#1 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/11007-32-bit-uefi

#2 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

Fixes the problem on the 32-bit UEFI laptop that allowed me to identify it in the first place. Should not affect any other use case, since 32-bit UEFI is the only reason we include GRUB2 for.

#3 Updated by intrigeri over 3 years ago

Please merge into stable and devel (we want this fix in 2.0.1 if we have to put it out, IMO).

#4 Updated by anonym over 3 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#5 Updated by anonym over 3 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

I couldn't test it on the affected hardware since I do not have access to any, but I trust your testing of it, obviously.

#6 Updated by bertagaz over 3 years ago

  • Status changed from Fix committed to Resolved
  • QA Check deleted (Pass)

Also available in: Atom PDF