Project

General

Profile

Feature #10984

Test Rufus

Added by sajolida about 4 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
-
Start date:
01/22/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:

Description

The homepage of Rufus (http://rufus.akeo.ie/) displays "Tails 1.8.1" in its opening screenshot. So it's probably worth testing it.


Related issues

Related to Tails - Feature #8550: Make Tails Installer work on Windows Rejected 06/22/2015
Related to Tails - Bug #13206: Install by cloning sometimes silently fails from a stick installed with UUI Rejected 09/29/2017
Related to Tails - Feature #14447: Consider using Win32 Disk Imager to install from Windows In Progress 08/24/2017
Related to Tails - Feature #11825: Consider switching to Rufus instead of UUI for Windows users Rejected 09/22/2016
Related to Tails - Feature #15292: Distribute a USB image Resolved 04/14/2016 01/29/2019
Duplicated by Tails - Feature #7034: Test Rufus for manual installation on Windows Duplicate 04/07/2014
Blocked by Tails - Bug #7938: Universal USB Installer creates unbootable devices Rejected 09/23/2014
Blocks Tails - Feature #14448: Consider documenting Rufus as a workaround in case UUI doesn't work Rejected 08/24/2017

History

#1 Updated by sajolida about 4 years ago

I tried Rufus 2.6 Portable on Windows Vista and a Tails 1.8 ISO image.

  • Using the "ISO Image" resulted in no "Boot Tails" menu and a blinking cursor. I tried installing twice and got the same result.
  • Using the "DD Image" it worked as expected and I got a DD Tails.

But that's a cool tool to replace dd on Windows :)

#2 Updated by sajolida about 4 years ago

  • Related to Feature #8550: Make Tails Installer work on Windows added

#3 Updated by intrigeri about 4 years ago

  • Using the "DD Image" it worked as expected and I got a DD Tails.

But that's a cool tool to replace dd on Windows :)

Cool! I'm curious how the data installed on the target drive compares with the original ISO image.

#4 Updated by sajolida about 4 years ago

  • QA Check set to Info Needed

#5 Updated by sajolida about 4 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)

I'm curious how the data installed on the target drive compares with the original ISO image.

I'm not :)

#6 Updated by intrigeri about 4 years ago

I'm curious how the data installed on the target drive compares with the original ISO image.

I'm not :)

Fair enough :)

But until someone does that, we can't draw conclusions from this ticket, can we?

#7 Updated by sajolida about 4 years ago

  • Status changed from Resolved to In Progress

Hmm... depends on the goal of the ticket, which might be not have been clear enough indeed.

I initially thought (seeing their promising screenshot) was that Rufus was maybe doing the right GPT dance and could replace Tails Installer all the way. And this is not the case. I didn't analyse that's wrong on the USB stick but it doesn't boot.

Now, if Rufus can be a replacement for dd, the most we can make out of it is to:

  • Replace UUI by Rufus in our instructions. I'm not sure that's worth it given the fact that UUI hasn't been that problematic over the years.
  • Use it as a replacement for dd on Windows if maybe-some-day we ship disk images instead of ISO images. To the light on this why not... but that does beyond my initial curiosity for testing it.

So I'm leaving this ticket open if someone wants to take over.

#8 Updated by intrigeri about 4 years ago

Understood, and given this context I now think we should close this ticket.

#9 Updated by sajolida over 3 years ago

  • Duplicated by Feature #7034: Test Rufus for manual installation on Windows added

#10 Updated by sajolida over 3 years ago

  • Related to Bug #7938: Universal USB Installer creates unbootable devices added

#11 Updated by sajolida over 3 years ago

  • Blocked by Feature #11825: Consider switching to Rufus instead of UUI for Windows users added

#12 Updated by sajolida over 3 years ago

  • Related to deleted (Bug #7938: Universal USB Installer creates unbootable devices)

#13 Updated by sajolida over 3 years ago

  • Blocked by Bug #7938: Universal USB Installer creates unbootable devices added

#14 Updated by intrigeri over 3 years ago

Blocked by Feature #11825: Consider switching to Rufus instead of UUI for Windows users added

Did you mean s/Blocked by/Blocks/?

#15 Updated by sajolida over 3 years ago

  • Blocked by deleted (Feature #11825: Consider switching to Rufus instead of UUI for Windows users)

#16 Updated by sajolida over 3 years ago

  • Blocks Feature #11825: Consider switching to Rufus instead of UUI for Windows users added

#17 Updated by sajolida over 3 years ago

Did you mean s/Blocked by/Blocks/?

Fixed. It's good that you're always on the lookout!

#18 Updated by mercedes508 about 3 years ago

  • Assignee set to intrigeri

I went through this ticket, and don't get if there's anything left to test according to replace UUI bye Rufus?

If, yes, assign it to me please.

#19 Updated by sajolida about 3 years ago

  • Status changed from In Progress to Rejected
  • Assignee deleted (intrigeri)
  • QA Check deleted (Info Needed)

#20 Updated by sajolida about 3 years ago

  • Status changed from Rejected to Confirmed
  • Assignee set to mercedes508

Reopening after reading #11825#note-8 and answering with #11825#note-9. Sorry for the mess!

#21 Updated by jgallias almost 3 years ago

sajolida wrote:

Reopening after reading #11825#note-8 and answering with #11825#note-9. Sorry for the mess!

Add me to the list of people who needed to use Rufus because UUI wouldn't work.

Thanks.

#22 Updated by sajolida almost 3 years ago

Hi jgallias, good to know that we can get in touch with a user facing these issues.

I'll let mercedes get in touch with you to analyze and document better what we need as explained in #11825#note-9 (failures of UUI and successes of Rufus).

#23 Updated by Anonymous over 2 years ago

Ping @mercedes508?

#24 Updated by mercedes508 over 2 years ago

  • Assignee changed from mercedes508 to Anonymous

Well, last week I got several "UUI not working but Rufus fine", but don't get exactly what I should gather as input?

Is the point to reproduce exact same user conditions?

#25 Updated by sajolida over 2 years ago

  • Assignee changed from Anonymous to mercedes508
  • QA Check set to Info Needed

Ok... hmm...

To be able to solve a problem ("UUI not working") we must be able to see it, at least to know when its fixed. So what I need is to be able to reproduce the problem: find parameters and procedures that create a broken Tails through UUI.

Then only we will be able to know:

  • If we can fix UUI to always work.
  • What Rufus does differently and hopefully how to make Rufus work for more people than UUI (all the times I tried it didn't work and I don't want to be the first one to try again).

#26 Updated by sajolida over 2 years ago

As an alternative, I'm fine contacting myself these people to try to understand better why UUI doesn't work for them.

Some other input you could gather is test Rufus yourself, see if it works and report about your setup and procedure.

#27 Updated by sajolida over 2 years ago

  • Related to Bug #13206: Install by cloning sometimes silently fails from a stick installed with UUI added

#28 Updated by jgallias over 2 years ago

Latest Tails and UUI worked without issue from my Desktop.

I was able to update several different existing USB Tails drives using the
intermediary drive I created from UUI.

It would seem I am no longer having any issues with UUI, but it might be
good to still have Rufus as a fallback, as it seems like the only other
option when UUI fails for whatever reason.

Thanks.

On Thu, Aug 3, 2017 at 1:42 PM <> wrote:

Issue #10984 has been updated by sajolida.

Related to Bug #13206: Install by cloning sometimes silently fails from a
stick installed with UUI added

----------------------------------------
Bug #10984: Test Rufus
https://labs.riseup.net/code/issues/10984#change-73414

  • Author: sajolida
  • Status: Confirmed
  • Priority: Normal
  • Assignee: mercedes508
  • Category: Installation
  • Target version:
  • QA Check: Info Needed
  • Feature Branch:
  • Type of work: Test
  • Blueprint:
  • Easy:
  • Affected tool:
    ----------------------------------------
    The homepage of Rufus (http://rufus.akeo.ie/) displays "Tails 1.8.1" in
    its opening screenshot. So it's probably worth testing it.

--
You have received this notification because you have either subscribed to
it, or are involved in it.
To change your notification preferences, please click here:
https://labs.riseup.net/code/my/account

--

--
John Gallias

<>
johngallias.com
keybase.io/jgallias

#29 Updated by sajolida over 2 years ago

  • Related to Feature #14447: Consider using Win32 Disk Imager to install from Windows added

#30 Updated by mercedes508 over 2 years ago

  • Assignee changed from mercedes508 to anonym

We should verify what does Rufus do when installing Tails ISO onto a USB.
So we can decide if that's something we want document or to advice to users from help Desk PoV.

#31 Updated by mercedes508 over 2 years ago

  • Assignee changed from anonym to sajolida

#32 Updated by mercedes508 over 2 years ago

  • Blocks deleted (Feature #11825: Consider switching to Rufus instead of UUI for Windows users)

#33 Updated by mercedes508 over 2 years ago

  • Related to Feature #11825: Consider switching to Rufus instead of UUI for Windows users added

#34 Updated by sajolida over 2 years ago

  • Blocks Feature #14448: Consider documenting Rufus as a workaround in case UUI doesn't work added

#35 Updated by sajolida over 2 years ago

Let's make sure there's no regression (like no UEFI boot if using new tools).

#36 Updated by Anonymous about 2 years ago

  • Assignee changed from sajolida to goupille

I would like to close this ticket as a duplicate as we decided not to switch in #11825.
Furthermore @jgallias reported that they did not have problems anymore with recent versions of Rufus.

We decided to document Rufus as a possible fallback if UUI does not work: #14448.
I think we should simply document there that we don't know if UEFI will work and not spend more time on this.

@helpdesk: I'd still like to know if you have seen recent problems related to UUI? If not, please close this ticket as a duplicate.

#37 Updated by goupille about 2 years ago

@helpdesk: I'd still like to know if you have seen recent problems related to UUI? If not, please close this ticket as a duplicate.

I think that every week, one or two users are reporting issues with starting a tails device installed with UUI, usually the issue is solved after advising the use of Rufus. however, I don't know if the issue is related to UUI, or if the user didn't follow carefully the documentation (e.g. #13206)...

that's said, I'm ok with closing this ticket

#38 Updated by goupille about 2 years ago

  • Status changed from Confirmed to Duplicate
  • Assignee deleted (goupille)
  • QA Check deleted (Info Needed)

duplicate of #14448

#39 Updated by Anonymous about 2 years ago

I tested Rufus on Windows 7. Had to download supplementary Syslinux versions. This happens automatically after Rufus reported an error. Rufus' UX is very complicated, not to name it horrible, there are too many options.. Rufus proposed me to choose between ISO install and DD install, once it detected that our ISO image is hybrided. I selected DD mode and I got a bootable USB stick (in legacy mode) and the checksums of sha1sum /dev/sdb1 and sha1sum tails-amd64-3.5.iso matched.

#40 Updated by sajolida about 2 years ago

  • Tracker changed from Bug to Feature
  • Status changed from Duplicate to In Progress
  • Assignee set to sajolida

Now that I have a UEFI laptop, I'll test again Rufus to see if some of its options lead to a working USB with my UEFI.

#41 Updated by sajolida over 1 year ago

#42 Updated by sajolida over 1 year ago

  • Status changed from In Progress to Rejected
  • Assignee deleted (sajolida)

We now have a contract for #15292 that will document Etcher instead, so I'm rejecting this.

Also available in: Atom PDF