Project

General

Profile

Bug #10961

KeePassX uses qwerty instead of configured layout

Added by alant almost 4 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Internationalization
Target version:
-
Start date:
01/17/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Password Manager

Description

To reproduce the issue:

- launch Tails 2.0rc1 on e media containing a persistence with KeePassX configured
- select e.g. french layout
- open KeePassX
- type "a" and click the eye to see what's written
- you'll see "q"

This bug prevents to use KeePassX (at least without changing password) if it contains non-qwerty characters.

History

#1 Updated by intrigeri almost 4 years ago

  • Assignee set to intrigeri

I'll give it a look.

#2 Updated by intrigeri almost 4 years ago

  • Assignee changed from intrigeri to sajolida

I won't have time to work on this for 2.0 => sajolida, anonym: can you please make sure this is documented in the known issues? Please reassign to me, for the actual bug resolution, once it's been documented.

#3 Updated by sajolida almost 4 years ago

  • Status changed from New to Resolved
  • Assignee changed from sajolida to alant
  • Target version deleted (Tails_2.0)
  • QA Check set to Info Needed

I couldn't reproduce this. I tried on my 2.0 with persistence and many different keyboard layouts: French (ç), Danish (ø), Spanish (ñ), Vietnamese (â), etc. I also tried on a fresh Tails with no persistence.

Reassigning as Alan for confirmation.

#4 Updated by sajolida over 2 years ago

  • Affected tool set to Password Manager

Also available in: Atom PDF