Project

General

Profile

Bug #10959

Drop tsocks

Added by intrigeri almost 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/17/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

It's been unmaintained for years in Debian, I just had to NMU it so that it is not RC-buggy anymore and can go back into Debian testing.

We're using it for:

  • Git: if I get 3922b0b2c119de81c682b9e1f8f80a1b8355690d right, we could now use torsocks 2.1 with its AllowOutboundLocalhost option enabled;
  • ttdnsd uses tsocks' library; maybe it's time to realize that ttdnsd is not maintained either, and drop it or find some suitable replacement, then.

Related issues

Related to Tails - Bug #10955: Install tsocks from testing once it is back in Stretch Rejected 01/17/2016

Associated revisions

Revision 1512c2ba (diff)
Added by intrigeri about 3 years ago

Stop shipping ttdnsd.

It was only useful for developers and power-users who can install it themselves
as needed. It's been unmaintained upstream for many years. It's very buggy so we
had to remove it from the DNS resolution loop years ago. It's not in Debian.
And it's one of the only two bits of Tails that still rely on tsocks, that is
RC-buggy, unmaintained in Debian, and not in Stretch at the moment.

So it has become clear that the cost of keeping ttdnsd now outweighs the
benefits it brings.

refs: #10959

Revision 795357be (diff)
Added by intrigeri about 3 years ago

Use torsocks to torify Git, and drop tsocks entirely.

tsocks has been unmaintained for years in Debian, and is not in testing
at the moment.

Since we dropped ttdnsd, the only use case for tsocks was torifying Git.
But thanks to torsocks 2.1's AllowOutboundLocalhost we can now use torsocks to
torify Git without breaking Git-over-SSH. See 3922b0b2 for the previous
iteration of this.

refs: #10959
closes: #10955

History

#1 Updated by intrigeri almost 4 years ago

  • Target version set to Tails_3.0

I'd like to have this done for Tails 3.0 (Stretch), in order to not have to maintain tsocks in Debian for the next few years. But really, there's nothing that prevents us from doing this earlier, in the Tails 2.x series.

#2 Updated by intrigeri about 3 years ago

  • Related to Bug #10955: Install tsocks from testing once it is back in Stretch added

#3 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF