Project

General

Profile

Bug #10957

Check where localized search engines went in iceweasel-l10n-* 43+

Added by intrigeri over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Internationalization
Target version:
Start date:
01/17/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Browser

Description

See b476be974ec94eaef9e5c97c2be2d7d12e2a05cb. Were they moved somewhere else? Or is only the -ar package concerned?

History

#1 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#2 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#3 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#4 Updated by intrigeri over 3 years ago

  • Priority changed from Normal to Elevated

#5 Updated by intrigeri over 3 years ago

  • Assignee set to anonym
  • Target version changed from Tails_3.0 to Tails_2.4

Actually, we'll be affected by this as soon as we're based on FF45ESR.

#6 Updated by anonym about 3 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check set to Info Needed

intrigeri wrote:

Actually, we'll be affected by this as soon as we're based on FF45ESR.

I think you implicitly assume we also have to start fetching newer iceweasel-l10n packages, but since we are not installing them, but just unpacking the search plugins, we can continue using the old (Jessie) ones unless the new (Stretch?) ones have changes we care about. So this is not necessarily an imminent problem, but one for when we start working on Stretch for real. Or am I wrong?

(Side note: I am more and more feeling that we should stop installing these localized search plugins. They're full with purely commercial crap that IMHO is questionable to ship for a general purpose dist (Debian) and that are not vetted for a privacy-oriented one (Tails).)

#7 Updated by intrigeri about 3 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Info Needed to Dev Needed

I think you implicitly assume we also have to start fetching newer iceweasel-l10n packages,

I was indeed assuming that it may be a good idea to have search plugins that come from iceweasel-l10n-* whose version kind of match the version of Firefox we ship. But indeed, some version mismatch here is probably OK.

we can continue using the old (Jessie) ones unless the new (Stretch?) ones have changes we care about. So this is not necessarily an imminent problem, but one for when we start working on Stretch for real. Or am I wrong?

Jessie will have FF45 soon, once FF38 is not supported anymore, that is probably a few days after we build Tails 2.4. So, my understanding is that this problem will hit us shortly after 2.4 is out (assuming we don't have to postpone the release or rebuild the ISO). With this in mind, it doesn't sound crazy to postpone this ticket to 2.5.

(Side note: I am more and more feeling that we should stop installing these localized search plugins. They're full with purely commercial crap that IMHO is questionable to ship for a general purpose dist (Debian) and that are not vetted for a privacy-oriented one (Tails).)

I have no strong opinion on this matter.

I looked a bit closer, and:

  • on Stretch, iceweasel-l10n-* are transitional packages now, so they won't contain anything useful
  • none of firefox-esr-l10n-* ship any search plugins (unless it's hidden in the langpack extension?)

⇒ it looks like the decision has been made for us in Debian (or upstream, whatever) already. Let's stop trying to ship those localized search engines.

#8 Updated by anonym about 3 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Dev Needed to Info Needed

intrigeri wrote:

(Side note: I am more and more feeling that we should stop installing these localized search plugins. They're full with purely commercial crap that IMHO is questionable to ship for a general purpose dist (Debian) and that are not vetted for a privacy-oriented one (Tails).)

I have no strong opinion on this matter.

I looked a bit closer, and:

  • on Stretch, iceweasel-l10n-* are transitional packages now, so they won't contain anything useful
  • none of firefox-esr-l10n-* ship any search plugins (unless it's hidden in the langpack extension?)

Good hunch! They are,

 7z l langpack-es-ES@firefox-esr.mozilla.org.xpi  | grep searchplugins
2016-05-07 23:19:34 .....         6350         4404  browser/chrome/es-ES/locale/browser/searchplugins/bing.xml
2016-05-07 23:19:34 .....         8285         3284  browser/chrome/es-ES/locale/browser/searchplugins/ddg.xml
2016-05-07 23:19:34 .....         7875         4319  browser/chrome/es-ES/locale/browser/searchplugins/drae.xml
2016-05-07 23:19:34 .....         2595         1825  browser/chrome/es-ES/locale/browser/searchplugins/eBay-es.xml
2016-05-07 23:19:34 .....         8064         2230  browser/chrome/es-ES/locale/browser/searchplugins/google.xml
2016-05-07 23:19:34 .....           59           56  browser/chrome/es-ES/locale/browser/searchplugins/list.txt
2016-05-07 23:19:34 .....         2909         2142  browser/chrome/es-ES/locale/browser/searchplugins/twitter.xml
2016-05-07 23:19:34 .....         9359         5843  browser/chrome/es-ES/locale/browser/searchplugins/wikipedia-es.xml
2016-05-07 23:19:34 .....         9555         7073  browser/chrome/es-ES/locale/browser/searchplugins/yahoo-es.xml

So fixing our script is pretty simple...

⇒ it looks like the decision has been made for us in Debian (or upstream, whatever) already.

... so this is not true, but...

Let's stop trying to ship those localized search engines.

... I still think we should remove them. I'm pretty sure we started installing these mostly to get localized versions of search engines and wikipedia, and we now generate localized version of them ourselves.

Is this something we need a larger discussion about, or can I just go ahead closing this ticket, opening a new one for removing them, and then proceed?

#9 Updated by intrigeri about 3 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check changed from Info Needed to Dev Needed

... I still think we should remove them. I'm pretty sure we started installing these mostly to get localized versions of search engines and wikipedia, and we now generate localized version of them ourselves.

Yes, exactly.

Is this something we need a larger discussion about,

Given what's the reason why we wanted these things initially, I don't think so. The use case we meant to support will still be supported.

or can I just go ahead closing this ticket, opening a new one for removing them, and then proceed?

Yes, please.

#10 Updated by anonym about 3 years ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (anonym)
  • QA Check deleted (Dev Needed)

Moving on to #11418.

Also available in: Atom PDF