Project

General

Profile

Bug #10955

Install tsocks from testing once it is back in Stretch

Added by intrigeri almost 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/17/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

I've NMU'ed it to Debian to fix https://bugs.debian.org/769343, and uploaded to our feature-stretch so that we have it until it makes it into Debian testing.


Related issues

Related to Tails - Bug #10959: Drop tsocks Resolved 01/17/2016

Associated revisions

Revision 795357be (diff)
Added by intrigeri about 3 years ago

Use torsocks to torify Git, and drop tsocks entirely.

tsocks has been unmaintained for years in Debian, and is not in testing
at the moment.

Since we dropped ttdnsd, the only use case for tsocks was torifying Git.
But thanks to torsocks 2.1's AllowOutboundLocalhost we can now use torsocks to
torify Git without breaking Git-over-SSH. See 3922b0b2 for the previous
iteration of this.

refs: #10959
closes: #10955

History

#1 Updated by intrigeri almost 4 years ago

  • Subject changed from Drop tsocks from our AP repository once 1.8beta5-9.3 is in Stretch to Drop tsocks from our APT repository once 1.8beta5-9.3 is in Stretch

#2 Updated by intrigeri almost 4 years ago

  • Subject changed from Drop tsocks from our APT repository once 1.8beta5-9.3 is in Stretch to Install tsocks from testing once 1.8beta5-9.3 is in Stretch

Actually: revert 33092df287e1f0d6d9833220ad6f60d2615110f0 when it's time.

#3 Updated by intrigeri over 3 years ago

  • Subject changed from Install tsocks from testing once 1.8beta5-9.3 is in Stretch to Install tsocks from testing once it is back in Stretch

#4 Updated by intrigeri over 3 years ago

#5 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to Rejected
  • % Done changed from 0 to 100

We don't ship tsocks in feature/stretch anymore.

Also available in: Atom PDF