Project

General

Profile

Bug #10941

seahorse-tool --import does not import keys completely

Added by muri about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/14/2016
Due date:
% Done:

10%

Feature Branch:
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:

Description

hi,

i'm not exactly sure if the title is correct, but: seahorse-tool (the default command to import keys, i.e. if you double click a downloaded .key in nautilus) doesn't seem to be able to import signatures on keys (or only one of them). for example: if you start tails, delete all the keys from the keyring and then download the new key from https://tails.boum.org/tails-signing.key, it imports an expired key. or if a user has an old tails and wants to update the key using the keyfile from the website, it doesn't work.
(seahorse-tool is part of the seahorse-nautilus package)


Related issues

Related to Tails - Bug #10943: Seahorse is not associated with application/pgp-signature Resolved 01/15/2016
Related to Tails - Bug #12733: Seahorse fails to import private PGP keys: pinentry-gtk-2 passphrase prompt not displayed Resolved 06/19/2017
Duplicated by Tails - Bug #11622: Signing Key import Bug Duplicate 08/06/2016

History

#1 Updated by emmapeel about 4 years ago

  • Related to Bug #10943: Seahorse is not associated with application/pgp-signature added

#2 Updated by intrigeri about 4 years ago

  • Subject changed from seahorse-tool doesn't import signatures to seahorse-tool --import does not import keys completely
  • Status changed from New to Confirmed
  • Assignee set to muri
  • QA Check set to Info Needed

Reproduced on Tails 1.8.2 and 2.0~rc1:

$ gpg --delete-keys 0xDBB802B258ACD84F
[...]
$ seahorse-tool --import /usr/share/doc/tails/website/tails-signing.key
$ $ gpg --import /usr/share/doc/tails/website/tails-signing.key 
gpg: key 0xDBB802B258ACD84F: "Tails developers (offline long-term identity key) <tails@boum.org>" 1 new user ID
gpg: key 0xDBB802B258ACD84F: "Tails developers (offline long-term identity key) <tails@boum.org>" 37 new signatures
gpg: key 0xDBB802B258ACD84F: "Tails developers (offline long-term identity key) <tails@boum.org>" 3 new subkeys
gpg: Total number processed: 1
gpg:           new user IDs: 1
gpg:            new subkeys: 3
gpg:         new signatures: 37
gpg: no ultimately trusted keys found

muri, can you check if this is known in upstream Bugzilla, and/or try and reproduce on non-Tails so we can report it upstream? (Ideally, for GNOME things best is to reproduce on the last Fedora, they have a pretty useful Live ISO. Failing that, Debian testing/sid is OK, and worst case Debian stable is already a helpful data point).

#3 Updated by muri about 4 years ago

reproduced on debian stretch.
wasn't able to reproduce on fedora, because on fedora the key doesn't get imported at all.
didn't find any bugreport, created https://bugzilla.gnome.org/show_bug.cgi?id=760693

#4 Updated by intrigeri about 4 years ago

  • Type of work changed from Debian to Communicate

Cool, thanks! I see that you've reported it against the seahorse-plugins "product". I'm not sure it's the best place, since seahorse-plugins has been deprecated and unmaintained for years. Perhaps the seahorse "product" would be more adequate, even though technically seahorse-nautilus is something else? (its README points to the Seahorse page as its home page, so well)

#5 Updated by intrigeri about 4 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • QA Check deleted (Info Needed)

#6 Updated by muri about 4 years ago

intrigeri wrote:

Cool, thanks! I see that you've reported it against the seahorse-plugins "product". I'm not sure it's the best place, since seahorse-plugins has been deprecated and unmaintained for years. Perhaps the seahorse "product" would be more adequate, even though technically seahorse-nautilus is something else? (its README points to the Seahorse page as its home page, so well)

ah, yeah, you're right. i've moved it to product 'seahorse', component 'nautilus'

#7 Updated by muri over 3 years ago

  • Status changed from In Progress to Resolved

we cannot do much more, so marking as resolved

#8 Updated by emmapeel over 3 years ago

  • Duplicated by Bug #11622: Signing Key import Bug added

#9 Updated by emmapeel over 2 years ago

  • Related to Bug #12733: Seahorse fails to import private PGP keys: pinentry-gtk-2 passphrase prompt not displayed added

Also available in: Atom PDF