Project

General

Profile

Bug #10940

KeePassX misses characters

Added by emmapeel almost 4 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/14/2016
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Password Manager

Description

I guess it may be caused by the 'flaky' interface issue, or how quick a double character is typed:

Steps to reproduce:

- Open KeepassX
- Open website with username-pasword form
- Select the pertinent record on KeepassX
- Hit Ctrl+V

Username field lacks a character, always when it is double, as in 'emmapel' instead of 'emmapeel'

The second try works.

This didn't happenned to me until Tails 2.0beta and still hapenning in Tails 2.0RC1


Related issues

Related to Tails - Feature #10780: Upgrade KeePassX to 2.x Resolved 12/20/2015

History

#1 Updated by intrigeri almost 4 years ago

  • Category deleted (Hardware support)

#2 Updated by intrigeri almost 4 years ago

  • Subject changed from KeypassX misses characters when typing on Browser to KeePassX misses characters when typing on Browser

#3 Updated by intrigeri almost 4 years ago

I guess it may be caused by the 'flaky' interface issue,

Can you please clarify what issue this is referring to? I'm not aware of any corresponding ticket.
(Not assigning to you + info needed since this is rather a side question, and one can probably work on this ticket without waiting for your answer.)

#4 Updated by emmapeel almost 4 years ago

intrigeri wrote:

I guess it may be caused by the 'flaky' interface issue,

Can you please clarify what issue this is referring to? I'm not aware of any corresponding ticket.

Could not find a ticket. I refer to the comments on tails-testers about mouse stuttering or moving too fast, and high loads when doing Alt+Tab, etc.

#5 Updated by segfault almost 4 years ago

  • Subject changed from KeePassX misses characters when typing on Browser to KeePassX misses characters

keepassx 0.4.3 also misses and mistypes special characters when autotyping. This is also not only an issue with the browser, it happened to me in pinentry and is reproducable in gedit.

I generated this password:
!]!.}(~<#=).+(<=`[{;&\`+^[|,)<[++%+^=[+(?%*'$(}^{)

When using autotype, keepassx enters this instead:
!~!.¯(″<#=).+(<=′&’′+⅝)<+%+⅝=(?%*'$(¯⅝

I installed the keepassx package from debian testing and this seems to be fixed. This is KeepPassX 2.0 which uses a new database format and requires to import passwords from old databases.

#6 Updated by intrigeri almost 4 years ago

I installed the keepassx package from debian testing and this seems to be fixed.

This is good news! So this will be fixed in Tails 3.0, worst case.

This is KeepPassX 2.0 which uses a new database format and requires to import passwords from old databases.

If you're interested in looking into upgrading Tails 2.x to KeePassX 2.0, please let #10780 know. I can at least sponsor uploads of the backport if needed.

#7 Updated by segfault almost 4 years ago

If you're interested in looking into upgrading Tails 2.x to KeePassX 2.0, please let #10780 know. I can at least sponsor uploads of the backport if needed.

I am indeed interested in upgrading KeePassX sooner than in Tails 3.0. The only thing I see that needs to be done for this is #10956. What do you mean with "sponsor uploads of the backport"?

#8 Updated by intrigeri almost 4 years ago

I'll reply on #10780, which feels like a better place to have this discussion.

#9 Updated by segfault over 3 years ago

#10 Updated by segfault over 3 years ago

If it turns out that it will take a while to do #10780, disabling the use of special characters in KeePassX' password generator would be a quick fix to lessen the impact of this bug. It would at least make the behaviour I described above in note 5 not appear with newly created passwords without the user changing the default settings.
This is achieved by adding this line to the [options] section in .config/keepassx/config.ini

PwGenOptions=01110000011110

Then we might consider increasing the default password length (25) to compensate for the loss of entropy:

PwGenLength=30

I would prepare a patch if you think this makes sense.

#11 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to Resolved
  • Target version set to Tails_3.0
  • % Done changed from 0 to 100

So apparently this is fixed in Stretch, so will be fixed for free in Tails 3.0. I've seen no progress on #10780 for a long time, so I'll assume that we will do the transition in Tails 3.0.

#12 Updated by emmapeel almost 3 years ago

  • Status changed from Resolved to Confirmed

I am afraid I had this problem in Tails 3.0beta1.

Reopening thus.

#13 Updated by intrigeri over 2 years ago

  • Assignee set to spriver
  • % Done changed from 100 to 50
  • QA Check set to Info Needed

spriver, can you please try and reproduce this when working on the KeePassX v2 integration/doc?

#14 Updated by emmapeel over 2 years ago

Spriver: try it with a username that has douuble characters. It creates a single character from a double one, as in

emapel instead of emmapeel

but never emmpeel or emmaeel

#15 Updated by spriver over 2 years ago

  • Assignee changed from spriver to emmapeel

I could not reproduce it with some testing I made today. I copied the username/pw via Ctrl+b and Ctrl+c and pasted it into a user/password form, and it worked all well (including double characters).

Could you describe the way you copied the username and password from KeePassX into e.g. the browser?

#16 Updated by sajolida over 2 years ago

  • Affected tool set to Password Manager

#17 Updated by emmapeel over 2 years ago

  • Assignee changed from emmapeel to spriver

spriver wrote:

I could not reproduce it with some testing I made today. I copied the username/pw via Ctrl+b and Ctrl+c and pasted it into a user/password form, and it worked all well (including double characters).

Could you describe the way you copied the username and password from KeePassX into e.g. the browser?

I select the entry on KeepassX, and hit Ctrl+V (provided the window directly under KeepassX is the login window, and the cursor is focused in the user textarea)

#18 Updated by intrigeri over 2 years ago

  • Assignee changed from spriver to emmapeel
  • Target version deleted (Tails_3.0)
  • % Done changed from 50 to 0

I could not manage to reproduce this, so please:

  • try to reproduce with 3.0 final, and if you see it again send me a complete WhisperBack bug report
  • try to paste into gedit (instead of Tor Browser) and tell me the outcome
  • run xclip -o in a Terminal and then copy the username in KeePassX: what KeePassX put in the clipboard should appear in the Terminal; tell me what it is (I'm curious if KeePassX copies the wrong thing into the clipboard, or if Tor Browser pastes the wrong thing from the clipboard)

#19 Updated by u almost 2 years ago

No news since 7 months, not able to reproduce this. @emmapeel: please test if the issue still persists, otherwise reject this ticket.

#20 Updated by emmapeel almost 2 years ago

  • Status changed from Confirmed to Rejected

I haven't seen it in a while,

Also available in: Atom PDF