Project

General

Profile

Bug #10932

Feature #7584: Update documentation for Jessie

Disks cannot open local harddrive LVM (as Disk Utility did)

Added by emmapeel almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
01/13/2016
Due date:
% Done:

100%

Feature Branch:
doc/10932-disks-vs-lvm
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Booting on a Debian laptop with LVM LUKS it is not possible anymore to access the contents of the disk with Disks, the application that replaces Disk Utility.

Steps to reproduce:

- Boot Tails 2.0beta1 on a laptop with Debian LVM.
- Try to open the local hard drive

The Disks application allows me to Unlock the device, but then I get no 'Play button' to mount it.

Desired result:

Being able to mount it like in Tails 1.8.2 and before.


Related issues

Blocks Tails - Bug #8045: Update path to GNOME Disks for Jessie Resolved 10/09/2014

Associated revisions

Revision 06c2ebde
Added by sajolida over 3 years ago

Merge remote-tracking branch 'origin/doc/10932-disks-vs-lvm' (Closes: #10932)

History

#1 Updated by spriver almost 4 years ago

Hi,
I reproduced the bug and tried to find out what is happening. The unlocking of the device with Disks seems to be without any errors - in /var/log/ctl there's a mesage that the parition was succesfully unlocked. I tried also to unlock my LVM'ed SSD with Nautilus and got the error "Unable to access "120GB Encrypted" The unlocked device does not have a recognizable file system". I don't have any more ideas. Unlocking and mounting of encrypted USB sticks works without any problems.

#2 Updated by sajolida almost 4 years ago

  • Assignee set to spriver
  • QA Check set to Info Needed

Yeah, that's a pain. I think that Disks removed the opening/closing of LVM volumes for some reason. If you want to further work on this, maybe you could:

1. Investigate whether there are bugs about this on the GNOME bug tracker. I'm sure more people complained about it.
2. Maybe we should document executing `vgchange -ay` in a root terminal to activate the volume group. Then you can see the partitions in Disks.

And if you don't want to work on this, I'm fine doing it :)

#3 Updated by emmapeel almost 4 years ago

I confirm that I can mount it if I do `vgchange -ay` on a root terminal after unlocking the volume in Disks

#4 Updated by spriver over 3 years ago

How should we proceed here? I couldn't find any bug in a trice for now. Is there a doc page that needs an update then?

#5 Updated by sajolida over 3 years ago

  • Parent task set to #7584

At least the last note on https://tails.boum.org/doc/encryption_and_privacy/your_data_wont_be_saved_unless_explicitly_asked/ would then need to be updated. Marking this as a subtask of #7584.

It's somehow a corner case and I'm not sure we can do better than documenting `vgchange -ay` in this same note.

I assigned this to you because you are working on Disks in Jessie. But feel free to assign this to me if you prefer.

#6 Updated by sajolida over 3 years ago

  • Assignee changed from spriver to sajolida

#7 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to spriver
  • Target version set to Tails_2.2
  • QA Check changed from Info Needed to Ready for QA
  • Feature Branch set to doc/10932-disks-vs-lvm

Ready for review!

#8 Updated by sajolida over 3 years ago

  • Blocks Bug #8045: Update path to GNOME Disks for Jessie added

#9 Updated by spriver over 3 years ago

  • Assignee changed from spriver to sajolida
  • QA Check changed from Ready for QA to Pass

I've reviewed the changes, for me they seem to be good (:

#10 Updated by sajolida over 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

#11 Updated by sajolida over 3 years ago

  • Assignee deleted (sajolida)
  • QA Check deleted (Pass)

Also available in: Atom PDF