Project

General

Profile

Bug #10930

Feature #7584: Update documentation for Jessie

Update documentation on accessibility in Tails Jessie

Added by sajolida almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Accessibility
Target version:
-
Start date:
01/13/2016
Due date:
% Done:

0%

Feature Branch:
bugfix/10930-accesibility_docs
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

We now have the Accessibility menu in the top bar!

Associated revisions

Revision 65fbdf84
Added by sajolida over 3 years ago

Merge remote-tracking branch 'origin/bugfix/10930-accesibility_docs' (Closes: #10930)

History

#1 Updated by sajolida almost 4 years ago

  • Parent task set to #7584

#2 Updated by emmapeel almost 4 years ago

  • Assignee changed from sajolida to emmapeel

I take it

#3 Updated by emmapeel almost 4 years ago

  • Assignee changed from emmapeel to sajolida
  • QA Check set to Info Needed

Orca Screen Reader does not appear on 'Applications/Universal Access'. Shall I change the docs, or oopen a bug to add it to the menu?

#4 Updated by intrigeri over 3 years ago

  • Assignee changed from sajolida to emmapeel
  • QA Check changed from Info Needed to Dev Needed

Orca Screen Reader does not appear on 'Applications/Universal Access'.

I see it in the accessibility menu. As the "Universal Access" section in the GNOME Help reads: "You can find this menu by clicking the icon which looks like a person surrounded by a circle on the top bar".

#5 Updated by emmapeel over 3 years ago

Yes, I see it there too...

So there is no possibility to add it to the Applications/Universal Access menu? Maybe this is a Debian bug?

I think we should take out the Applications/Universal Access menu then, if it lacks functionality....

#6 Updated by emmapeel over 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from emmapeel to sajolida
  • QA Check changed from Dev Needed to Ready for QA
  • Feature Branch set to emmapeel:bugfix/10930-accesibility_docs

Updated the paths and added the screenshot. I think we need a proper name for 'the icon which looks like a person surrounded by a circle on the top bar'. Universal Access icon?

#7 Updated by intrigeri over 3 years ago

Yes, I see it there too...

Cool. I take it that as far as this ticket is concerned, you're not blocked anymore from updating the doc, then. If there's any additional info needed, let me know :)

So there is no possibility to add it to the Applications/Universal Access menu?

Technically: yes, we could do that, but this feels useless to me since there's now a better, and already documented, way to start Orca.

Maybe this is a Debian bug?

Accessibility tools that are part of GNOME were migrated to the accessibility menu, which feels right; the way I understand it, in other desktop environments (that have no accessibility menu), Orca will nevertheless appear in the applications menu. So I think there's no bug to report to Debian.

But some other accessibility tools (Florence, Dasher) are not integrated in the accessibility menu, that's why we still have the Applications → Universal Access menu, that provides launchers for these tools.

I think we should take out the Applications/Universal Access menu then, if it lacks functionality....

I agree the situation is not ideal, but I have no idea if we can solve it without lots of painful work. Please file a ticket about it if you have any idea where the launchers for Florence and Dasher should go ("add them to the accessibility menu" is not realistic , I think :) Long term: we have various reasons to replace Florence with the virtual keyboard that is already integrated in the accessibility menu (#8281), and regarding predictive text input, I see that there's WIP in GNOME to do that, so hopefully we can replace Dasher some day… and then the Applications/Universal Access will go away :)

#8 Updated by emmapeel over 3 years ago

Thanks for the explanation! I understand the situation now.

#9 Updated by sajolida over 3 years ago

Regarding your doubts on how to refer to this button in the doc, see https://mail.gnome.org/archives/gnome-doc-list/2016-January/msg00004.html and install/linux/usb.mdwn.

You can find these in /usr/share/icons/HighContrast/16x16.

I'll still review your branch as it is now and comment on the rest.

#10 Updated by sajolida over 3 years ago

  • Priority changed from Normal to Elevated
  • Target version changed from Tails_2.0 to Tails_2.2

#11 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to emmapeel
  • Feature Branch changed from emmapeel:bugfix/10930-accesibility_docs to bugfix/10930-accesibility_docs

So I reviewed your work and improved on it. I hope you won't mind but I felt there was many details that I wanted to improve even in the previous documentation and thought I could do myself directly. So please review and tell me if I can merge.

#12 Updated by emmapeel over 3 years ago

I liked it, and corrected a little typo.

The commit is available at emmapeel:bugfix/10930-accesibility_docs

#13 Updated by emmapeel over 3 years ago

  • Assignee changed from emmapeel to sajolida
  • QA Check changed from Ready for QA to Pass

#14 Updated by sajolida over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • Target version deleted (Tails_2.2)
  • QA Check deleted (Pass)

Both "more details" and "more detail" are correct according to https://english.stackexchange.com/questions/123672/detail-or-details-read-on-for-more-detail-details. Our initial disagreement might come from our respectif native languages -- not to be releaved here :) But we're using "more details" usually in /doc so I'll stick to this one not to generate more confusion in my head.

#15 Updated by emmapeel over 3 years ago

Both "more details" and "more detail" are correct according to [...]

OK then!

Also available in: Atom PDF