Project

General

Profile

Bug #10926

Feature #7563: Update the automated test suite for Jessie ISO images

The I2P AppArmor confinement test case succeeds even when I2P is not confined

Added by intrigeri over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
01/13/2016
Due date:
% Done:

100%

Feature Branch:
test/10926-fix-apparmor-check
Type of work:
Code
Blueprint:
Starter:
Affected tool:
I2P

Description

During the 2.0~rc1 test suite run, "Scenario: I2P's AppArmor profile is in enforce mode" apparently passed, while it should have noticed that on current Tails/Jessie, I2P is not confined (#10925).

I'm assuming that this test was verified to actually work when it was first implemented and merged (a033ba69, c2c96e76), and that this is a regression on Jessie, hence the parent task + assignee I'm setting.

Associated revisions

Revision c2eeb5b4 (diff)
Added by anonym over 3 years ago

Fix typo which have broken our AppArmor checks.

This `assert` will always pass since `mode` always is either one of
two String:s. The intention was clearly `assert_equal`.

Will-fix: #10926

Revision c7d0843f
Added by anonym over 3 years ago

Merge remote-tracking branch 'origin/test/10926-fix-apparmor-check' into testing

Fix-committed: #10926

History

#1 Updated by intrigeri over 3 years ago

  • Subject changed from The I2P AppArmor confinement test case wrongly succeeds to The I2P AppArmor confinement test case succeeds even when I2P is not confined

#2 Updated by anonym over 3 years ago

  • Status changed from Confirmed to In Progress

#3 Updated by anonym over 3 years ago

  • Assignee changed from anonym to kytv
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to test/10926-fix-apparmor-check

By looking at the 'the running process "(.+)" is confined with AppArmor in (complain|enforce) mode' step I can immediately tell that it's incorrect:

assert(mode, get_apparmor_status(pid))

where mode is a String, so assert (which only triggers on false or nil) always passes. Obviously we want assert_equal... :)

So, yeah, anti-tests and all that.

#4 Updated by anonym over 3 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#5 Updated by anonym over 3 years ago

  • Assignee deleted (kytv)
  • QA Check changed from Ready for QA to Pass

The overhead of our review'n'merge process just seems ridiculous in this case. I just went a head and merged this myself.

#6 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

#7 Updated by intrigeri over 3 years ago

I just went a head and merged this myself.

ACK

Also available in: Atom PDF