Project

General

Profile

Bug #10913

Keyboard layout keyboard shortcut has changed

Added by anonym over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Internationalization
Target version:
Start date:
01/12/2016
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/11042-disable_alt+shift_shortcut
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

From Alt+Shift to Meta+Space. Well, Alt+Shift is still bound to "Modifiers-only switch to next source" which I don't even understand what it means.

However, perhaps we don't want to break all shortcuts using Alt+Shift and instead use GNOME's defaults? The rationale for using Alt+Shift is that's what's used in Windows (see ac32dd7).


Related issues

Related to Tails - Bug #11042: alt + shift switch the keyboard layout without indicating it in the keyboard layout menu Resolved 02/02/2016
Related to Tails - Feature #11048: Permanently remove the rest of the keyboard layout Confirmed 02/03/2016
Related to Tails - Feature #8294: Research how to detect if a keyboard layout is latin-based or not Confirmed 11/23/2014

Associated revisions

Revision bd49273c (diff)
Added by anonym over 3 years ago

Clean up seemingly unused code.

We have decided to stick with GNOME's default keyboard shortcut so we
do not need this non-default shortcut any more, and it doesn't seem to
work any way.

Refs: #10913

History

#1 Updated by intrigeri over 3 years ago

  • Subject changed from Kayboard layout keyboard shortcut has changed to Keyboard layout keyboard shortcut has changed

#2 Updated by intrigeri over 3 years ago

  • Type of work changed from Code to User interface design

I'm now in favour of sticking to GNOME defaults, that are documented (the relevant GNOME help page seems pretty good to me), and have less chances to interact poorly with the rest of the system configuration.

However, Super+Space does not work for me here after I chose French in the Greeter, while LeftShift+RightShift does work. Perhaps it's due to my crazy host system keyboard layout combined with Spice in the VM. I can't check on bare metal right now.

#3 Updated by intrigeri over 3 years ago

I see that we have shifts_toggle turned on, which explains at least why both shifts work for me.

#4 Updated by intrigeri over 3 years ago

I've no idea what the next steps should be (discuss here? discuss on tails-dev@? ask -ux@?). anonym, do you think it's a blocker for 2.0?

#5 Updated by sajolida over 3 years ago

Meta+Space works for me: it displays an horizontal list of keyboard layouts as Alt+Tab does for applications. RightShift+LeftShift works as well and changes to the next keyboard layout silently.

I'm also in favor of sticking to GNOME's default. In Tails Wheezy for example, Alt+Shift was changing keyboard and Alt+Shift+Tab was changing application (to the left). This often resulted in unexpected changes of keyboard layout. So personally I prefer the current version :)

#6 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to Rejected

OK, closing then. If anyone feels strongly that the current situation is wrong, please reopen and set type of work = Discuss :)

#7 Updated by anonym over 3 years ago

  • Status changed from Rejected to Confirmed
  • Assignee set to sajolida
  • QA Check set to Dev Needed
  • Feature Branch set to feature/10913-keyboard-layout-shortcut
  • Type of work changed from User interface design to End-user documentation

If so, there still this around, which doesn't seem to work, but Thou Shalt Not Bloat:

[org/gnome/libgnomekbd/keyboard]
options=['grp\tgrp:shifts_toggle', 'grp\tgrp:alt_shift_toggle']

Still, I don't think we can dismiss this topic this easily. GNOME may have objectively sane and thought through default, but they are only so for GNOME users, at best. I'd wager that the number of users familiar with Windows outnumbers the GNOME users by at least 10 times. None of them will have any help whatsoever by this shortcut unless we document it, e.g. in

wiki/src/doc/first_steps/introduction_to_gnome_and_the_tails_desktop.mdwn:Keyboard layouts

I guess I'll settle with that, but I'm pretty sure a lot of users won't see it, and will be a bit lost in Tails, expecting Shift+Alt (that they have deeply trained in their hand muscle memory) to work when they want to switch from their non-Latin layout to English for e.g. typing a URL in the browser.

#8 Updated by sajolida over 3 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#9 Updated by segfault over 3 years ago

  • Type of work changed from End-user documentation to Discuss

The alt+shift shortcut is buggy, see #11042. And it happens to me all the time that I accidentally click alt+shift or both shifts, which causes the keyboard layout to switch and it's very annoying. I put this in a script I execute on startup, so it's fine for me:

gsettings set org.gnome.desktop.input-sources xkb-options "[]"

But I saw this happen to other users who were confused by it. I think we should either remove all default keyboard layouts except for the one the user chooses in the greeter (+ english, if the chosen layout is non-latin). Or we should disable the alt+shift and both shifts shortcuts and keep only the super+space, which is a lot less frequently pressed accidentally.

#10 Updated by intrigeri over 3 years ago

  • Related to Bug #11042: alt + shift switch the keyboard layout without indicating it in the keyboard layout menu added

#11 Updated by segfault over 3 years ago

  • Related to Feature #11048: Permanently remove the rest of the keyboard layout added

#12 Updated by segfault over 3 years ago

  • Related to Feature #8294: Research how to detect if a keyboard layout is latin-based or not added

#13 Updated by muri over 3 years ago

  • Assignee changed from sajolida to segfault
  • Type of work changed from Discuss to Code

assigning to segfault and changing type of work to code, as discussed in the meeting today

#15 Updated by sajolida over 3 years ago

Dumping here what's relevant in them:

Right-now there as three keyboard shortcuts to change keyboard layout:

  • Super+Space which is provided by GNOME.
  • Shift+Shift which is custom to Tails (added in e492749). segfault will see whether we should get rid of this one as well.
  • Alt+Shift which is custom to Tails (added in 370f48c). Saying that this is the default in Windows might have been an ok argument at some point.

Seeing that alt + shift switch the keyboard layout without indicating it in the keyboard layout menu, GNOME is giving it a different meaning by default: Alt+Shift shortcut will be removed. segfault will submit a branch.

#16 Updated by anonym about 3 years ago

  • Status changed from Confirmed to Fix committed
  • Assignee deleted (segfault)
  • % Done changed from 0 to 100
  • QA Check changed from Dev Needed to Pass
  • Feature Branch changed from feature/10913-keyboard-layout-shortcut to bugfix/11042-disable_alt+shift_shortcut

Wow, so there was quite a bit of duplication with #11042. Apparently I even pushed a fix in this ticket's feature branch that does the same thing as the other branch, that now is merged. Heh. Let's just close this ticket, then.

#17 Updated by anonym about 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF