Project

General

Profile

Bug #10912

Tails Installer fails to install on USB stick that has a isohybrid dd'ed to it

Added by u over 3 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
01/12/2016
Due date:
% Done:

100%

Feature Branch:
Bug/10912-installer-fails-USB-stick-isohybrid
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installer

Description

We should try to reproduce this and investigate:


https://bugs.freedesktop.org/show_bug.cgi?id=76178
had to dd if=/dev/zero the beginning of the disk to work around it. 

I guess this means that the isobybrids we instruct people to make (as an alternative of burning a DVD) makes it so that users then will fail to install
Tails to *that* device, at a later stage, which isn't inconceivable that they
want.

if it matters, it was a pretty large (64 GiB) stick.
if it helps, the relevant part of the code is creator.py:843
that's where the exception was thrown.

3.png View (11.3 KB) kurono, 07/06/2017 04:55 PM

4.png View (21.1 KB) kurono, 07/06/2017 04:55 PM


Related issues

Related to Tails - Feature #6304: Automate the most important bits of the Icedove tests Resolved 09/26/2013
Related to Tails - Bug #14724: Make Tails Installer's isohybrid detection code robust Rejected 09/25/2017
Related to Tails - Bug #15031: Installing to a device that previously had an hybrid ISO copied to it is fragile Resolved 12/09/2017

History

#1 Updated by u over 3 years ago

  • Status changed from New to Confirmed

#2 Updated by u over 3 years ago

  • Description updated (diff)

#3 Updated by intrigeri over 3 years ago

  • Category set to Installation

#4 Updated by u almost 3 years ago

The upstream bug in udisks has not really been fixed, but a better error message has been added by upstream.

From what I understand, the problem is that when a partition is wiped, for example during an upgrade, the partition table still contains information about a iso9660 partition table.
People who experience this will have to reformat their USB stick entirely before being able to use it as a Tails stick.

I've not tested this with a real usecase, and I think that instructing users to reformat their stick should be good enough. But it very much looks like this is not a bug in tails-installer itself.

#5 Updated by intrigeri almost 3 years ago

u wrote:

I've not tested this with a real usecase, and I think that instructing users to reformat their stick should be good enough.

This would work, at least as a first iteration, and should be pretty cheap.

Another option would be that when this failure mode happens, Tails Installer detects it and wipes the partition table itself (which requires yet another sudo password prompt on Debian/Ubuntu, so let's not do that unless needed). Not sure if it's worth the effort.

#6 Updated by intrigeri almost 3 years ago

  • Related to Feature #6304: Automate the most important bits of the Icedove tests added

#7 Updated by u over 2 years ago

  • Assignee changed from u to intrigeri

Reassigning to the foundations team. I let you decide what to do about that.

#8 Updated by intrigeri over 2 years ago

  • Subject changed from Tails-Installer possible bug: udisks fails to format iso9660 usb flash drive to Tails Installer fails to install on USB stick that has a isohybrid dd'ed to it
  • Assignee changed from intrigeri to kurono
  • QA Check set to Info Needed

So I think the next steps are:

  1. reproduce the bug on Debian Stretch; I seem to remember that some changes in util-linux might have fixed that problem
  2. carefully copy the error message
  3. document the workaround (by pointing to our "reset a Tails USB stick" page) where it matters; ideally, as close as possible to the instructions that may lead to this error, i.e. probably the installation instructions from Debian and Tails; and if that doesn't work, document it on the Known Issues page

I can do at least the documentation part, but kurono: if you want to handle the first two steps, please do! Do you?

#9 Updated by kurono over 2 years ago

intrigeri wrote:

So I think the next steps are:

  1. reproduce the bug on Debian Stretch; I seem to remember that some changes in util-linux might have fixed that problem
  2. carefully copy the error message
  3. document the workaround (by pointing to our "reset a Tails USB stick" page) where it matters; ideally, as close as possible to the instructions that may lead to this error, i.e. probably the installation instructions from Debian and Tails; and if that doesn't work, document it on the Known Issues page

I can do at least the documentation part, but kurono: if you want to handle the first two steps, please do! Do you?

ok I will :)

#10 Updated by kurono about 2 years ago

  • File 3.png View added
  • File 4.png View added
  • Assignee changed from kurono to intrigeri
  • QA Check changed from Info Needed to Dev Needed

I have reproduced the error in Debian Stretch, and I got the following error on the Tails Installer:

tails-amd64-3.0.iso selected
Partitioning device /dev/sdb
GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error synchronizing after initial wipe: Timed out waiting for object
Tails installation failed!
udisks-error-quark: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error synchronizing after initial wipe: Timed out waiting for object (0)

I attach two screenshots from gnome-disk and Tails-installer.

#11 Updated by intrigeri about 2 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to sajolida
  • % Done changed from 0 to 10
  • QA Check changed from Dev Needed to Info Needed
  • Type of work changed from Test to User interface design

Thanks! I wonder if "_always_ wiping the first few MiB of the target stick before installing" would be acceptable. If it is, I think it's not more work than documenting the workaround. The only downside is that it adds a 3rd sudo password prompt on non-Tails systems. The advantage is that we avoid making our installation path more complex with "if this happens then go to that other page" (I think the IA currently tries to be linear, and avoids encouraging the reader to open additional tabs). I'd like sajolida's opinion on this one.

#12 Updated by intrigeri about 2 years ago

#13 Updated by sajolida about 2 years ago

  • Assignee changed from sajolida to kurono

Adding a 3rd root password prompt is probably better than relying on documentation.

Still, bare with me repeating that these multiple root password prompts are a UX abberation (I'm myself often confused about what's going on, if something went wrong, if this comes from Tails Installer or something else, etc.). I understand that this is the best we can have right now but please don't forget it's quite bad.

kurono: Do you want to work on the code?

#14 Updated by kurono about 2 years ago

  • Target version set to Tails_3.5
  • QA Check deleted (Info Needed)

#15 Updated by kurono almost 2 years ago

  • Feature Branch set to Bug/10912-installer-fails-USB-stick-isohybrid

#16 Updated by sajolida almost 2 years ago

#17 Updated by sajolida almost 2 years ago

  • Blocks Feature #14761: Core work 2017Q4 → 2018Q1: User experience added

#18 Updated by sajolida almost 2 years ago

  • Blocks deleted (Feature #14761: Core work 2017Q4 → 2018Q1: User experience)

#19 Updated by intrigeri almost 2 years ago

  • Related to Bug #14724: Make Tails Installer's isohybrid detection code robust added

#20 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.5 to Tails_3.6
  • Type of work changed from User interface design to Code

I'm assuming this can be fixed at the same time as #14724 (possibly a duplicate).

#21 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#22 Updated by intrigeri over 1 year ago

  • Related to Bug #15031: Installing to a device that previously had an hybrid ISO copied to it is fragile added

#23 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#24 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#25 Updated by u about 1 year ago

Not sure what is the current status of this ticket? May someone please clarify?

#26 Updated by intrigeri about 1 year ago

Since Tails Installer is going away on non-Tails system (#15292) and the proposed solution has no known problem on Tails, next step is to implement it.

#27 Updated by kurono about 1 year ago

  • Assignee changed from kurono to intrigeri
  • QA Check set to Info Needed

intrigeri wrote:

Since Tails Installer is going away on non-Tails system (#15292) and the proposed solution has no known problem on Tails, next step is to implement it.

Funny thing, I am not able to reproduce this anymore. I thought it was because of resolving #15031, but when I reverted the changes made for that ticket, I cannot reproduce the bug anyway.

#28 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to kurono

Funny thing, I am not able to reproduce this anymore. I thought it was because of resolving #15031, but when I reverted the changes made for that ticket, I cannot reproduce the bug anyway.

Interesting! Did you test this on Debian Stretch or in Tails?

#29 Updated by kurono about 1 year ago

  • Assignee changed from kurono to intrigeri

intrigeri wrote:

Funny thing, I am not able to reproduce this anymore. I thought it was because of resolving #15031, but when I reverted the changes made for that ticket, I cannot reproduce the bug anyway.

Interesting! Did you test this on Debian Stretch or in Tails?

On Debian Stretch only.

#30 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee changed from intrigeri to mercedes508

Dear help desk, do users still report such problems?

(Indeed, our Scenario: Writing a Tails isohybrid to a USB drive and booting it, then installing Tails on top of it using Tails Installer, and it still boots test case does not expose #15031 anymore AFAICT.)

#31 Updated by mercedes508 about 1 year ago

intrigeri wrote:

Dear help desk, do users still report such problems?

We haven't seen reports about this issue recently.

#32 Updated by intrigeri about 1 year ago

  • Assignee deleted (mercedes508)
  • % Done changed from 10 to 100
  • QA Check deleted (Info Needed)

Thanks! Let's keep this closed for now then. Let us know if you see new bug reports.

Also available in: Atom PDF