Project

General

Profile

Bug #10907

Feature #7563: Update the automated test suite for Jessie ISO images

usb_install.feature fails when run as part of the entire test suite

Added by intrigeri over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
01/12/2016
Due date:
% Done:

100%

Feature Branch:
test/10907-fix-badly-named-disk
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Installer

test.feature.bad (3.41 KB) intrigeri, 01/14/2016 01:50 PM

test.feature.good (2.81 KB) intrigeri, 01/14/2016 01:50 PM


Related issues

Blocks Tails - Bug #10720: Tails Installer freezes when calling system_partition.call_set_name_sync in partition_device Resolved 12/07/2015

Associated revisions

Revision 3e8ef908 (diff)
Added by anonym over 3 years ago

Fix badly named new disk.

In fact, "current" is already used as the disk name internally for our
snapshots, and this would overwrite this one, including all snapshots.

Will-fix: #10907

Revision d63d41e9 (diff)
Added by anonym over 3 years ago

Give a more thoughtful name for the disk used by our snapshots.

Hopefully a test writer would think twice before re-using this name
when creating a new disk, so we won't repeat #10907.

Refs: #10907

Revision 74537f2d
Added by intrigeri over 3 years ago

Merge remote-tracking branch 'origin/test/10907-fix-badly-named-disk' into testing

Fix-committed: #10907

History

#1 Updated by intrigeri over 3 years ago

  • Blocks Bug #10720: Tails Installer freezes when calling system_partition.call_set_name_sync in partition_device added

#2 Updated by intrigeri over 3 years ago

Running features/totem.feature features/untrusted_partitions.feature features/usb_install.feature seems to be enough to trigger the bug.

#3 Updated by intrigeri over 3 years ago

Trying these two test suite runs:

  • features/totem.feature features/untrusted_partitions.feature features/usb_install.feature
  • features/totem.feature features/usb_install.feature

#4 Updated by intrigeri over 3 years ago

  • features/totem.feature features/usb_install.feature fails
  • features/untrusted_partitions.feature features/usb_install.feature passes

#5 Updated by intrigeri over 3 years ago

OK, I've bisected it a bit more, see attachments.

#6 Updated by anonym over 3 years ago

Thanks a lot for the bisection! Looking at the diff, the issue seems obvious:

-  Scenario: Try installing Tails to a too small USB drive
-    Given I have started Tails from DVD without network and logged in
-    And I temporarily create a 2 GiB disk named "too-small-device" 
-    And I start Tails Installer in "Clone & Install" mode
-    But a suitable USB device is not found
-    When I plug USB drive "too-small-device" 
-    Then Tails Installer detects that a device is too small
-    And a suitable USB device is not found
-    When I unplug USB drive "too-small-device" 
-    And I create a 4 GiB disk named "current" 
-    And I plug USB drive "current" 
-    Then the "current" USB drive is selected

We create a drive "current" which then over-writes the disk of the same name we internally use in our snapshots. :) I'll fix this and give it a shot.

#7 Updated by anonym over 3 years ago

  • Status changed from Confirmed to In Progress

#8 Updated by anonym over 3 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to test/10907-fix-badly-named-disk

Yippie! :)

#9 Updated by intrigeri over 3 years ago

Thanks! Merged into bugfix/10720-installer-freezes-on-jenkins, we'll see how it goes on Jenkins.

#10 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#11 Updated by intrigeri over 3 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

Great, thanks!

#12 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF