Project

General

Profile

Bug #10905

Feature #5663: Return to Icedove

Override Torbirdy default settings in a more maintainable way

Added by intrigeri over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
01/12/2016
Due date:
% Done:

100%

Feature Branch:
feature/6154-secure-autoconfig-in-icedove
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

I see that we override Torbirdy default prefs by patching /usr/share/xul-ext/torbirdy/chrome/content/preferences.js with with config/chroot_local-patches/torbirdy-adjust-defaults.diff. It certainly works, and was totally good enough for the initial iterations, but this is the kind of things that's a pain to maintain: patches get fuzzy, one has to rebase them, and one has to review diffs-of-diffs.

In general, when software offers ways to configure it, let's use them, instead of patching the source code. The good news is that Torbirdy offers quite some config tools meant for downstream like us :)

E.g.

  • We can use /etc/xul-ext/torbirdy.js.
  • Upstream provides a way to define various Enigmail torification modes (see setEnigmailPrefs); I think we should add the one we want, instead of patching the source code.
  • For the proxy settings, we can either do the same (see e.g. pub.setProxyWhonix), or keep using a custom one; if the latter, it looks like we might be able to set extensions.torbirdy.custom.network.proxy.socks_port in our prefs file, instead of patching the code (untested).

Associated revisions

Revision c5c2c85d (diff)
Added by anonym over 3 years ago

Stop patching in our default into Torbirdy.

Instead:

  • We have a patch against upstream Torbirdy that we will upstream,
    which switches from using http://127.0.0.1:8118 as the Enigmail
    keyserver proxy to socks5h://127.0.0.1:9050, which is safer and will
    always work if Tor is installed.
  • Use Torbirdy's pref branch overrides in /etc/xul-ext/torbirdy.js to
    set the socks_port and keyserver URL.

Will-fix: #10905

Revision 898564ba
Added by intrigeri over 3 years ago

Merge branch 'feature/6154-secure-autoconfig-in-icedove' into devel

fix-committed: #6154, #10906, #10905, #10574, #10464

History

#1 Updated by anonym over 3 years ago

  • Assignee changed from kytv to anonym

#2 Updated by anonym over 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 30
  • Feature Branch set to feature/6154-secure-autoconfig-in-icedove

Fixed in the feature branch, but that includes bumping our Torbirdy patch of stuff we want to upstream => yes, part of this will be fixed upstream, namely:

 commit 89bf536f14872660815886f480cc88902904d4aa
Author: anonym <anonym@riseup.net>
Date:   Fri Mar 18 17:42:16 2016 +0100

    Use Tor's SOCKSPort for Enigmail's keyserver configuration.

    It's not necessarily the case that users have an HTTP proxy running on
    port 8118, and if they do it may be a non-torified Privoxy instance.

    Using the Tor SOCKSPort will always work, and be torified.

which totally makes sense to upstream to me.

#3 Updated by intrigeri over 3 years ago

What's the status here?

#4 Updated by anonym over 3 years ago

  • Assignee changed from anonym to intrigeri
  • % Done changed from 30 to 50
  • QA Check set to Ready for QA

#5 Updated by intrigeri over 3 years ago

  • % Done changed from 50 to 60

ACK the current code, will test and merge.

#6 Updated by intrigeri over 3 years ago

  • % Done changed from 60 to 90

OK, works fine.

#7 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 90 to 100
  • QA Check changed from Ready for QA to Pass

#8 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF