Project

General

Profile

Feature #10900

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

"I should be able to install a package using Synaptic" step is fragile

Added by intrigeri about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
01/12/2016
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

  Scenario: Install packages using Synaptic                                                                        # features/apt.feature:23
    When I start Synaptic                                                                                          # features/step_definitions/apt.rb:52
    And I update APT using Synaptic                                                                                # features/step_definitions/apt.rb:31
    Then I should be able to install a package using Synaptic                                                      # features/step_definitions/apt.rb:37
      FindFailed: can not find SynapticChangesAppliedPrompt.png on the screen.
      Line ?, in File ? (RuntimeError)
      features/apt.feature:26:in `Then I should be able to install a package using Synaptic'

... while the screenshot does show the "Changes applied" dialog. Timeout bump?


Related issues

Blocked by Tails - Bug #10441: Synaptic test is fragile Resolved 10/28/2015

Associated revisions

Revision 593478af (diff)
Added by intrigeri almost 4 years ago

Test suite: bump timeout in Synaptic test.

refs: #10900

History

#1 Updated by anonym almost 4 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#2 Updated by intrigeri almost 4 years ago

  • Parent task deleted (#7563)

#3 Updated by intrigeri almost 4 years ago

  • Parent task set to #10288

#4 Updated by intrigeri almost 4 years ago

  • Subject changed from "I should be able to install a package using Synaptic" step is fragile on Jessie to "I should be able to install a package using Synaptic" step is fragile

#5 Updated by anonym almost 4 years ago

  • Blocked by Bug #10441: Synaptic test is fragile added

#6 Updated by anonym almost 4 years ago

  • Assignee changed from anonym to kytv
  • Target version changed from Tails_2.2 to Tails_2.4

Given that you have #10441 alrady, I assign this one to you since it's in the same scenario.

#7 Updated by anonym almost 4 years ago

  • Assignee changed from kytv to anonym

I'll try to improve this with Chutney (#9521) and/or dogtail (#7729) depending on exactly what the problem is.

#8 Updated by anonym over 3 years ago

  • Feature Branch set to test/10441-synaptic-test-is-fragile

Let's fix everything related to synaptic in the same branch.

It's worth noting that despite the fact that synaptic runs as root dogtail can deal with it! Wow! Is this due to /usr/bin/synaptic-pkexec? It would be amazing if that is the case, and we can use that for the chroot browser and other applications run as non-amnesia in the X session.

#9 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.4 to Tails_2.6

#10 Updated by intrigeri over 3 years ago

  • Assignee changed from anonym to bertagaz
  • Target version changed from Tails_2.6 to Tails_2.5
  • QA Check set to Info Needed

Is the branch you proposed on #10441 supposed to address this problem as well? It seems that we need to fix that, before we un-fragilize this scenario.

#11 Updated by bertagaz over 3 years ago

  • Assignee changed from bertagaz to intrigeri

intrigeri wrote:

Is the branch you proposed on #10441 supposed to address this problem as well? It seems that we need to fix that, before we un-fragilize this scenario.

To be honest I've never seen this bug in my many runs (nor in Jenkins short memory). Note that it seems to have been created before Tails Jessie, might as well have disappeared this way. Maybe we can consider that the retry_for logic is helping here already?

#12 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym

To be honest I've never seen this bug in my many runs (nor in Jenkins short memory).

Cool.

Note that it seems to have been created before Tails Jessie, might as well have disappeared this way.

It initially had #7563 as its parent, so I doubt it comes from the Wheezy area. Anyway, let's try and see. As long as we're good enough at marking stuff as fragile again if needed, we should be good.

Maybe we can consider that the retry_for logic is helping here already?

Perhaps.

I'll let anonym decide.

#13 Updated by intrigeri over 3 years ago

  • Assignee changed from anonym to intrigeri

#14 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to anonym
  • Target version changed from Tails_2.5 to Tails_2.6

#15 Updated by anonym over 3 years ago

  • Status changed from Confirmed to 11
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100
  • QA Check changed from Info Needed to Pass
  • Feature Branch deleted (test/10441-synaptic-test-is-fragile)

Given that #10441 removed the @fragile tag from the only scenario using this step, let's try closing this branch, and reopen it if the problem reappears.

#16 Updated by anonym over 3 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF