Project

General

Profile

Feature #10885

Better integrate new upgrade scenarios with upgrade documentation

Added by sajolida almost 4 years ago. Updated 21 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
01/08/2016
Due date:
% Done:

0%

Feature Branch:
doc/10885-better-upgrade-doc
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Installation Assistant

Description

For the release of the installation assistant, I did a quick fix but we could:

-* Deduplicate doc/first_steps/upgrade/release_notes.inline.
  • Merge /doc/first_steps/upgrade and /upgrade to prevent clicks and possible confusion.
  • Rethink where Tails Upgrader should point to.
  • Maybe mention release notes in IA.-

Also, now that we are distributing USB images we should adapt /upgrade:

* It could be done equally from Windows and macOS than "from Linux" (as currently advertized)


Related issues

Related to Tails - Feature #16991: Cognitive walkthrough of automatic and manual upgrades Confirmed
Related to Tails - Feature #17146: Redirect /doc/first_steps/upgrade/ to /doc/upgrade Resolved
Related to Tails - Feature #17151: Point Tails Upgrader to /doc/upgrade Resolved
Blocks Tails - Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing Confirmed 01/08/2016

History

#1 Updated by u almost 2 years ago

Is this still up-to-date wrt the IA version2?

#2 Updated by sajolida almost 2 years ago

We only redesigned the download page but haven't changed much the rest of the installation instructions :)

#3 Updated by sajolida 4 months ago

  • Assignee deleted (sajolida)

#4 Updated by sajolida 4 months ago

  • Assignee set to sajolida
  • Target version set to Tails_3.16
  • Parent task set to #16711

#5 Updated by sajolida 3 months ago

  • Parent task deleted (#16711)

#6 Updated by sajolida 3 months ago

  • Blocks Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing added

#7 Updated by sajolida 3 months ago

  • Description updated (diff)
  • Target version changed from Tails_3.16 to Tails_4.0

The next people we'll rely on this heavily is for the release of 4.0.

#8 Updated by sajolida 2 months ago

  • Related to Feature #16991: Cognitive walkthrough of automatic and manual upgrades added

#9 Updated by sajolida about 1 month ago

  • Status changed from Confirmed to Needs Validation
  • Assignee changed from sajolida to cbrownstein
  • Feature Branch set to doc/10885-better-upgrade-doc

@cbrownstein: Hi! I'm in the middle of travel & holidays but this could be quite important to do before 4.0, so I'll try to work on it incrementally and see how far we can go. I thought about notifying you each time I push something new to the branch, so you could review each bit even if I'm not done with the whole thing. Maybe you could tell me up to which commit you did each of your review.

I pushed doc/10885-better-upgrade-doc (at a8ac9eb582) today that merges /upgrade and /doc/upgrade and fixes a few smallish things.

#10 Updated by sajolida about 1 month ago

  • Related to Feature #17146: Redirect /doc/first_steps/upgrade/ to /doc/upgrade added

#11 Updated by sajolida about 1 month ago

  • Related to Feature #17151: Point Tails Upgrader to /doc/upgrade added

#12 Updated by cbrownstein about 1 month ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from cbrownstein to sajolida

Looks good!

#13 Updated by sajolida about 1 month ago

  • Tracker changed from Bug to Feature
  • Description updated (diff)
  • Status changed from In Progress to Needs Validation
  • Assignee changed from sajolida to cbrownstein

Thanks for the prompt review.

I had to rewrite a8ac9eb582 because it included wiki/src/news/celebrating_10_years_of_Tails.mdwn which is a draft for an upcoming blog post that I had locally. But then I merged 50322ef981, the rewritten a8ac9eb582 into master.

So make sure to reset your local branch when fetching again. If you don't have any local change, you could do git reset --hard origin/doc/10885-better-upgrade-doc.

I also did more work to create different manual upgrade scenarios for Windows, macOS, and Linux. Seeing that upgrades are still a top complain from users I think that it's worth it.

Doing manual upgrades from a regular OS might be:

  • Faster to do download (eg. Torrent)
  • Less intrusive
  • Possible to do proactively

Even though it might be a bit less safe if the other OS is compromised.

Please review again at eef79fd46d. I won't do more work on this branch.

#14 Updated by intrigeri 29 days ago

  • Target version changed from Tails_4.0 to Tails_4.1

#15 Updated by cbrownstein 25 days ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from cbrownstein to sajolida

I pushed a single change to my branch. Otherwise looks good!

https://0xacab.org/cbrownstein/tails/commits/doc/10885-better-upgrade-doc

#16 Updated by sajolida 21 days ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

Merged, thanks!

Also available in: Atom PDF