Project

General

Profile

Feature #10851

Feature #5926: Freezable APT repository

Feature #9489: Implement packages importing and freezing

Feature #6303: Adapt our infrastructure to be able to handle tons of packages

Give lizard enough free storage to host our freezable APT repository

Added by intrigeri over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
01/04/2016
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

  • #6295#note-29 says we'll need 620G in a year.
  • We don't have that much available disk space.
  • Other stuff grows too, see #9400 has estimates. Better take this into account.

10851-storage.ods (11.3 KB) intrigeri, 01/04/2016 03:54 PM


Related issues

Related to Tails - Feature #9264: Consider buying more server hardware to run our automated test suite Resolved 12/15/2015
Related to Tails - Bug #11680: Upgrade server hardware (2017-2019 edition) In Progress 09/19/2016
Related to Tails - Feature #11806: Update server storage planning needs for at least 2017 Resolved 09/19/2016

History

#1 Updated by intrigeri over 3 years ago

  • Related to Feature #9264: Consider buying more server hardware to run our automated test suite added

#2 Updated by intrigeri over 3 years ago

  • Description updated (diff)

#3 Updated by intrigeri over 3 years ago

  • File 10851-storage.ods added
  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to bertagaz
  • % Done changed from 0 to 10

The attached spreadsheet says we need to get 300G more to host what we want to host until the end of the year => I propose buying two Samsung 850 EVO, 2.5-inc, 500GB SSDs ($160 each on Amazon).

We could maybe make it fit into 250GB SSDs, but:

  • the price difference is not that big;
  • storage density is important, and it doesn't seem worth it to "sacrifice" 2 slots for 250 mere GB;
  • the bonus space won't be wasted, and can allow us to postpone a little bit next time we have to think about this topic again.

bertagaz, can you please quickly review my figures and see if I forgot something, or got the maths wrong enough to make the conclusion bogus?

#4 Updated by intrigeri over 3 years ago

@bertagaz: ideally I would get your ACK this week. If this doesn't seem realistic, let me know what is doable, and then I'll see if I can wait.

#5 Updated by bertagaz over 3 years ago

  • Assignee changed from bertagaz to intrigeri
  • % Done changed from 10 to 20

intrigeri wrote:

bertagaz, can you please quickly review my figures and see if I forgot something, or got the maths wrong enough to make the conclusion bogus?

Had a look, compared with #9400, and it sounds fair to me. With 500G drives we have a little margin in case something grows more than expected, so it seems to be a reasonable option. Please purchase!

#6 Updated by intrigeri over 3 years ago

  • Subject changed from Give lizard enough free storage to host our freezable APT repository to Give lizard enough free storage to host our freezable APTrepository

#7 Updated by intrigeri over 3 years ago

  • Subject changed from Give lizard enough free storage to host our freezable APTrepository to Give lizard enough free storage to host our freezable APT repository

#8 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to sajolida

tl;dr: we need more storage on lizard, and the current state of things is blocking deployment of the freezable APT repo PoC. It was estimated that a pair of 500GB SSDs (2 * $160) would do the job until the end of the year. Shall we go ahead?

#9 Updated by intrigeri over 3 years ago

  • Assignee changed from sajolida to intrigeri

sajolida ack'ed the proposal on tails-dev (xmpp).

#10 Updated by intrigeri over 3 years ago

  • % Done changed from 20 to 30

Drives ordered, arrive on Thursday.

#11 Updated by intrigeri over 3 years ago

  • % Done changed from 30 to 40

Drives plugged, I'm running badblocks etc. on them.

#12 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to bertagaz
  • % Done changed from 40 to 50
  • QA Check set to Ready for QA

badblocks OK, reset drives with ATA "secure erase" (https://wiki.archlinux.org/index.php/SSD_memory_cell_clearing), set up RAID and LUKS, added to our VG, updated crypttab and mdadm.conf, updated initramfs. Gave almost all of the planned space to apt-snapshots LV:

ssh misc.lizard df -h /srv/apt-snapshots
Filesystem      Size  Used Avail Use% Mounted on
/dev/vdb        611G  327G  284G  54% /srv/apt-snapshots

So I think we're good!

bertagaz, please check I didn't forget anything :)

#13 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#14 Updated by bertagaz over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 100
  • QA Check deleted (Ready for QA)

Sorry for the lag, a quick tour lead me to think all is fine. Congrats!

#15 Updated by intrigeri over 2 years ago

  • Related to Bug #11680: Upgrade server hardware (2017-2019 edition) added

#16 Updated by intrigeri over 2 years ago

  • Related to Feature #11806: Update server storage planning needs for at least 2017 added

Also available in: Atom PDF