Project

General

Profile

Bug #10791

Feature #7584: Update documentation for Jessie

Secure deletion documentation needs to be updated

Added by goupille almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
-
Start date:
12/23/2015
Due date:
% Done:

0%

Feature Branch:
emmapeel:bugfix/10791-secure_deletion
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

it seems that https://tails.boum.org/doc/encryption_and_privacy/secure_deletion/#clean_disk_space step-by-step is not working anymore since a few monthes (maybe since Tails-wheezy). it doesn't describe correctly the behavior of Nautilus-wipe and doesn't advertise the user that an administrator password is now needed.

History

#1 Updated by emmapeel almost 4 years ago

  • Assignee set to emmapeel

I take it...

#2 Updated by emmapeel almost 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee deleted (emmapeel)
  • QA Check set to Ready for QA
  • Feature Branch set to emmapeel:bugfix/10791-secure_deletion

please review!

#3 Updated by intrigeri almost 4 years ago

  • Assignee set to sajolida

#4 Updated by sajolida over 3 years ago

  • Subject changed from secure deletion documentation needs to be updated to Secure deletion documentation needs to be updated
  • Assignee changed from sajolida to emmapeel
  • Parent task set to #7584
  • QA Check changed from Ready for QA to Dev Needed

First of all, I think that there is a rebase error on your branch as I can see the same commit having two different names. For example bf94412 in testing and 91dd84e in your branch. So I think you should reapply your changes manually on top of a fresh branch based on testing.

Then, regarding your changes. I'm realizing now that this page needs updating for Jessie, so I'm marking this as a subtask of #7584. Thanks for realizing this!

But then you're not adressing the issue raised by goupille who's saying that "doesn't advertise the user that an administrator password is now needed". I guess the very generic ticket name didn't help.

Actually, I happen to test this earlier today while working on #8063 and:

  • You don't need an administration password to wipe the available space on an external USB stick formatted in FAT for example.
  • You need an administration password to wipe the available space on the persistent storage.

So I guess this is related to the owner of the filesystem (root for persistence, amnesia for FAT) and this might have been the case already since the beginning.

Do you think we should write something about this?

#5 Updated by intrigeri over 3 years ago

So I guess this is related to the owner of the filesystem (root for persistence, amnesia for FAT) and this might have been the case already since the beginning.

IIRC there was something about filesystems that have disk space reserved for specific users or groups, such as root: cleaning it requires root privileges. And IIRC again, there was some improvement on this topic in some iteration of nautilus-wipe, that has introduced a helper that runs as root (using polkit / pkexec). But I'm not sure, so better check nautilus-wipe changelog and documentation for authoritative info.

#6 Updated by sajolida over 3 years ago

With no news in 20 days, I'll take this one over.

#7 Updated by sajolida over 3 years ago

  • Assignee changed from emmapeel to sajolida

#8 Updated by sajolida over 3 years ago

  • Priority changed from Normal to Elevated
  • Target version set to Tails_2.2

#9 Updated by sajolida over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • Target version deleted (Tails_2.2)
  • QA Check deleted (Dev Needed)

This has been solved already actually.

Also available in: Atom PDF