Project

General

Profile

Bug #10784

Dotfiles persistent feature is broken on Jessie

Added by intrigeri almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Persistence
Target version:
Start date:
12/21/2015
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/persistence-fixes-for-2.0-take1
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Symlinks point to /lib/live/mount/persistence/TailsData_unlocked/dotfiles/, but /lib/live/mount/persistence/ does not exist. We should either add a symlink to make this still work, or point to /live/persistence/ instead.


Related issues

Related to Tails - Bug #10840: Automatically test dotfiles persistence Resolved 01/03/2016

Associated revisions

Revision 59573b6f (diff)
Added by intrigeri almost 3 years ago

Repair dotfiles persistence feature by adding a symlink from /lib/live/mount/persistence to /live/persistence.

live-boot's "link" option generates symlinks to /lib/live/mount/persistence.

This is correct in the supported use case (persistence initialized at initramfs
time), because components/9990-main.sh does "Move all mountpoints below /live
into /root/lib/live/mount" after setting up persistence. Our own
config/chroot_local-includes/usr/local/sbin/live-persist, however, mounts stuff
in /live/persistence instead, so the generated links are wrong.

We have lots of Tails-specific stuff that depends on the /live/persistence path,
so I'd rather not change that, and instead I'm adding a compatibility symlinks.

Will-fix: #10784

Revision aeee0d93
Added by anonym almost 3 years ago

Merge remote-tracking branch 'origin/bugfix/persistence-fixes-for-2.0-take1' into devel

Fix-committed: #10784, #10809, #10831, #10832

History

#1 Updated by intrigeri almost 3 years ago

sajolida uses this workaround:

install -m 755 -d /lib/live/mount/persistence
install -m 755 -d /lib/live/mount/persistence/TailsData_unlocked
mount --bind /live/persistence/TailsData_unlocked /lib/live/mount/persistence/TailsData_unlocked

#2 Updated by intrigeri almost 3 years ago

  • Subject changed from Dotfiles persistent feature seems to be broken on Jessie to Dotfiles persistent feature is broken on Jessie

#3 Updated by intrigeri almost 3 years ago

Seems like this commit in live-boot updated most paths, but not all, from /lib/live/mount/persistence to /live/persistence:

commit 9555545410914f4f6cf1b1c00bb4a5b5dfe2b5cc
Author: Gaudenz Steinlin <gaudenz@debian.org>
Date:   Tue Feb 12 08:14:17 2013 +0100

    Fixing mounting of rootfs, cow and medium filesystems (Closes: #696495).

Not sure if it was on purpose. I'll try adjusting all remaining paths, and we'll see.

#4 Updated by intrigeri almost 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

Actually, I think there's nothing to be fixed in live-boot: the generated links are correct in the supported use case (persistence initialized at initramfs time), because components/9990-main.sh does "Move all mountpoints below /live into /root/lib/live/mount" after setting up persistence. Our own config/chroot_local-includes/usr/local/sbin/live-persist mounts stuff in /live/persistence instead, which is why the generated links are wrong. We have lots of Tails-specific stuff that depends on the /live/persistence path, so I think I'll just try adding a symlink to it from /lib/live/mount/persistence.

#5 Updated by intrigeri almost 3 years ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/10831-update-nopersistent-boot-parameter

#6 Updated by intrigeri almost 3 years ago

  • Feature Branch changed from bugfix/10831-update-nopersistent-boot-parameter to bugfix/persistence-fixes-for-2.0-take1

#7 Updated by intrigeri almost 3 years ago

@kytv: can you please add this bug to your list of needed regression tests, for some milestone in 2016Q2?

#8 Updated by anonym almost 3 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#9 Updated by anonym almost 3 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

I thought we already (automatically) tested this, but indeed we explicitly do not. Fearing that kytv may miss your comment, I quickly created #10840.

#10 Updated by intrigeri almost 3 years ago

  • Related to Bug #10840: Automatically test dotfiles persistence added

#11 Updated by anonym almost 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF