Project

General

Profile

Feature #10780

Upgrade KeePassX to 2.x

Added by esmmsdoi almost 4 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/20/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Test
Blueprint:
Starter:
Affected tool:
Password Manager

Description

https://www.keepassx.org/news/2015/12/533

Please update KeePassX from 0.4 to 2.0


Related issues

Related to Tails - Bug #10940: KeePassX misses characters Rejected 01/14/2016
Related to Tails - Feature #10956: Document how to migrate existing KeePassX database Rejected 01/17/2016

History

#1 Updated by intrigeri almost 4 years ago

  • Assignee set to esmmsdoi
  • Target version changed from Tails_2.0 to Tails_3.0
  • QA Check set to Info Needed

Please update KeePassX from 0.4 to 2.0

We'll have it for free in Tails 3.0 based on Debian Stretch, presumably.

Tails ships tons of packages and we don't try to ship the last version for each one. Any strong reason why we should bother upgrading KeePassX earlier?

#2 Updated by esmmsdoi almost 4 years ago

intrigeri wrote:

Any strong reason why we should bother upgrading KeePassX earlier?

Improvements and changes are important to me, but I understand that's not strong reason. Sorry that took your time and for my bad English. Thanks for your work!

#3 Updated by intrigeri almost 4 years ago

  • Status changed from New to Rejected

Thanks for following up :)

#4 Updated by intrigeri almost 4 years ago

  • Subject changed from KeePassX 2.0 has arrived to Upgrade KeePassX to 2.x
  • Assignee deleted (esmmsdoi)
  • QA Check deleted (Info Needed)
  • Starter deleted (Yes)

Redirecting a discussion that started on #10940:

If you're interested in looking into upgrading Tails 2.x to KeePassX 2.0, please let #10780 know. I can at least sponsor uploads of the backport if needed.

I am indeed interested in upgrading KeePassX sooner than in Tails 3.0.

Cool!

The only thing I see that needs to be done for this is #10956.

I hope it's indeed the only thing. We'll see :)

What do you mean with "sponsor uploads of the backport"?

I suspect that sooner or later, the keepassx 2.x package from Debian testing won't install as-is on Jessie, and we will have to backport it. I am a Debian developer and can thus upload to the official backports repository (http://backports.debian.org/). I won't maintain the backport myself though, so we would need someone else to do it, and then I'll merely upload stuff once it's ready, which is what we call "sponsoring an upload" in Debian jargon.

Let me know if I shall reopen this ticket, then.

#5 Updated by muri over 3 years ago

intrigeri wrote:

I suspect that sooner or later, the keepassx 2.x package from Debian testing won't install as-is on Jessie, and we will have to backport it. I am a Debian developer and can thus upload to the official backports repository (http://backports.debian.org/). I won't maintain the backport myself though, so we would need someone else to do it, and then I'll merely upload stuff once it's ready, which is what we call "sponsoring an upload" in Debian jargon.

fyi: keepassx 2.0.2-1~bpo8+1 is in jessie-backports now

#6 Updated by segfault over 3 years ago

  • Related to Bug #10940: KeePassX misses characters added

#7 Updated by segfault over 3 years ago

  • Status changed from Rejected to New

fyi: keepassx 2.0.2-1~bpo8+1 is in jessie-backports now

Woo, that's great! I think we should use it. It will fix #10940.
Users would have to import their 0.4 databases, but that's easy: http://keepass.info/help/v2/version.html

And anonym mentioned that in 2.0 it is currently not possible to use the global auto-type shortcut if the database is locked, it would be nice if that would be fixed:
https://www.keepassx.org/dev/issues/197

#8 Updated by stolenprivacy over 3 years ago

Psl. upgrade keepassx
For me its not possible to use an existing keepassx V 2.0.2 database in tails 2.2.
"Wrong signature".

#9 Updated by BitingBird over 3 years ago

  • Related to Feature #10956: Document how to migrate existing KeePassX database added

#10 Updated by BitingBird over 3 years ago

  • Status changed from New to Confirmed
  • Type of work changed from Debian to Test

The new version could be tested in the Tails-stretch iso when they work :)

#11 Updated by intrigeri about 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100
  • Estimated time deleted (1.00 h)

I've seen no progress wrt. upgrading in Tails 2.x, so I'll close this as done in feature/stretch for Tails 3.0. Next step is #10956, which is needed both for Tails 3.0 and in case someone wants to spend extra time on this to upgrade KeePassX in Tails 2.x.

#12 Updated by sajolida over 2 years ago

  • Affected tool set to Password Manager

Also available in: Atom PDF