Project

General

Profile

Bug #10776

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

Step "I shutdown and wait for Tails to finish wiping the memory" fails when memory wiping causes a freeze

Added by intrigeri almost 4 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
12/18/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Associated revisions

Revision 24b59bf2 (diff)
Added by intrigeri almost 4 years ago

Test suite: mark scenarios that wipe memory as fragile.

refs: #10776

Revision fc194b0d (diff)
Added by intrigeri almost 4 years ago

Revert "Test suite: mark scenarios that wipe memory as fragile."

This reverts commit 24b59bf21447968731e1583987624812af2359f7.

refs: #10776

Revision 72697482 (diff)
Added by anonym almost 3 years ago

Work around Tails freezing during memory wiping.

This should be reverted once #11786 is fixed properly.

This commit is a backport from the tails/stretch of the two
workarounds we implemented there.

Refs: #10776, #11786

History

#1 Updated by intrigeri almost 4 years ago

  • Related to Bug #9707: Jessie: System sometimes does not poweroff after memory erasure added

#2 Updated by intrigeri almost 4 years ago

Looking at the video (which is very interesting), this does not seem to be a duplicate of #9707.

#3 Updated by anonym over 3 years ago

  • Assignee changed from anonym to bertagaz

We have lost the jenkins artifacts for this one. :/ bert, can you look for this one when doing #11083? If you do not see it, reject this ticket.

#4 Updated by anonym over 3 years ago

  • Priority changed from Normal to Elevated

#5 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#6 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#7 Updated by intrigeri over 3 years ago

  • Assignee changed from bertagaz to anonym
  • Target version changed from Tails_2.4 to Tails_2.5
  • Feature Branch set to test/10776-fragile-memory_wipe

I've just merged current stable into the branch, so it'll be run by Jenkins again, and we can have fresh data.

#8 Updated by Staples over 3 years ago

I have this issue on every release only when using the late 2011 model Macbook Pro. I get no asterisks or anything. I'm prompted to remove the USB or DVD stick as usual than there is a line saying "starting new kernel" . After waiting long enough the latop beeps endlessly till I hold down the power button to shut down. I don't know why I'm using macbook to boot tails on a persistant USB anyways, from what I've read its not possible to boot on macbook pro in the first place...

#9 Updated by intrigeri over 3 years ago

I have this issue on every release only when using the late 2011 model Macbook Pro.

FYI this ticket is about a similar problem in our test suite. The problem you're reporting here is something different, and it is already documented on our known issues page.

#10 Updated by anonym over 3 years ago

  • Target version changed from Tails_2.5 to Tails_2.7

#12 Updated by intrigeri about 3 years ago

intrigeri wrote:

I've just merged current stable into the branch, so it'll be run by Jenkins again, and we can have fresh data.

I've just done it again.

#13 Updated by intrigeri about 3 years ago

  • Related to Bug #10733: Run our initramfs memory erasure hook earlier added

#14 Updated by intrigeri about 3 years ago

  • Related to deleted (Bug #10733: Run our initramfs memory erasure hook earlier)

#15 Updated by intrigeri about 3 years ago

  • Blocked by Bug #10733: Run our initramfs memory erasure hook earlier added

#16 Updated by anonym about 3 years ago

  • Assignee changed from anonym to intrigeri
  • QA Check set to Info Needed

anonym wrote:

We have lost the jenkins artifacts for this one.

This is still the case, and I in fact have no idea how this step is fragile. Looking at the code for the step I would imagine something similar to #9707 but apparently there strong reason to think it is something else according to #10776#note-3. So I am clueless. Do you remember anything about this, intrigeri?

#17 Updated by intrigeri about 3 years ago

  • Assignee changed from intrigeri to anonym

Do you remember anything about this, intrigeri?

No, sorry. I suggest you enable the branch on Jenkins again, as I did a couple times in the past already, in order to gather data… and then try to look into it before it disappears :)

#18 Updated by BitingBird about 3 years ago

  • QA Check deleted (Info Needed)

#19 Updated by anonym almost 3 years ago

  • Target version changed from Tails_2.7 to 284

Actually, we have this commit:

commit 0aaeb150e3c42f39f9f2878a4e268433193d6a7d
Merge: 71ac15e 914bbbc
Author: intrigeri <intrigeri@boum.org>
Date:   Wed Jun 1 14:03:10 2016 +0000

    Merge branch 'test/10776-fragile-memory_wipe' into bugfix/10733-run-memory-erasure-hook-earlier

so the @fragile untagging has already hit our base branches, so the data can be collected from any branch. However, due to #11786 this step (and any step that depends on Tails successfully shutting down or rebooting) is indeed fragile, but due to an actual bug in Tails. I say: let's block on #11786, and revisit this one after #11786 has been solved for a while, when we have relevant data to find any test suite-specific problem.

#20 Updated by anonym almost 3 years ago

  • Blocked by deleted (Bug #10733: Run our initramfs memory erasure hook earlier)

#21 Updated by anonym almost 3 years ago

  • Related to deleted (Bug #9707: Jessie: System sometimes does not poweroff after memory erasure)

#22 Updated by anonym almost 3 years ago

  • Blocked by Bug #11786: System often crashes during/after memory wipe since Linux 4.6 added

#23 Updated by anonym almost 3 years ago

  • Target version changed from 284 to Tails 2.10

#24 Updated by anonym almost 3 years ago

  • Status changed from Confirmed to In Progress
  • Target version changed from Tails 2.10 to Tails_2.11

Let's backport the workaround we have in feature/stretch, cd66f0ba49af773489db3a1bf15294255f681ecd, into stable and devel and revisit this at the next CI meeting.

#25 Updated by anonym almost 3 years ago

  • Target version changed from Tails_2.11 to Tails 2.10

Whoops, I have not done the backport yet.

#26 Updated by anonym almost 3 years ago

  • Subject changed from "I shutdown and wait for Tails to finish wiping the memory" step is fragile to Step "I shutdown and wait for Tails to finish wiping the memory" fails when memory wiping causes a freeze

Renaming to distinguish from #12132.

#27 Updated by anonym almost 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 0 to 100

These commits are now in stable, testing and devel:

7269748273 Work around Tails freezing during memory wiping.
41d88dcdd3 Work around another instance of #11786.
2c9f39bb00 Try to identify #11786 explicitly.

I've tested them locally, and they correctly react when #11786 appears. Let's investigate and discuss the results during the next CI meeting.

#28 Updated by anonym almost 3 years ago

  • Feature Branch deleted (test/10776-fragile-memory_wipe)

(This branch wasn't involved.)

#29 Updated by intrigeri almost 3 years ago

Great!

#30 Updated by anonym over 2 years ago

  • Blocked by deleted (Bug #11786: System often crashes during/after memory wipe since Linux 4.6)

#31 Updated by anonym over 2 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF