Project

General

Profile

Bug #10758

Bug #10754: Install Electrum 0.2.5.x in Tails/Jessie

Update electrum.feature for Electrum 2.5.x

Added by bertagaz almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Test suite
Target version:
Start date:
12/15/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/10754-electrum-2.5.4-2
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

Electrum 2.5 has a new icon, so the feature is failing due to this change. We have to upgrade features/images/GnomeApplicationsElectrum.png to fix this. The wizard and other parts of the GUI probably has some changes too that need to be taken care of.


Related issues

Related to Tails - Bug #9713: Upgrade Electrum to >= 2.5.x for compatibility with all Electrum servers Resolved 07/08/2015

Associated revisions

Revision 92eb6fad (diff)
Added by intrigeri over 3 years ago

Test suite: update Electrum icon.

refs: #10758

Revision d8d8ecd0
Added by intrigeri over 3 years ago

Merge branch 'bugfix/10754-electrum-2.5.4-2' into devel

Fix-committed: #10754, #10758

History

#1 Updated by bertagaz almost 4 years ago

  • Related to Bug #9713: Upgrade Electrum to >= 2.5.x for compatibility with all Electrum servers added

#2 Updated by anonym almost 4 years ago

  • Parent task set to #7563

#3 Updated by anonym almost 4 years ago

  • Blocked by Bug #10754: Install Electrum 0.2.5.x in Tails/Jessie added

#4 Updated by anonym almost 4 years ago

  • Subject changed from Update electrum feature with new icon to Update electrum.feature for Electrum 2.5.x
  • Description updated (diff)
  • Assignee set to anonym

#5 Updated by intrigeri over 3 years ago

  • Priority changed from Normal to High
  • Starter changed from Yes to No

#6 Updated by intrigeri over 3 years ago

  • Assignee changed from anonym to intrigeri

I'll take it because I can't merge #10754 without running its test suite (I won't test it manually), and given the ticket description, it seems that --retry-find should allow me to do it trivially.

#7 Updated by intrigeri over 3 years ago

  • Feature Branch set to bugfix/10754-electrum-2.5.4-2

#8 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 10

Updated the icon, but indeed there's more (I had missed this part of the ticket description, sorry).

#9 Updated by intrigeri over 3 years ago

  • Blocked by deleted (Bug #10754: Install Electrum 0.2.5.x in Tails/Jessie)

#10 Updated by intrigeri over 3 years ago

  • Parent task changed from #7563 to #10754

(These test cases were broken by the Electrum upgrade on Wheezy too, so it's not strictly speaking part of #7563. But IMO upgrading the software on Jessie should come with the corresponding test suite updates.)

#11 Updated by anonym over 3 years ago

  • Assignee changed from anonym to kytv
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#12 Updated by intrigeri over 3 years ago

  • Assignee changed from kytv to intrigeri

#13 Updated by intrigeri over 3 years ago

  • % Done changed from 50 to 60

Code review passes.

#14 Updated by intrigeri over 3 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 60 to 100

#15 Updated by intrigeri over 3 years ago

  • Assignee deleted (intrigeri)
  • QA Check changed from Ready for QA to Pass

#16 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF