Project

General

Profile

Feature #10734

Inconsistent titles in overviews

Added by sajolida about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
-
Start date:
12/09/2015
Due date:
% Done:

20%

Feature Branch:
web/10734-title-consistency
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Installation Assistant

Description

We currently have:

  1. "Install from windows" which lacks a capital letter on Windows
  2. "_Install from Linux_ (Red Hat, Fedora, etc.) which is not underlined consistently with others
  3. "Install from Debian" which doesn't mention Ubuntu
  4. "Mac: burn a DVD and then install" which doesn't follow the same structure as all the other ones
  5. meta title="Other Linux (Red Hat, Fedora, etc.) inconsistent with h1
  6. meta title="Debian (& Ubuntu, Linux Mint, etc.)" inconsistent with h1

It might also be worth check how much these titles are consistent with their corresponding scenarios.

Assigned to tchou who wrote this code originally.

10734-title-in-assistant-proposal.ods (47.5 KB) tchou, 12/14/2015 08:38 AM


Related issues

Blocked by Tails - Bug #10953: Document Tails Installer in Jessie backports Resolved 01/16/2016

History

#1 Updated by sajolida about 4 years ago

  • Description updated (diff)

#2 Updated by sajolida about 4 years ago

  • Description updated (diff)

#3 Updated by tchou about 4 years ago

Before commiting:

- please have a look in the spreadsheet. I try to summarize the current state of title in any steps (read it from left to right it's button => title of the next page => button...). Say me if you are ok with my proposal.

- I propose a overview or steps in the titles : it can be elsewhere too (like in the last overview compacted). The point is to keep the same title with a overview/step difference somewhere

- I think we must use consistant title styling in steps (I already did a trick to differenciate it from all the other h1 in the step pages)

- I assume that h1 and title are the same

#4 Updated by tchou about 4 years ago

  • Feature Branch set to web/10734-title-consistency

#5 Updated by tchou about 4 years ago

I pushed the "Assistant styled titles in steps" trick.

#6 Updated by sajolida about 4 years ago

  • Target version changed from Tails_1.8 to Tails_2.0

#7 Updated by sajolida about 4 years ago

  • Description updated (diff)
  • Assignee changed from sajolida to tchou
  • QA Check changed from Ready for QA to Dev Needed

Some comments on your spreadsheet:

  • "Mac (DVD method)" makes it less clear that the DVD is not the final objective. I'm afraid you're changing things here that were not problematic during the testing but without a clear benefit in my opinion.
  • You're removing "Tails" and "on a USB stick" from titles in general. I'm OK with that.
  • You're adding ": steps" in the title from steps. I don't think that's useful as the fact that we are coming from an "overview" and the content and the structure of the page make it pretty clear that these are the instructions. And this has not been pointing out as problematic during the tests.
  • I'm not convinced by "Install from Debian or Ubuntu (command line and gnupg method)" which is not really shorter than "Install from Debian or Ubuntu using the command line and GnuPG"

Then regarding your branch. I'm really against duplicating more [[!meta title into <h1>. The only reason to do so in the router and the overview was to be able to put some parts of the titles in bold. That's a minor benefit that I consented to have to the price of information duplication on some pages. This very ticket proves that we already failed at maintaining consistent titles across this duplication (see my points 5 and 6). I also understand how highlighting words my help sometimes, but I don't think that's any useful in the title of the steps where people already went through two other pages that told them what the scenario was about (the router and the overview).

If you want to use the same CSS styling in the steps as in the router and overview that's fine with me, but then please do this using the span.title selector.

#8 Updated by sajolida about 4 years ago

  • Parent task changed from #8590 to #8592

#9 Updated by tchou about 4 years ago

  • Assignee changed from tchou to sajolida
  • QA Check changed from Dev Needed to Ready for QA

I did a first implementation, even if we have stuffs to discuss.

sajolida wrote:

Some comments on your spreadsheet:

  • "Mac (DVD method)" makes it less clear that the DVD is not the final objective. I'm afraid you're changing things here that were not problematic during the testing but without a clear benefit in my opinion.

There is something I don't get. You say me that the previous version is not good because it "doesn't follow the same structure as all the other ones" and now that I change it trying to find and follow a structure, you say "I'm afraid you're changing things here that were not problematic". What do we do ?

  • You're removing "Tails" and "on a USB stick" from titles in general. I'm OK with that.

ok.

  • You're adding ": steps" in the title from steps. I don't think that's useful as the fact that we are coming from an "overview" and the content and the structure of the page make it pretty clear that these are the instructions. And this has not been pointing out as problematic during the tests.

It as been pointed that some people at the overview where thinking that it was the step, so I think it's good to have a difference between the 2 pages titles (or sub-titles). I think this question will be solved in the overview styling branch, but regarding titles, I used the shema:
- "the name of the scenario: overview" in the <title>
- and "the name of the scenario" in the <h1>.

  • I'm not convinced by "Install from Debian or Ubuntu (command line and gnupg method)" which is not really shorter than "Install from Debian or Ubuntu using the command line and GnuPG"

I did not felt that the point was not shorten things. Regarding your comments in the description, I understood it was more about consistency.

#10 Updated by sajolida about 4 years ago

  • Blocked by Bug #10953: Document Tails Installer in Jessie backports added

#11 Updated by sajolida about 4 years ago

  • Priority changed from Normal to Elevated
  • Target version changed from Tails_2.0 to Tails_2.2

Postponing and raising priority.

#12 Updated by sajolida almost 4 years ago

  • Parent task deleted (#8592)

#13 Updated by sajolida almost 4 years ago

  • Target version deleted (Tails_2.2)

#14 Updated by sajolida almost 4 years ago

  • Assignee changed from sajolida to tchou
  • Priority changed from Elevated to Normal

I pushed a bunch more commits with 41e772b..c62f902. Tell if I can merge.

#16 Updated by BitingBird over 3 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 20

#17 Updated by tchou over 3 years ago

  • Assignee changed from tchou to sajolida
  • QA Check deleted (Ready for QA)

ok

#18 Updated by sajolida over 3 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

Also available in: Atom PDF