Project

General

Profile

Bug #10725

Feature #5288: Run the test suite automatically on autobuilt ISOs

Test jobs sometimes hang at cucumber report parsing step

Added by bertagaz over 3 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
12/07/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

We've noticed first time in test_Tails_ISO_feature-jessie #82 and test_Tails_ISO_stable #49 that test jobs sometimes hang at the cucumber report parsing step. It may be the first time it happens, it may be because we just tagged a lot of scenarios as @fragile and they are the first runs since then.

History

#1 Updated by bertagaz over 3 years ago

  • Subject changed from Test jobs sometimes hangs at cucumber report parsing step to Test jobs sometimes hang at cucumber report parsing step

Note that the /tmp/TailsToaster directory was empty when I aborted manually this builds.

#2 Updated by intrigeri over 3 years ago

https://jenkins.tails.boum.org/job/test_Tails_ISO_feature-jessie/82/console just failed with:

20:23:53 Archiving artifacts
20:23:54 [Cucumber Tests] Parsing results.
20:23:54 [Cucumber Tests] parsing tailstester.json

21:32:28 ERROR: Publisher org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberTestResultArchiver aborted due to exception
21:32:28 java.lang.InterruptedException
21:32:28     at java.lang.Object.wait(Native Method)
21:32:28     at java.lang.Object.wait(Object.java:503)
21:32:28     at hudson.model.Run$RunExecution$CheckpointSet.waitForCheckPoint(Run.java:1557)
21:32:28     at hudson.model.Run.waitForCheckpoint(Run.java:1511)
21:32:28     at hudson.model.CheckPoint.block(CheckPoint.java:145)
21:32:28     at org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberTestResultArchiver.perform(CucumberTestResultArchiver.java:101)
21:32:28     at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
21:32:28     at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:756)
21:32:28     at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:720)
21:32:28     at hudson.model.Build$BuildExecution.post2(Build.java:182)
21:32:28     at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:669)
21:32:28     at hudson.model.Run.execute(Run.java:1731)
21:32:28     at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
21:32:28     at hudson.model.ResourceController.execute(ResourceController.java:88)
21:32:28     at hudson.model.Executor.run(Executor.java:232)

21:32:30 Sending e-mails to: anonym@riseup.net killyourtv@i2pmail.org
21:32:30 
21:32:30 Deleting project workspace... 

21:32:31 done
21:32:31 
21:32:31 Finished: FAILURE

#3 Updated by bertagaz over 3 years ago

intrigeri wrote:

https://jenkins.tails.boum.org/job/test_Tails_ISO_feature-jessie/82/console just failed with:

Yeah, I aborted it:

21:32:28 ERROR: Publisher org.jenkinsci.plugins.cucumber.jsontestsupport.CucumberTestResultArchiver aborted due to exception
21:32:28 java.lang.InterruptedException

Also note that no remaining processes of the test suite were left running on the isotesters used by this job when I aborted the jobs.

#4 Updated by bertagaz over 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from bertagaz to intrigeri
  • Target version changed from Tails_1.8 to Tails_2.0
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

Never seen that again. It happened after/while we worked on a change in Jenkins, so I think that's why.

#5 Updated by intrigeri over 3 years ago

  • Assignee changed from intrigeri to bertagaz
  • QA Check changed from Ready for QA to Info Needed

bertagaz wrote:

It happened after/while we worked on a change in Jenkins, so I think that's why.

I can't remember that => just curious: what change was it?

(Assuming you're not referring to the changes in test suite scenarios themselves, that should not impact what this ticket is about, otherwise we have a way more serious problem :)

Anyway, I'm fine with rejecting this ticket. We can still reopen it if we see such problems again.

#6 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#7 Updated by bertagaz over 3 years ago

  • Status changed from In Progress to Rejected
  • Assignee deleted (bertagaz)
  • % Done changed from 50 to 0
  • QA Check deleted (Info Needed)

intrigeri wrote:

bertagaz wrote:

It happened after/while we worked on a change in Jenkins, so I think that's why.

I can't remember that => just curious: what change was it?

Hmmm, I've searched in the history of our jenkins-job repo and in our puppet manifests for changes that happened at quite the same time than the test job mentioned in the first note, but couldn't find anything, sorry. Maybe I was just confused.

Anyway, I'm fine with rejecting this ticket. We can still reopen it if we see such problems again.

I've done a search in the test logs history just to be sure, but couldn't find any new occurrence of this bug. The only moment where the plugin error out is when someone aborts the build manually, so I'm rejecting this bug as you acked.

Also available in: Atom PDF