Project

General

Profile

Bug #10708

Have a mapping between parts of Tails and their programming languages

Added by sajolida almost 4 years ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/03/2015
Due date:
% Done:

100%

Feature Branch:
https://salsa.debian.org/tails-team/tails/merge_requests/37#note_108671
Type of work:
Contributors documentation
Blueprint:
Starter:
Affected tool:

Description

While having a look at http://whatcanidoformozilla.org/ on tails-project we end up agreeing that we are missing a mapping between the subprojects of Tails and their programming languages. In other word, an easy for new contributors to match their programming skills with tickets they can solve.

It should be maintanable but not necessarily depend on a fancy webapp like Mozilla does.

https://mailman.boum.org/pipermail/tails-project/2015-November/000368.html


Related issues

Related to Tails - Feature #10179: Document mentors for new contributors Resolved 09/11/2015
Related to Tails - Bug #14516: Lower technical requirements for new contributors Confirmed 08/30/2017

Associated revisions

Revision b50d22b7 (diff)
Added by intrigeri about 1 month ago

Document the programming language for each Tails component (refs: #10708)

We've been wanting to do something better for 4 years, and failed to so far.
So let's do the simplest thing that can help here.

Revision bf7195c0 (diff)
Added by intrigeri about 1 month ago

Link from the new "code" contributor page to the list of components & their programming language (refs: #10708)

Revision e8895194
Added by segfault about 1 month ago

Merge branch 'test/17029+17027+17028+16931+force-all-tests' into devel

Closes: #17029, #17027, #17028, #16931, #16617, #17030, #10708, #16465
Closes: #13469

History

#1 Updated by sajolida almost 4 years ago

  • Subject changed from Have a mappings between parts of Tails and their programming languages to Have a mapping between parts of Tails and their programming languages

#2 Updated by sajolida almost 4 years ago

  • Related to Feature #10179: Document mentors for new contributors added

#3 Updated by emmapeel over 3 years ago

  • Assignee set to sajolida
  • QA Check set to Info Needed

Can it be a subsection of https://tails.boum.org/contribute/how/ ?

Or maybe is better to work on top of u's mentors contribution (#10179)?

#4 Updated by sajolida over 3 years ago

  • Assignee changed from sajolida to emmapeel
  • QA Check deleted (Info Needed)

Since this is about programming languages only, maybe this mapping should go in https://tails.boum.org/contribute/how/code/ ("Developer and Maintainer"). If we end up doing what I suggested in #10179#note-12, then this mapping could serve as the list of mentors for the "Developer and Maintainer" section.

Regarding #10179, feel free to join the discussion. I've been too busy to disentangle this last month but maybe having your opinion would help moving things forward. Especially if you're ready to work on this ticket which I think is related.

#5 Updated by emmapeel over 2 years ago

  • Assignee deleted (emmapeel)

Does not look like I will do it in the close future... I deassign myself to see if someody else takes it.

#6 Updated by u about 1 year ago

  • Related to Bug #14516: Lower technical requirements for new contributors added

#7 Updated by intrigeri about 1 month ago

  • Status changed from Confirmed to In Progress

#8 Updated by intrigeri about 1 month ago

  • Assignee set to intrigeri
  • Feature Branch set to test/17029+17027+17028+16931+force-all-tests

I've done something. It's not perfect and does not reorganize the contents as well as we would love to, but seriously, this has been open for 4 years so at this point, even this imperfect solution feels much better than the status quo.

#9 Updated by intrigeri about 1 month ago

  • Status changed from In Progress to Needs Validation
  • Assignee deleted (intrigeri)
  • Target version set to Tails_4.0
  • Feature Branch changed from test/17029+17027+17028+16931+force-all-tests to https://salsa.debian.org/tails-team/tails/merge_requests/37#note_108671

#10 Updated by segfault about 1 month ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF