Project

General

Profile

Feature #10643

Feature #8580: Installation Assistant

Feature #8592: Release the installation assistant

Have a responsive CSS in Tails Installation Assistant

Added by tchou about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/24/2015
Due date:
% Done:

0%

QA Check:
Feature Branch:
web/10643-responsive
Type of work:
Website
Blueprint:
Starter:
Affected tool:
Installation Assistant

image in flow.png View (90.4 KB) sajolida, 12/17/2015 07:47 AM

ugly opening.png View (76.7 KB) sajolida, 12/17/2015 07:48 AM


Related issues

Related to Tails - Feature #10641: Have mechanism for troubleshooting (big and small) and improve affordance Resolved 11/24/2015

Associated revisions

Revision 94f679c9
Added by sajolida almost 3 years ago

Merge branch 'web/10643-responsive' (Closes: #10643)

Revision 476aac19
Added by sajolida almost 3 years ago

Merge remote-tracking branch 'origin/web/10643-responsive' (Closes: #10643, #10641)

Conflicts:
wiki/src/install/inc/stylesheets/dave.css

History

#1 Updated by sajolida about 3 years ago

  • Parent task set to #8590

#2 Updated by tchou about 3 years ago

  • Assignee changed from tchou to sajolida
  • QA Check set to Ready for QA
  • Feature Branch set to web/10643-responsive

See comment, espacialy 8f9c80fdc1c60c0e478a015e7f544141eb83e5ef on viewports and ikiwiki layout.

#3 Updated by sajolida about 3 years ago

  • Target version changed from Tails_1.8 to Tails_2.0

#4 Updated by sajolida about 3 years ago

  • I can't see what meta viewport does but I read
    https://developer.mozilla.org/en-US/docs/Mozilla/Mobile/Viewport_meta_tag
    and understand why we need it. Regarding how to add this to our
    website, I see in the ikiwiki changelog (3.20150107) that they
    already added this directive "somewhere". Could you check when and
    how they did that and see if we should maybe synchronize our
    template (templates/page.tmpl) with theirs. Don't hesitate to ask
    for help but it this that's initial part of your work.
  • I disagree with .step-image { display: none; }. If we believe
    these images are useful, then they should be useful for
    everybody. I thought you would do something to bring them back in
    the vertical flow. See attachment. Did you try this?
  • The opening screen is pretty ugly. See attachment.

#5 Updated by tchou almost 3 years ago

sajolida wrote:

  • I can't see what meta viewport does but I read
    https://developer.mozilla.org/en-US/docs/Mozilla/Mobile/Viewport_meta_tag
    and understand why we need it. Regarding how to add this to our
    website, I see in the ikiwiki changelog (3.20150107) that they
    already added this directive "somewhere". Could you check when and
    how they did that and see if we should maybe synchronize our
    template (templates/page.tmpl) with theirs. Don't hesitate to ask
    for help but it this that's initial part of your work.

I don't understand the "it this that's initial", but I'm ok to do it.

  • I disagree with .step-image { display: none; }. If we believe
    these images are useful, then they should be useful for
    everybody. I thought you would do something to bring them back in
    the vertical flow. See attachment. Did you try this?

I tried. I felt it was a lot of space and information in the flow.
But I don't have strong opinion.

  • The opening screen is pretty ugly. See attachment.

I focuses on the steps part, while the user ar not suppos to do the full flow with a tablet or a smarphone (but it's nice to have it, just less elevated I think).

#6 Updated by tchou almost 3 years ago

  • Assignee changed from tchou to sajolida
  • QA Check changed from Dev Needed to Ready for QA

tchou wrote:

sajolida wrote:

  • I can't see what meta viewport does but I read
    https://developer.mozilla.org/en-US/docs/Mozilla/Mobile/Viewport_meta_tag
    and understand why we need it. Regarding how to add this to our
    website, I see in the ikiwiki changelog (3.20150107) that they
    already added this directive "somewhere". Could you check when and
    how they did that and see if we should maybe synchronize our
    template (templates/page.tmpl) with theirs. Don't hesitate to ask
    for help but it this that's initial part of your work.

I don't understand the "it this that's initial", but I'm ok to do it.

So, some fun. Maybe I miss something, but here is what I understand:

- responsiveness directive come in ikiwiki 3.20150107. In the template there is a <TMPL_IF RESPONSIVE_LAYOUT><meta name="viewport" content="width=device-width, initial-scale=1" /></TMPL_IF> directive

- the Tails default template is synchronised with upstream (or at least a not so old version) and this directive is in our template.(67c1b4cd4548f623fcd3eb96a97f2408034b3236)

- in the production website the directive is interpreted, because I imagine an ikiwiki >= at 3.20150107 is installed

- but we, localy, have older ones, that's why it wasn't working:

   responsive:     3.20150107
   wheezy:         3.20120629.2
   wheezy-backport 3.20130904.1~bpo70+1
   jessy           3.20141016.2

So for the production on tails.boum.org we don't have to do anything. But if we want to use this directive localy, we will have to find some trick.

Am I right ?

  • I disagree with .step-image { display: none; }. If we believe
    these images are useful, then they should be useful for
    everybody. I thought you would do something to bring them back in
    the vertical flow. See attachment. Did you try this?

I tried. I felt it was a lot of space and information in the flow.
But I don't have strong opinion.

I display it in c5aa51925443f4bd5b456c6c40bb1adc6cb3551f.
Keep it or not, like you want.

  • The opening screen is pretty ugly. See attachment.

I focuses on the steps part, while the user ar not supposed to do the full flow with a tablet or a smarphone (but it's nice to have it, just less elevated I think).

I suggest to do this last point in january, and merge the other things.

#7 Updated by intrigeri almost 3 years ago

So for the production on tails.boum.org we don't have to do anything. But if we want to use this directive localy, we will have to find some trick.

Data point: installing ikiwiki from Debian testing just works most of the time (ikiwiki rarely depends on stuff that is not in stable).

#8 Updated by sajolida almost 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

#9 Updated by sajolida almost 3 years ago

  • Status changed from Resolved to Confirmed
  • Assignee changed from sajolida to tchou
  • % Done changed from 100 to 0
  • Parent task changed from #8590 to #8592
  • QA Check changed from Ready for QA to Dev Needed

Thanks for investigating the ikiwiki-related stuff. It's good to know
we already support this thanks to Naar who synchronized our template
with upsteam some time ago :)

So, I removed with commit 6a92823 the viewport directive you added
previously and documented the need for ikiwiki >= 3.20150107.

I also fixed some margins with 3ead02d.

So done a first merge, but leaving this ticket open to solve the rest and reassign as a child of #8592, the final release.

#10 Updated by tchou almost 3 years ago

  • Assignee changed from tchou to sajolida
  • QA Check changed from Dev Needed to Ready for QA

#11 Updated by sajolida almost 3 years ago

  • Assignee changed from sajolida to tchou

Nice!

I've added a bunch of commits on top of yours so have a look at 3a09654..7e2d347 and then I think we can merge.

#12 Updated by sajolida almost 3 years ago

  • Related to Feature #10641: Have mechanism for troubleshooting (big and small) and improve affordance added

#13 Updated by tchou almost 3 years ago

  • Assignee changed from tchou to sajolida
  • QA Check changed from Ready for QA to Pass

#14 Updated by sajolida almost 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

#15 Updated by sajolida almost 3 years ago

  • Assignee deleted (sajolida)
  • % Done changed from 100 to 0
  • QA Check deleted (Pass)

Also available in: Atom PDF