Project

General

Profile

Bug #10591

CUPS fails to start with read-only persistent configuration on Jessie

Added by intrigeri over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
11/20/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Nov 20 09:02:28 amnesia kernel: audit: type=1400 audit(1448010148.604:31): apparmor="DENIED" operation="open" profile="/usr/sbin/cupsd" name="/live/persistence/TailsData_unlocked/cups-configuration/cups-files.conf" pid=4657 comm="cupsd" requested_mask="r" denied_mask="r" fsuid=0 ouid=0

Related issues

Blocks Tails - Feature #7563: Update the automated test suite for Jessie ISO images Resolved 11/26/2014 01/15/2016

Associated revisions

Revision 1863d4a3 (diff)
Added by intrigeri over 3 years ago

Make AppArmor profile for cupsd work in read-only persistence mode.

Closes: #10591

History

#1 Updated by intrigeri over 3 years ago

  • Blocks Feature #7563: Update the automated test suite for Jessie ISO images added

#2 Updated by intrigeri over 3 years ago

  • Priority changed from Elevated to High

anonym, it's the root cause of the failure of Scenario: Writing files first to a read/write-enabled persistent partition, and then to a read-only-enabled persistent partition # features/persistence.feature:20.

#3 Updated by intrigeri over 3 years ago

  • Subject changed from CUPS fails to start with persistent configuration on Jessie to CUPS fails to start with read-only persistent configuration on Jessie

#4 Updated by intrigeri over 3 years ago

We've decided that read-only persistence support is best effort (#8423) but here it would probably take me longer to adjust the test suite to this bug, than to actually fix it.

#5 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

#6 Updated by intrigeri over 3 years ago

  • Assignee deleted (intrigeri)

Also available in: Atom PDF