Project

General

Profile

Feature #10532

Feature #7544: Have a multiplatform Installer

Feature #8550: Make Tails Installer work on Windows

Feature #8558: Study feasibility of porting Tails Installer to Windows

Make sure tails-installer is not included in Ubuntu 16.04 LTS (Xenial)

Added by u about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Installation
Target version:
Start date:
11/10/2015
Due date:
% Done:

50%

Feature Branch:
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:
Installer

Description

Because we would like to distribute our package through the PPA, but Ubuntu will probably also fetch the package from Debian.


Related issues

Related to Tails - Bug #11004: Check the status of Tails Installer in Ubuntu 16.04 LTS Resolved 06/04/2016

History

#1 Updated by intrigeri about 4 years ago

  • Category set to Installation
  • Status changed from New to Confirmed
  • Target version set to Tails_1.8
  • Parent task set to #8549

#3 Updated by intrigeri about 4 years ago

  • Subject changed from Check how automatic fetching of Debian packages works in Ubuntu to Check how automatic synchronization of Debian packages works in Ubuntu

They call it a "sync". Start there:

We probably want them to blacklist tails-installer.

#4 Updated by intrigeri almost 4 years ago

  • Target version changed from Tails_1.8 to Tails_2.0

(The package won't be in sid by 1.8 release date, and in January we'll still have plenty of time to get it out of Ubuntu in time for 16.04 in case it has been sync'ed already => this can wait a bit :)

#5 Updated by intrigeri almost 4 years ago

FWIW it's been pulled into xenial already.

#6 Updated by hans almost 4 years ago

just an FYI, since I do a lot with Debian around Ubuntu releases. Here's the process as I understand it:

  • When an Ubuntu release is in dev mode, all changes to Debian/unstable are automatically imported, except where there are custom Ubuntu versions of the package
  • between the DebianImportFreeze date and the final release, the automatic Debian/unstable import stops, and changes must be manually requested to be imported
  • the automatic importing resumes when the next Ubuntu release is opened

#7 Updated by sajolida almost 4 years ago

  • Related to Bug #11004: Check the status of Tails Installer in Ubuntu 16.04 LTS added

#8 Updated by u almost 4 years ago

So from what I see now with tails-installer is that Ubuntu has fetched automatically the latest version for Xenial, but not for Wily. That means, maybe we do not need to do blacklisting after all. We can upload packages to the PPA, and if ever there is a newer automatic version, people can install it. Otherwise, they would get it from the PPA.

Does this sound logical?

#9 Updated by u almost 4 years ago

  • QA Check set to Info Needed

#10 Updated by sajolida almost 4 years ago

I'm not sure to understand, so I'm rephrasing to clarify what this means to me.

  • Wily is out already so yes, we won't get tails-installer in Wily-universe automatically.
  • The DebianImportFreeze is on February 18, so whatever version of tails-installer will be in Debian/unstable on this date would be imported by default in Xenial-universe unless we blacklist it. I'm glad we're on time to take this decision!

So, if we don't blacklist it to prevent its import to Xenial-universe, then could we:

  • Instruct people running Xenial to use the version in Xenial-universe once Xenial is out.
  • Continue to instruct people with Wily to use the version in Wily-PPA even once Xenial is out. Wily we be supported officially until July 2016 (9 months from October 2015), after that we can drop this special case.
  • Whenever we publish a newer version of tails-installer after February 18 it won't be in Xenial-universe automatically so we should decide whether it's better to instruct people, depending on what's fixed in the new version, to:
    • Use the old version in Xenial-universe which is simpler for them but might have problems (we're probably releasing a new version for some reason).
    • Use the new version in Xenial-PPA which is more complicated. See the bug in adding a PPA documented on /install/debian/usb/.

Does this make sense?

#11 Updated by intrigeri almost 4 years ago

FTR, it has been imported a while ago:

$ rmadison -u ubuntu tails-installer
tails-installer | 4.4.7+dfsg-1 | xenial/universe | source, amd64, i386

So I guess the question becomes: how do we have it removed?

So, if we don't blacklist it to prevent its import to Xenial-universe, then could we:

Unless there are new elements that make it worth revisiting the decision we made, I'd rather not put this option back on the table now. I'm all for revisiting it for Stretch+1 and the Ubuntu LTS after 16.04, though; we'll have more information then. If someone wants to discuss it further, let's please do it in a more suitable place than this ticket.

#12 Updated by u almost 4 years ago

Hi, sorry for restarting the discussion then.

Actually, because it was imported automatically to Xenial, I was wondering if we should not actually let it be like this and not do blacklisting. My argument in favour of this is that the code of the installer will probably not change that much in the near future - and this would allow people to install it without bothering much. But my assumption might be very wrong.

Then we still would want people to use the PPA instead, because it might have a newer version.

But I understand the idea, and we can also do as we discussed first and see for a later version.

Note to self:
https://wiki.ubuntu.com/ArchiveAdministration#Blacklisting -> the process seems to be to bzr checkout and add a commit there with an explanation for the blacklist but i believe this is to be done only by a ubuntu dev.

#13 Updated by intrigeri almost 4 years ago

Actually, because it was imported automatically to Xenial, I was wondering if we should not actually let it be like this and not do blacklisting. My argument in favour of this is that the code of the installer will probably not change that much in the near future

I agree it won't change that much. I'm under the impression, however, that it can still potentially change enough to put us in an awkward situation where we have to deal with users running various versions of Tails Installer, some of them having this or that feature, some of them not. From the top of my head, the UEFI support seems to be a good example of this kind of changes. I'm personally not going to commit to spend time dealing with that kind of problems, but if others want (on the packaging, doc and support sides), yay, I'm excited to see it happen!

and this would allow people to install it without bothering much.

I agree this makes the "let's get Tails Installer into Debian and Ubuntu releases" option very appealing.

#14 Updated by sajolida almost 4 years ago

Sorry for the noise :(

#15 Updated by intrigeri almost 4 years ago

  • Priority changed from Normal to High
  • Target version changed from Tails_2.0 to Tails_2.2

We're approaching the last minute to remove the package from Xenial, so bumping priority and setting an up-to-date target version. Please let me know if you need help (and what for, exactly).

#16 Updated by u almost 4 years ago

intrigeri wrote:

We're approaching the last minute to remove the package from Xenial, so bumping priority and setting an up-to-date target version. Please let me know if you need help (and what for, exactly).

I know I'm very late on this. I've just sent a request to the ubuntu-archive maintainers with a request for the removal and told them that I'll also open a bug report for it now. However, it's not properly documented how to do such a request anywhere. That's why...

#18 Updated by intrigeri almost 4 years ago

Great to see this moving forward, and you learning bits of Ubuntu processes that may be useful again in the future; thanks! :)

#19 Updated by intrigeri over 3 years ago

What's the status on this? Judging from the bug report on Launchpad only: I suggest poking people on the bug + IRC. If that's not enough, let me know and I'll try to ping some Ubuntu people who might remember me, but it's better if I don't have to ask them to do something in some kind of emergency :)

#20 Updated by u over 3 years ago

  • Assignee changed from u to intrigeri

I pinged once before, now i did it again. I thought the deadline was already on the 18th of february, so I think it's not a bad idea to ping people personally if you can do such a thing.

#21 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#22 Updated by intrigeri over 3 years ago

  • Subject changed from Check how automatic synchronization of Debian packages works in Ubuntu to Make sure tails-installer is not included in Ubuntu 16.04 LTS (Xenial)
  • Assignee changed from intrigeri to u
  • % Done changed from 0 to 50
  • QA Check deleted (Info Needed)
  • Type of work changed from Research to Communicate

#23 Updated by u over 3 years ago

  • Status changed from Confirmed to Resolved

https://bugs.launchpad.net/ubuntu/+bug/1544207/comments/2 A fix has been release to handle this. I think we can close this ticket now.

#24 Updated by intrigeri over 3 years ago

I think we can close this ticket now.

Confirmed! rmadison -u ubuntu tails-installer now returns an empty output.

Also available in: Atom PDF