Project

General

Profile

Bug #10440

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

Time syncing scenarios are fragile

Added by kytv almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
10/28/2015
Due date:
% Done:

100%

Feature Branch:
test/10497-tor-bootstrap-is-fragile
Type of work:
Wait
Blueprint:
Starter:
Affected tool:

Related issues

Blocked by Tails - Feature #9521: Use the chutney Tor network simulator in our test suite Resolved 04/15/2016
Blocked by Tails - Bug #10497: wait_until_tor_is_working helper is fragile Resolved 11/06/2015

Associated revisions

Revision ffba63de (diff)
Added by anonym over 3 years ago

Remove most scenarios testing "tordate".

"tordate" just isn't working well in Tails, so we shouldn't expect the
tests to actually work all of the time. The two tests we keep will at
least ensure that "tordate" doesn't break the (presumably) most common
situation, where the hardware clock is correct.

Refs: #10440

History

#1 Updated by kytv almost 4 years ago

  • Parent task set to #10288

#2 Updated by kytv almost 4 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch set to kytv/test/10440-time-syncing-tests-are-fragile

#4 Updated by intrigeri almost 4 years ago

  • Assignee set to anonym

#5 Updated by anonym almost 4 years ago

  • Target version set to Tails_2.3

#6 Updated by anonym over 3 years ago

  • Target version deleted (Tails_2.3)

#7 Updated by anonym over 3 years ago

  • Target version set to Tails_2.4
  • % Done changed from 0 to 50
  • QA Check set to Dev Needed
  • Feature Branch changed from kytv/test/10440-time-syncing-tests-are-fragile to test/9521-chutney
  • Type of work changed from Code to Wait

Since "tordate", the actual Tails feature, is essentially broken, let's kill these scenarios. Let's spend all energy in this category on fixing #5774 (Robust time syncing).

#8 Updated by anonym over 3 years ago

  • Blocked by Feature #9521: Use the chutney Tor network simulator in our test suite added

#9 Updated by anonym over 3 years ago

(Details for this decision: #9521#note-46)

#11 Updated by intrigeri over 3 years ago

  • Feature Branch changed from test/9521-chutney to test/10497-tor-bootstrap-is-fragile

test/10497-tor-bootstrap-is-fragile drops the fragile flags on those tests, so once it's merged, we can mark this ticket as fix committed :)

#12 Updated by intrigeri over 3 years ago

  • Blocked by Bug #10497: wait_until_tor_is_working helper is fragile added

#13 Updated by intrigeri over 3 years ago

  • Subject changed from Time syncing tests are fragile to Time syncing scenarios are fragile

#14 Updated by anonym over 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Dev Needed to Pass

intrigeri wrote:

test/10497-tor-bootstrap-is-fragile drops the fragile flags on those tests, so once it's merged, we can mark this ticket as fix committed :)

Doing so.

#15 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF