Project

General

Profile

Feature #10438

Feature #11406: Implement automatic l10n screenshots for wiki

Research if we could do automatic screenshots for wiki l10n

Added by u almost 4 years ago. Updated about 1 year ago.

Status:
Confirmed
Priority:
Low
Assignee:
-
Category:
Internationalization
Target version:
-
Start date:
10/28/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

as suggested on the tails-l10n mailinglist we could check if there is some way to automate the screenshot stuff.
something like: choose language in greeter, login, start screenshot script which starts one program after the other and makes screenshots...

History

#1 Updated by u almost 4 years ago

  • Assignee set to muri

Assigning to you because you proposed it, but if you think it's not your cup of tea, feel free to unassign yourself :)

#2 Updated by spriver almost 4 years ago

Thanks for creating this ticket. Another question would be how to handle screenshots where some external pictures are being used (e.g. on this page https://tails.boum.org/doc/about/warning/index.de.html the picture on how Tor works and the picture about MITM attacks). Any ideas? (ofc we could start also translating the stuff on the screenshots and edit them)

#3 Updated by elouann almost 4 years ago

spriver wrote:

Thanks for creating this ticket. Another question would be how to handle screenshots where some external pictures are being used (e.g. on this page https://tails.boum.org/doc/about/warning/index.de.html the picture on how Tor works and the picture about MITM attacks). Any ideas? (ofc we could start also translating the stuff on the screenshots and edit them)

Hi spriver,

for the pictures in doc/about/warning, we could ease the translation by using .svg: svg files can be opened in a text editor, and the modification can be easily tracked with git. But let's focus on the screenshots here and discuss this on another ticket : #10439

#4 Updated by muri almost 4 years ago

u wrote:

Assigning to you because you proposed it, but if you think it's not your cup of tea, feel free to unassign yourself :)

i'll look into it and do some reading about automated tests ;)

#5 Updated by muri over 3 years ago

  • Assignee changed from muri to u

so, kytv and i talked about that at the congress and it seems doable with our current setup for the automated tests. i think the next step would be to create the tickets to implement the steps and collect the images we want...
(assigingin to u, i'm not sure how to proceed, i guess we can close this ticket?)

#6 Updated by u over 3 years ago

  • Assignee changed from u to muri

Hi muri,

as you talked about the steps to be taken, would you be able to create the tickets for them please? and then, yes, please close this ticket.

cheers!

#7 Updated by muri over 3 years ago

  • Status changed from New to Resolved

new ticket to track progress: #11406

#8 Updated by u over 2 years ago

  • Status changed from Resolved to Confirmed

I'm reopening this ticket because it states "we could do that with our current setup of tests" made by kytv. However, kytv did not report in detail on how that would be possible. before moving on, we need to make this clear first and write it down on this ticket.

#9 Updated by u over 2 years ago

  • Parent task set to #11406

#10 Updated by muri about 1 year ago

  • Assignee deleted (muri)

i won't have time to work on this in the foreseeable future

Also available in: Atom PDF