Project

General

Profile

Feature #10436

Feature #5663: Return to Icedove

Consider disabling the Enigmail wizard on first start

Added by sajolida about 3 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
10/27/2015
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Discuss
Blueprint:
Starter:
Affected tool:
Email Client

Description

I find the current opening of Icedove a bit rough:

  • The Icedove wizard appears.
  • It's then shutoff by TorBirdy with a warning that bring you back to the main account settings interface. Ok, that's tracked by #6154.
  • But underneath there's the Enigmail setup wizard that you're faced with after setting up your account.

I propose to disable the Enigmail setup wizard and here is why.

Everybody starting Icedove wants an email account set up, so the Icedove wizard makes perfect sense. Now, the Enigmail wizard is only relevant for people already knowledgeable about OpenPGP. It's opening sentences are probably confusing for people who don't know what Enigmail is good for:

Welcome to the Enigmail Setup Wizard
This wizard helps you to start using Enigmail right away. Over the next few screens we'll ask you some questions to get everything setup.

This sounds like Enigmail is needed for the proper functioning of Icedove in Tails which is not the case if you don't know or don't care about OpenPGP.

On the other hand, I can understand why and how this wizard makes sense for people installing Enigmail outside of Tails as they are clearly interested about that.

I propose to instead document how to run the setup wizard from the menu in the Icedove documentation Menu → Enigmail → Setup Wizard.


Related issues

Related to Tails - Feature #15658: Enable Enigmail by default if a GnuPG secret key is detected Confirmed 06/15/2018

History

#1 Updated by sajolida about 3 years ago

  • Parent task set to #5663

#2 Updated by sajolida about 3 years ago

  • Target version set to Tails_1.8

Could this fit into Tails 1.8 as something technically small but user-facing?

#3 Updated by u about 3 years ago

I am in favour of your solution.

I also think that one does not need to run the wizard if one has a function $HOME/.gnupg/ from before.

At least, when I tested the migration from Claws to Icedove, using also some encrypted emails, they were decrypted by enigmail without me setting up anything in particular as far as i remember.

#6 Updated by kytv about 3 years ago

sajolida wrote:

I find the current opening of Icedove a bit rough:

  • The Icedove wizard appears.
  • It's then shutoff by TorBirdy with a warning that bring you back to the main account settings interface. Ok, that's tracked by #6154.
  • But underneath there's the Enigmail setup wizard that you're faced with after setting up your account.

This shouldn't be. Indeed, I just booted the 1.7~rc1 iso on a new device, created an account, and I did not see the Enigmail wizard. O.o

#7 Updated by intrigeri about 3 years ago

  • Assignee set to sajolida
  • QA Check set to Info Needed

This shouldn't be. Indeed, I just booted the 1.7~rc1 iso on a new device, created an account, and I did not see the Enigmail wizard. O.o

Thus reassigning to sajolida to get more info :)

#8 Updated by sajolida about 3 years ago

  • Assignee changed from sajolida to kytv

I confirm that starting from a fresh in 1.7~rc1 the Enigmail wizard does not appear. Sorry for the mess.

What I did previously was to create a new profile from scratch (without what's in /etc/skel/.icedove). What prevents the wizard to open currently is profile.default/preferences/0000tails.js but I don't really know why. Anyway, kytv, feel free to reject this ticket if you think that this settings will be reliable in the future (because from the Git history the intention of this is not to disable the Enigmail wizard).

#9 Updated by kytv about 3 years ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (kytv)
  • QA Check deleted (Info Needed)

sajolida wrote:

I confirm that starting from a fresh in 1.7~rc1 the Enigmail wizard does not appear. Sorry for the mess.

'Tis fine. :) Apologies for not being more explicit in the Git history about the purpose of extensions.enigmail.configuredVersion.

What I did previously was to create a new profile from scratch (without what's in /etc/skel/.icedove). What prevents the wizard to open currently is profile.default/preferences/0000tails.js but I don't really know why. Anyway, kytv, feel free to reject this ticket if you think that this settings will be reliable in the future (because from the Git history the intention of this is not to disable the Enigmail wizard).

As long as the enigmail prefererences are updated at release time, as is done with Adblock, this should be fine. Rejecting as suggested.

#10 Updated by intrigeri over 2 years ago

  • % Done changed from 0 to 100

#11 Updated by sajolida 5 months ago

  • Related to Feature #15658: Enable Enigmail by default if a GnuPG secret key is detected added

Also available in: Atom PDF