Project

General

Profile

Bug #10419

The OpenPGP key for deb.tails.boum.org will expire soon

Added by bertagaz over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
10/25/2015
Due date:
% Done:

100%

Feature Branch:
bugfix/10419-update-tails-APT-repo-key
Type of work:
Sysadmin
Blueprint:
Starter:
No
Affected tool:

Description

The test suite recently started to fail on the test of the deb.tails.boum.org package signing key.

It expires in less than 3 monthes:

pub   4096R/0xC7988EA7A358D82E 2012-02-04 [expires: 2016-01-25]
      Key fingerprint = 221F 9A3C 6FA3 E09E 182E  060B C798 8EA7 A358 D82E
uid                 [ unknown] deb.tails.boum.org archive signing key

Related issues

Related to Tails - Bug #8747: The OpenPGP key for deb.tails.boum.org will expire soon Resolved 01/20/2015

Associated revisions

Revision 9e460350 (diff)
Added by bertagaz over 4 years ago

Update the Tails APT repo signing key.

Will-fix: #10419

Revision 1f580012
Added by anonym about 4 years ago

Merge remote-tracking branch 'origin/bugfix/10419-update-tails-APT-repo-key' into testing

Fix-committed: #10419

History

#1 Updated by bertagaz over 4 years ago

  • Related to Bug #8747: The OpenPGP key for deb.tails.boum.org will expire soon added

#2 Updated by intrigeri over 4 years ago

  • Target version set to Tails_1.7

So it must be updated in Tais 1.8 to the latest. But we generally try to be nice to users who skipped a release, so including the updated key in 1.7 would be ideal.

#3 Updated by bertagaz over 4 years ago

intrigeri wrote:

So it must be updated in Tais 1.8 to the latest. But we generally try to be nice to users who skipped a release, so including the updated key in 1.7 would be ideal.

Will try to do that for 1.7 as marked for this ticket, but can't really promise I will, too much stuffs on my plate for today and coming days.

#4 Updated by bertagaz over 4 years ago

  • Status changed from Confirmed to In Progress

#5 Updated by bertagaz over 4 years ago

  • Assignee changed from bertagaz to intrigeri
  • % Done changed from 0 to 80
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/10419-update-tails-APT-repo-key
  • Starter set to No

Updated in a branch of the Tails repo, on the SKS keyservers, and deployed in our infra (including http://deb.tails.boum.org/key.asc)

#6 Updated by bertagaz over 4 years ago

bertagaz wrote:

Updated in a branch of the Tails repo, on the SKS keyservers, and deployed in our infra (including http://deb.tails.boum.org/key.asc)

Test job #1 of the branch in Jenkins passed this step:

00:17:41.193   Scenario: The Tails Debian repository key is up-to-date                      # features/checks.feature:29
00:17:45.699     Given I have started Tails from DVD without network and logged in          # features/step_definitions/snapshots.rb:174
00:17:45.699     Then the shipped Debian repository key will be valid for the next 3 months # features/step_definitions/checks.rb:20

Seems to fix the issue there.

#7 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to anonym

Updated in a branch of the Tails repo,

Passing the review stick to anonym for this part.

on the SKS keyservers, and deployed in our infra

Reviewed the infra side of things, looks good.

(including http://deb.tails.boum.org/key.asc)

bertagaz, this makes me curious: IIRC I've done something semi-recently so that this is automated (at some point a few months ago it was outdated, so I bothered fixing the root cause). Did you have to do anything manual?

#8 Updated by bertagaz over 4 years ago

intrigeri wrote:

(including http://deb.tails.boum.org/key.asc)

bertagaz, this makes me curious: IIRC I've done something semi-recently so that this is automated (at some point a few months ago it was outdated, so I bothered fixing the root cause). Did you have to do anything manual?

Yep, I had to update the key.asc file in /srv/reprepro/ manually. Didn't find anything in the manifest about this file, didn't bother doing that now. I'll open a ticket to keep that in mind.

#9 Updated by anonym about 4 years ago

  • Status changed from In Progress to 11
  • % Done changed from 80 to 100

#10 Updated by anonym about 4 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#11 Updated by anonym about 4 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF