Project

General

Profile

Bug #10412

Synaptic hangs after updating APT lists

Added by intrigeri about 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
10/23/2015
Due date:
% Done:

100%

Feature Branch:
test/10441-synaptic-test-is-fragile
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Seen when testing a custom ISO (tails-i386-test_6302-mac-spoofing-1.7-20151023.iso) from the test/6302-mac-spoofing branch, but current devel is probably affected too:

    When I start Synaptic                                                                                          # features/step_definitions/apt.rb:61
[log] Ctrl+TYPE "r" 
    And I update APT using Synaptic                                                                                # features/step_definitions/apt.rb:31
      FindFailed: can not find SynapticPackageList.png on the screen.
      Line ?, in File ? (RuntimeError)
      features/apt.feature:22:in `And I update APT using Synaptic'

The video shows that Synaptic simply disappears at some point, after downloading stuff for a few minutes. Not tried to reproduce this outside of the test suite yet. I've seen other Synaptic failures in recent test runs on Jenkins so I dare reporting it already. Sorry.


Related issues

Related to Tails - Bug #10441: Synaptic test is fragile Resolved 10/28/2015

Associated revisions

Revision 2a88c643
Added by anonym over 3 years ago

Merge remote-tracking branch 'origin/test/10441-synaptic-test-is-fragile' into devel

Fix-committed: #10412, #10441

History

#1 Updated by intrigeri about 4 years ago

Reproduced with an ISO built from devel 11 days ago, from the same Git branch for the test suite.

#2 Updated by anonym about 4 years ago

  • Assignee changed from anonym to kytv
  • QA Check set to Info Needed

intrigeri wrote:

Reproduced with an ISO built from devel 11 days ago, from the same Git branch for the test suite.

Let's just immediately discard any suspicion that the test/6302-mac-spoofing branch has anything to do with this. While it did change the code of the the synaptic step definitions, it's obviously not related.

kytv, IIRC you had also seen this? You talked about synaptic segfaulting, right? Anything more to add?

(BTW, I won't have time to fix this in 1.7, but I'll keep that target version for now in hopes that kytv will answer faster :)

#3 Updated by bertagaz about 4 years ago

anonym wrote:

kytv, IIRC you had also seen this? You talked about synaptic segfaulting, right? Anything more to add?

I've seen it myself lately, had synaptic segfaulting with cryptic messages about GTK_TREE_VIEW or something.

I think the Jenkins isotesters seen that too recently, in devel based branch mainly and a bit in experimental.

Couldn't reproduce it in a Tails from devel, so was not sure what it might be.

#4 Updated by kytv about 4 years ago

  • Target version changed from Tails_1.7 to Tails_1.8

#5 Updated by kytv about 4 years ago

  • Assignee changed from kytv to anonym
  • QA Check deleted (Info Needed)

Yes, I've seen synaptic segfault in the past but the last time for me was some time ago, though to be clear I haven't run apt.feature much other than at release time.

#6 Updated by anonym about 4 years ago

  • Target version changed from Tails_1.8 to Tails_2.0

#7 Updated by anonym about 4 years ago

This was reported for Tails based on Debian Wheezy. Hopefully it's not a thing now when Tails is based on Jessie. I do not know, since I cannot recall ever seeing this bug. I suppose it'd be helpful to look at recent logs on our isotesters, before apt.feature was tagged @fragile.

#8 Updated by intrigeri about 4 years ago

I cannot recall ever seeing this bug.

I don't think I've ever seen it on Jessie, indeed. Let's close and come back to it if it reappears (e.g. in the batch of false positives I'll soon give bertagaz+kytv to analyze)?

I suppose it'd be helpful to look at recent logs on our isotesters, before apt.feature was tagged @fragile.

In theory we should have a branch with that feature not tagged as fragile, and up-to-date results, no?

#9 Updated by anonym about 4 years ago

  • Assignee changed from anonym to bertagaz

intrigeri wrote:

I cannot recall ever seeing this bug.

I don't think I've ever seen it on Jessie, indeed. Let's close and come back to it if it reappears (e.g. in the batch of false positives I'll soon give bertagaz+kytv to analyze)?

Agreed, but I first want bert to look at the logs...

I suppose it'd be helpful to look at recent logs on our isotesters, before apt.feature was tagged @fragile.

In theory we should have a branch with that feature not tagged as fragile, and up-to-date results, no?

Ah, of course! That is test/10441-synaptic-test-is-fragile. So, bert, can you look at the logs for that branch too? If you see nothing, just close this ticket, otherwise reassign it to me.

#10 Updated by bertagaz almost 4 years ago

  • Target version changed from Tails_2.0 to Tails_2.2

#11 Updated by bertagaz almost 4 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#12 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#13 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.4 to Tails_2.5

#14 Updated by bertagaz over 3 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20
  • Feature Branch set to test/10441-synaptic-test-is-fragile

anonym wrote:

intrigeri wrote:

I cannot recall ever seeing this bug.

I don't think I've ever seen it on Jessie, indeed. Let's close and come back to it if it reappears (e.g. in the batch of false positives I'll soon give bertagaz+kytv to analyze)?

Agreed, but I first want bert to look at the logs...

They disappeared meanwhile, so I updated the branch and will come back in a few days to parse the results.

#15 Updated by bertagaz over 3 years ago

  • Category set to Test suite

#16 Updated by bertagaz over 3 years ago

  • % Done changed from 20 to 50

I have not seen this particular bug in Jenkins recently, and I've pushed something in the branch that tackles #10441 and should workaround this. Let see how it behaves.

#17 Updated by bertagaz over 3 years ago

  • Assignee changed from bertagaz to anonym
  • QA Check set to Ready for QA

Not seen this error, and the commit I've pushed on the branch to fix #10441 should fix this one too anyway. => RfQA as the other ticket.

#18 Updated by intrigeri over 3 years ago

  • Related to Bug #10441: Synaptic test is fragile added

#19 Updated by intrigeri over 3 years ago

  • Assignee changed from anonym to bertagaz
  • QA Check changed from Ready for QA to Dev Needed

(Same as #10441 since it's the same branch.)

#20 Updated by bertagaz over 3 years ago

  • Assignee changed from bertagaz to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

RfQA as #10441.

#21 Updated by intrigeri over 3 years ago

  • Subject changed from synaptic hangs after updating APT lists to Synaptic hangs after updating APT lists
  • Assignee changed from intrigeri to bertagaz
  • QA Check changed from Ready for QA to Dev Needed

#22 Updated by intrigeri over 3 years ago

  • Assignee changed from bertagaz to anonym
  • Target version changed from Tails_2.5 to Tails_2.6
  • QA Check changed from Dev Needed to Ready for QA

(Same as #10441)

#23 Updated by anonym over 3 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#24 Updated by anonym over 3 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF