Project

General

Profile

Bug #10395

Tor Browser is slow at printing in Jessie

Added by anonym almost 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
10/20/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

See this commit:

commit 51a9e4130b5f8de2cabdac0df41502e7a0c1d060
Author: anonym <anonym@riseup.net>
Date:   Tue Oct 20 16:30:14 2015 +0200

    Bump timeout.

    The printing takes a lot longer now. It seems related to #7771 --
    setting print.postscript.cups.enabled = false makes it take just a few
    seconds again. I am not sure if that has other negative consequences,
    so I'll go with the timeout bump for now.


Related issues

Related to Tails - Bug #7771: Attempting to print hangs the Unsafe Browser Resolved 08/10/2014

Associated revisions

Revision 55506571 (diff)
Added by anonym over 3 years ago

Revert "Bump timeout."

This reverts commit 51a9e4130b5f8de2cabdac0df41502e7a0c1d060.

I am not sure what made printing so slow for me while updating the
automated test suite for Jessie, that originally made me do this bump,
but it is not there any more.

Refs: #10395

History

#1 Updated by intrigeri almost 4 years ago

  • Related to Bug #7771: Attempting to print hangs the Unsafe Browser added

#2 Updated by intrigeri almost 4 years ago

This suggests that cupsd, or the communication between Tor Browser and cupsd, is broken (#7771 was about the firewall blocking connections to cupsd, and Firefox taking a long time to realize that), which might be the actual problem we want to solve here.

#3 Updated by intrigeri over 3 years ago

  • Category deleted (Test suite)
  • Assignee changed from anonym to intrigeri
  • Target version changed from Tails_1.8 to Tails_2.0
  • Affected tool set to Browser

I'll at least check if this affects non-test-suite usage.

#4 Updated by intrigeri over 3 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • Target version changed from Tails_2.0 to Tails_1.8
  • % Done changed from 0 to 10
  • QA Check set to Info Needed

I've reverted that commit and the two printing operations from features/torified_browsing.feature pass just fine. Manual testing shows printing to PDF takes a few seconds as well. Can you please revert the commit and try reproducing the symptoms that made you apply it in the first place?

#5 Updated by intrigeri over 3 years ago

  • Target version changed from Tails_1.8 to Tails_2.0

Given my test results above, it can wait a bit.

#6 Updated by anonym over 3 years ago

  • Status changed from In Progress to Rejected
  • Assignee deleted (anonym)
  • % Done changed from 10 to 0
  • QA Check deleted (Info Needed)

intrigeri wrote:

I've reverted that commit and the two printing operations from features/torified_browsing.feature pass just fine. Manual testing shows printing to PDF takes a few seconds as well. Can you please revert the commit and try reproducing the symptoms that made you apply it in the first place?

I cannot reproduce this, so I reverted the commit and pushed it straight into testing.

Also available in: Atom PDF