Project

General

Profile

Feature #10384

Feature #7544: Have a multiplatform Installer

Feature #8550: Make Tails Installer work on Windows

Feature #8558: Study feasibility of porting Tails Installer to Windows

Feature #8552: Rename liveusb-creator to Tails Installer

Feature #9635: Try building a Python/GI executable on windows

Tails Installer: Merge master into feature/jessie

Added by u about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Installation
Target version:
Start date:
10/17/2015
Due date:
% Done:

100%

Feature Branch:
451f:liveusbcreator/feature/jessie
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installer

Description

In order to be able to rename liveusb-creator to tails-installer, we first need to merge, for a last time, master into feature/jessie.

History

#1 Updated by u about 4 years ago

  • % Done changed from 0 to 30
  • Parent task set to #8552

#2 Updated by u about 4 years ago

  • Assignee changed from u to intrigeri
  • QA Check set to Ready for QA
  • Feature Branch set to 451f:liveusbcreator/mergepo

Please review:

on branch feature/jessie, commits

commit bc138f1fb5a62495eac7da586ec59e16e4da44ee
commit 54ad97155b8906b5482b9cde1834e9cad5bf900e
commit f4cce772907a543ea2594a6a317bbd857121dcac
commit 9cc2294cb8743750484c5056532a47b29ebe5811
commit 57452e20f34877f048c08f3dc15a1125299cdb3c

and on branch mergepo (this branch also has the previous commits):

commit 781e4c53206f565468974dadbb3721e6d001f6f9
commit 01a1763689e528cfe0d27ad4d2b829dbeacf4038

The po files do contain some more lines than the POT file. But i thought we might as well leave those for now, until we regenerate the PO files. checked with fgrep msgid po/*.po -c

#4 Updated by intrigeri about 4 years ago

  • Category set to Installation
  • Status changed from Confirmed to In Progress
  • Priority changed from Normal to Elevated
  • Target version set to Tails_1.7

#5 Updated by intrigeri about 4 years ago

  • Assignee changed from intrigeri to u
  • % Done changed from 30 to 50
  • QA Check changed from Ready for QA to Dev Needed

The diff shows at least 2 self.textEdit.append(message) that weren't converted to how we do it with GTK (git log -p append_to_log would help). Otherwise, looks good!

But the two branches' content is identical so I'm wondering if I'm looking at the right thing.

I'll assume that you've done basic manual tests, and will postpone uploading an updated package to after the rename, so I won't run the test suite.

#6 Updated by u about 4 years ago

intrigeri wrote:

The diff shows at least 2 self.textEdit.append(message) that weren't converted to how we do it with GTK (git log -p append_to_log would help). Otherwise, looks good!

thanks for reviewing this. I will modify those 2.

But the two branches' content is identical so I'm wondering if I'm looking at the right thing.

that was a mistake, I've re-separated them, so that feature/jessie has code modifications and the mergepo branch has only a po-related commit.

I'll assume that you've done basic manual tests, and will postpone uploading an updated package to after the rename, so I won't run the test suite.

ack.

#7 Updated by u about 4 years ago

  • Assignee changed from u to intrigeri
  • QA Check changed from Dev Needed to Ready for QA
  • Feature Branch changed from 451f:liveusbcreator/mergepo to 451f:liveusbcreator/feature/jessie

Would you care to reverify my latest commit on feature/jessie please?

I've simply replaced

self.textEdit.append(message)

by

self.append_to_log(message)

I am not 100% sure if that is what we wanted.

the 2 branches to be merged are:
451f:liveusbcreator/feature/jessie
451f:liveusbcreator/mergepo

#8 Updated by intrigeri about 4 years ago

  • Assignee changed from intrigeri to u
  • QA Check changed from Ready for QA to Dev Needed

Would you care to reverify my latest commit on feature/jessie please?

I'll be glad to (with some delay, likely), once you've tested it, because:

I am not 100% sure if that is what we wanted.

If you test the exact situation in which this code is triggered, you should see if it works fine, I think.

(If I've missed something, then I'm very sorry, please explain me what it is.)

#9 Updated by u about 4 years ago

  • Assignee changed from u to intrigeri
  • QA Check changed from Dev Needed to Ready for QA

ok, now it's ready for review i think.

I've manually added intrigeri's commit from master which deletes the obsolete md5sum verification.

#10 Updated by intrigeri about 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Merged, thanks! As said earlier, I'm postponing testing to once we're done with #8552.

Also available in: Atom PDF