Project

General

Profile

Bug #10378

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

The "Tails OpenPGP keys" scenario is fragile

Added by kytv almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
10/15/2015
Due date:
% Done:

100%

Feature Branch:
test/10378-fix-tails-shipped-openpgp-keys-test-is-fragile
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

anonym wrote:

Expected. We need to be more proactive about updating the key... :)


Related issues

Related to Tails - Feature #10016: Include the updated signing key and new subkeys Resolved 08/14/2015
Related to Tails - Bug #14770: "Fetching OpenPGP keys" scenarios are fragile: communication failure with keyserver In Progress 10/04/2017

Associated revisions

Revision 6e7e2dd7
Added by anonym over 3 years ago

Merge remote-tracking branch 'kytv/test/10378-fix-tails-shipped-openpgp-keys-test-is-fragile' into devel

Fix-committed: #10378

History

#1 Updated by kytv almost 4 years ago

  • Status changed from New to Confirmed
  • Parent task set to #10288

#2 Updated by kytv almost 4 years ago

  • Description updated (diff)

#3 Updated by anonym almost 4 years ago

  • Subject changed from Mark "Tails OpenPGP keys" scenario as fragile to The "Tails OpenPGP keys" scenario is fragile

#4 Updated by anonym almost 4 years ago

  • Related to Feature #10016: Include the updated signing key and new subkeys added

#5 Updated by kytv almost 4 years ago

  • Parent task deleted (#10288)

#6 Updated by kytv almost 4 years ago

  • Blocks Bug #10288: Fix newly identified issues to make our test suite more robust and faster added

#7 Updated by kytv almost 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee set to anonym
  • % Done changed from 0 to 30
  • QA Check set to Ready for QA
  • Feature Branch set to kytv:test/05fe0a1-fix-openpgp-keys-are-up-to-date

Note: The @fragile tag was added to my devel branch. This branch reverts the change per #10288.

#8 Updated by intrigeri almost 4 years ago

  • Blocks deleted (Bug #10288: Fix newly identified issues to make our test suite more robust and faster)

#9 Updated by intrigeri almost 4 years ago

  • Parent task set to #10288

#11 Updated by intrigeri almost 4 years ago

  • Tracker changed from Feature to Bug

#12 Updated by anonym almost 4 years ago

  • Assignee changed from anonym to kytv
  • QA Check changed from Ready for QA to Dev Needed

kytv wrote:

Note: The @fragile tag was added to my devel branch. This branch reverts the change per #10288.

That's the idea, great! I think you copy-pasted the wrong thing into the branch name... :) I'll fix it when I pull your branch into Tails' Git.

However, I don't think I should do that yet (so you have time to rename it yourself), because your current devel contains @fragile tags for some unpushed branches, at least AFAICT. Please make sure that your devel is synched with the other branches you have pushed.

#13 Updated by kytv almost 4 years ago

  • Feature Branch changed from kytv:test/05fe0a1-fix-openpgp-keys-are-up-to-date to kytv:test/05fe0a1-fix-tails-shipped-openpgp-keys-test-is-fragile

#14 Updated by kytv almost 4 years ago

  • Feature Branch changed from kytv:test/05fe0a1-fix-tails-shipped-openpgp-keys-test-is-fragile to kytv:test/10378-fix-tails-shipped-openpgp-keys-test-is-fragile

#15 Updated by anonym almost 4 years ago

  • Feature Branch changed from kytv:test/10378-fix-tails-shipped-openpgp-keys-test-is-fragile to test/10378-fix-tails-shipped-openpgp-keys-test-is-fragile

Branch imported to our Git, scenarios marked as @fragile in devel.

#16 Updated by kytv almost 4 years ago

  • Target version changed from Tails_1.7 to Tails_1.8

#18 Updated by kytv almost 4 years ago

  • Target version changed from Tails_1.8 to 246

#19 Updated by sajolida almost 4 years ago

  • Target version changed from 246 to Tails_2.0

#20 Updated by kytv almost 4 years ago

  • Assignee changed from kytv to anonym
  • Target version changed from Tails_2.0 to Tails_1.8
  • % Done changed from 30 to 80
  • QA Check changed from Dev Needed to Ready for QA

Since the key's been updated we should be able to remove the fragile tag by merging this branch.

#21 Updated by anonym almost 4 years ago

  • Target version changed from Tails_1.8 to Tails_2.0

#22 Updated by anonym over 3 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 80 to 100

#23 Updated by anonym over 3 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#24 Updated by anonym over 3 years ago

  • Status changed from Fix committed to Resolved

#25 Updated by intrigeri almost 2 years ago

  • Related to Bug #14770: "Fetching OpenPGP keys" scenarios are fragile: communication failure with keyserver added

Also available in: Atom PDF