Project

General

Profile

Bug #10375

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

Increase the number of Tor circuit retries in the test suite

Added by kytv over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
10/15/2015
Due date:
% Done:

100%

Feature Branch:
kytv:test/10375-bump-Tor-retry-limit
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

The main rationales for this are OFTC's blocking of Tor and communication problems with the keyservers.

anonym wrote:

OFTC blocking is still a problem. We could try bumping the retries from 5 to 10. Thoughts?

I think raising the default to 10 or more would be fine. Any users that may want to run the test suite can set this however they'd like.

History

#1 Updated by kytv over 4 years ago

  • Description updated (diff)

#2 Updated by kytv over 4 years ago

  • Parent task set to #10288

#3 Updated by kytv over 4 years ago

  • Description updated (diff)

#4 Updated by anonym over 4 years ago

kytv wrote:

I think raising the default to 10 or more would be fine. Any users that may want to run the test suite can set this however they'd like.

Let's try 10. We value robustness over performance, I guess. However, there's some limit: if we need more, then #9517 was not the right solution for #9072 (and it should be reopened).

(Meta: redmine refuses to add any of those as Related tickets, complaining about "circular dependency". Argh!)

#5 Updated by kytv over 4 years ago

  • Tracker changed from Feature to Bug
  • Status changed from Confirmed to In Progress
  • Assignee set to anonym
  • QA Check set to Ready for QA
  • Feature Branch set to kytv:test/10375-bump-Tor-retry-limit

Done.

#6 Updated by kytv over 4 years ago

  • % Done changed from 0 to 50

#8 Updated by anonym over 4 years ago

  • Assignee changed from anonym to kytv
  • QA Check changed from Ready for QA to Dev Needed

This branch does not remove the @fragile tags for the IRC tests you added in your devel's commit 1e5fd8f. Please push a revert of that commit. (I would have done this myself if it wasn't for the fact that I cannot merge your devel per #10378#note-12.)

#9 Updated by anonym over 4 years ago

anonym wrote:

This branch does not remove the @fragile tags for the IRC tests you added in your devel's commit 1e5fd8f. Please push a revert of that commit. (I would have done this myself if it wasn't for the fact that I cannot merge your devel per #10378#note-12.)

I now see that 1e5fd8f added fragile due to #10376, so sorry for the noise.

However, as you noted on IRC, this might have uncovered a small problem with the scheme for #10288: if there are two (or more) reasons to tagging a scenario @fragile, what to do? Luckily, Cucumber has no issue with the same tag being specified multiple times for a scenario (and --tag @TAG@ and --tag ~@TAG@ still works the same as with only once instance), so the scheme will work: the revert will cause a merge conflict, and we remove only one of the @fragile tags. I've updated the description of #10288 to make this clear.

#10 Updated by anonym over 4 years ago

anonym wrote:

However, as you noted on IRC, this might have uncovered a small problem with the scheme for #10288: if there are two (or more) reasons to tagging a scenario @fragile, what to do? Luckily, Cucumber has no issue with the same tag being specified multiple times for a scenario (and --tag @TAG@ and --tag ~@TAG@ still works the same as with only once instance), so the scheme will work: the revert will cause a merge conflict, and we remove only one of the @fragile tags. I've updated the description of #10288 to make this clear.

Actually, that idea won't work. I updated the (end of the) description of #10288 with another solution. It got really complicated, so let's see if the instructions are clear enough for you to implement... :S

#11 Updated by kytv about 4 years ago

  • Status changed from In Progress to 11
  • Target version deleted (Tails_1.7)
  • % Done changed from 50 to 100
  • QA Check deleted (Dev Needed)

This was actually merged in 02bfdf71ece80fe5678a7b96f91105634135b071

#12 Updated by kytv about 4 years ago

  • Assignee deleted (kytv)

#13 Updated by intrigeri about 4 years ago

  • Status changed from 11 to Resolved
  • Target version set to Tails_1.7

Also available in: Atom PDF