Project

General

Profile

Bug #10373

Document the version of Jenkins plugins we have to stick to

Added by bertagaz almost 4 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
-
Start date:
10/15/2015
Due date:
% Done:

0%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
No
Affected tool:

Description

Given our Jenkins instance is old
And we can't install all Jenkins plugins at their latest version
Then we need to document which one we shouldn't upgrade during the sysadmin shifts

As stated in #10229, we'll do that in the definition of our tails::jenkins::master manifest.

History

#1 Updated by bertagaz almost 4 years ago

  • Target version changed from Tails_1.7 to Tails_1.8

Postponing as this won't happen before 1.7.

#2 Updated by intrigeri almost 4 years ago

  • Target version changed from Tails_1.8 to Tails_2.2
  • Starter changed from Yes to No

Postponing to less crazy times.

#3 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

Postponing: it's a bit less urgent than the rest of the things I have to do during the 2.2 release. I'll work on that during my next shift.

#4 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#5 Updated by bertagaz over 3 years ago

  • Target version changed from Tails_2.4 to Tails_2.5

#8 Updated by bertagaz about 3 years ago

  • Target version changed from Tails_2.5 to Tails_2.6

#9 Updated by anonym almost 3 years ago

  • Target version changed from Tails_2.6 to Tails_2.7

#10 Updated by bertagaz almost 3 years ago

  • Target version changed from Tails_2.7 to Tails_2.9.1

#11 Updated by anonym almost 3 years ago

  • Target version changed from Tails_2.9.1 to Tails 2.10

#12 Updated by anonym over 2 years ago

  • Target version changed from Tails 2.10 to Tails_2.11

#13 Updated by bertagaz over 2 years ago

  • Assignee changed from bertagaz to intrigeri
  • QA Check set to Info Needed

To me this ticket is a bit obsolete given we want to update our Jenkins instance to the upstream one. (see #10068) It has little sense to spend hours this task requires so we should probably kill it. Opinion?

#14 Updated by intrigeri over 2 years ago

  • Assignee changed from intrigeri to bertagaz

To me this ticket is a bit obsolete given we want to update our Jenkins instance to the upstream one. (see #10068) It has little sense to spend hours this task requires so we should probably kill it. Opinion?

Agreed, as long as any similar "the version of Jenkins we're running is not compatible with plugin X version Y" problem is documented as part of the upgrade to upstream 2.x.
Please make this explicit on the corresponding ticket (clearly the "it's obvious, no need to write it down" way didn't work for the initial deployment so let's not count on it), and then feel free to close this one :)

#15 Updated by bertagaz over 2 years ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (bertagaz)
  • Target version deleted (Tails_2.11)
  • QA Check deleted (Info Needed)

intrigeri wrote:

Agreed, as long as any similar "the version of Jenkins we're running is not compatible with plugin X version Y" problem is documented as part of the upgrade to upstream 2.x.
Please make this explicit on the corresponding ticket (clearly the "it's obvious, no need to write it down" way didn't work for the initial deployment so let's not count on it), and then feel free to close this one :)

Ack, good idea. Added a note on #10068 then, closing this one.

Also available in: Atom PDF