Project

General

Profile

Bug #10356

Feature #10153: Automated tests: phase two

Adapt the test job artifacts archiving script to their new location

Added by bertagaz over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Continuous Integration
Target version:
Start date:
10/11/2015
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
No
Affected tool:

Description

In the #10151 related branch, the screenshots, video captures and pcap files of a test suite run will be stored in a sub-directory of TMP_DIR.

In the Jenkins environment, the post_test_cleanup script copy them back in the workspace so that Jenkins can archive them. It uses a find "${TEMP_DIR}" -maxdepth 1 [...] to do so, which won't work anymore.

So once #10151 is merged, this find will have to be modified accordingly, likely by removing the -maxdepth 1.

History

#1 Updated by bertagaz over 4 years ago

  • Blocked by Feature #10151: Organize automated test suite artifacts in per-run directories added

#2 Updated by bertagaz over 4 years ago

  • Parent task set to #10153

#3 Updated by bertagaz over 4 years ago

  • Blocked by deleted (Feature #10151: Organize automated test suite artifacts in per-run directories)

#4 Updated by bertagaz over 4 years ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from bertagaz to intrigeri
  • % Done changed from 0 to 80
  • QA Check set to Ready for QA

I've already implemented this, in commit c49eb48 of the puppet-tails repo.

Since then test #5 of the stable branch (without #10151) and test #15 of the experimental branch (with #10151) have happened and they still correctly store the artifacts.

So I guess we can close this ticket.

(Note that the tailstester.json and debug.log files in this test run were not archived, but that's a different problem introduced by a buggy change in the puppet-tails repo in commit 29ea4c6 and resolved in 88efaf6).

#5 Updated by intrigeri over 4 years ago

  • Assignee changed from intrigeri to bertagaz
  • QA Check changed from Ready for QA to Info Needed

I've already implemented this, in commit c49eb48 of the puppet-tails repo.

:)

(Note that the tailstester.json and debug.log files in this test run were not archived, but that's a different problem introduced by a buggy change in the puppet-tails repo in commit 29ea4c6 and resolved in 88efaf6).

I see that the recent test_Tails_ISO_experimental had no artifacts stored, and I don't know if this has anything to do with this ticket. Is that the same problem that you say was fixed already? If not, please ticket++.

#6 Updated by bertagaz over 4 years ago

  • Assignee changed from bertagaz to intrigeri
  • QA Check changed from Info Needed to Ready for QA

intrigeri wrote:

I see that the recent test_Tails_ISO_experimental had no artifacts stored, and I don't know if this has anything to do with this ticket. Is that the same problem that you say was fixed already? If not, please ticket++.

No, that was because of the #10151 branch merge into experimental side affect, which failed the tests at the beginning, so no artifacts. Since then it has been fixed as shown in https://jenkins.tails.boum.org/view/Ale/job/test_Tails_ISO_experimental/20/

#7 Updated by intrigeri over 4 years ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 80 to 100
  • QA Check changed from Ready for QA to Pass

Thanks for the explanations + pointers. So we're done here :)

Also available in: Atom PDF