Project

General

Profile

Bug #10347

Troubleshooting for automatic upgrades that fail to restart

Added by emmapeel about 4 years ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
10/07/2015
Due date:
% Done:

0%

Feature Branch:
doc/10347-broken-after-automatic-upgrade
Type of work:
End-user documentation
Blueprint:
Starter:
Yes
Affected tool:

Description

When users cannot boot after an automatic upgrade, they are directed to the page

https://tails.boum.org/doc/upgrade/error/install/

In this page there are some commands to run, but this commands are meant for a booting Tails:

the output of the five following commands, run in a Terminal:

   ls -l /lib/live/mount/medium/live
   cat /lib/live/mount/medium/live/Tails.module
   mount
   df -h
   free -m

The user cannot run the broken Tails, so the instructions should be more:

- Start another Tails
- Mount the Tails partition with Disk Utility (not TailsData)
- Report a bug with the output of the five following commands, run in a Terminal:

ls -lh /lib/live/mount/medium/live
cat /lib/live/mount/medium/live/Tails.module
mount
df -h
free -m

or something like that.


Related issues

Related to Tails - Bug #10239: Tails Upgrader sometimes make device unbootable Resolved 09/23/2015
Related to Tails - Feature #15130: Restructure our support page and content Confirmed 09/28/2013
Related to Tails - Bug #15557: Document workaround for partially applied automatic upgrade Resolved 04/30/2018
Blocks Tails - Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing Confirmed 01/08/2016

Associated revisions

Revision ef26b49c
Added by sajolida about 2 months ago

Merge remote-tracking branch 'cbrownstein/doc/10347-broken-after-automatic-upgrade' (Closes: #10347)

History

#1 Updated by emmapeel about 4 years ago

  • Subject changed from Debugging steps in 'update error' documentation must be adjusted to Debugging steps in 'upgrade error' documentation must be adjusted

#2 Updated by emmapeel about 4 years ago

  • Description updated (diff)

#3 Updated by intrigeri about 4 years ago

emmapeel wrote:

When users cannot boot after an automatic upgrade, they are directed to the page

https://tails.boum.org/doc/upgrade/error/install/

Just to clarify: is that true in general, or only when we explicitly and manually ask them to provide the same information as the instructions on that page would produce?

#4 Updated by emmapeel about 4 years ago

Well, I think it that the page says 'might be unable to start', so maybe we can add a note for this case specifically, like: "If you cannot start then you need to mount it from another Tails"

Tails partition is not mounted automatically, and I think users new to Linux could not provide us with the debugging info during the problems with Tails 1.6 because of this little detail.

#5 Updated by intrigeri almost 4 years ago

  • Related to Bug #10239: Tails Upgrader sometimes make device unbootable added

#6 Updated by sajolida almost 4 years ago

  • Subject changed from Debugging steps in 'upgrade error' documentation must be adjusted to Troubleshooting for automatic upgrades that fail to restart
  • QA Check changed from Dev Needed to Info Needed

The page "/upgrade/error/install" reads "The upgrade could not be installed. Your Tails device needs to be repaired and might be unable to restart." and this page is pointed to from "/doc/first_steps/upgrade" with the label "If an error occurs while installing the upgrade".

So this page correctly corresponds to an automatic upgrade that fails while Tails is still running.

What you are referring to is the lack of troubleshooting information if the automatic upgrade succeeds but it's impossible to restart on the device.

I think this should be treated as a different case from "/upgrade/error/install". Maybe as "/upgrade/error/restart". Renaming this ticket accordingly.

emmapeel: do you agree? do you want to work on this?

#7 Updated by emmapeel over 3 years ago

  • QA Check changed from Info Needed to Dev Needed

Yes, I agree. I will work on creating such page.

#8 Updated by u almost 2 years ago

  • Description updated (diff)

#9 Updated by u almost 2 years ago

  • Related to Feature #15130: Restructure our support page and content added

#10 Updated by emmapeel over 1 year ago

  • Category set to Installation
  • Assignee changed from emmapeel to sajolida

sajolida please have a look at this ticket and prioritise as you see fit.

#11 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to cbrownstein
  • Estimated time deleted (0.50 h)
  • QA Check deleted (Dev Needed)

This one goes along with #15557.

#12 Updated by sajolida over 1 year ago

  • Blocks Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing added

#13 Updated by sajolida over 1 year ago

  • Related to Bug #15557: Document workaround for partially applied automatic upgrade added

#14 Updated by sajolida over 1 year ago

  • Priority changed from Normal to Elevated

Can you have a look at this one while working on #15557?

#15 Updated by sajolida about 1 year ago

  • Assignee changed from cbrownstein to sajolida

#16 Updated by sajolida about 1 year ago

  • Blocks deleted (Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing)

#17 Updated by sajolida about 1 year ago

  • Blocks Bug #15491: Tails 3.6* hangs during boot with Macbook 7.1 added

#18 Updated by sajolida about 1 year ago

  • Blocks deleted (Bug #15491: Tails 3.6* hangs during boot with Macbook 7.1)

#19 Updated by sajolida about 1 year ago

  • Blocks Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing added

#20 Updated by sajolida 12 months ago

  • Priority changed from Elevated to Normal
  • Target version set to Tails_3.11

#21 Updated by sajolida 11 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#22 Updated by sajolida 10 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#23 Updated by sajolida 8 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#24 Updated by sajolida 6 months ago

  • Target version deleted (Tails_3.14)

#25 Updated by sajolida 4 months ago

  • Blocks Feature #16711: Core work 2019Q3 → 2019Q4: Technical writing added

#26 Updated by sajolida 4 months ago

  • Blocks deleted (Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing)

#27 Updated by sajolida 4 months ago

  • Target version set to Tails_3.16

#28 Updated by sajolida 4 months ago

  • Status changed from Confirmed to Needs Validation
  • Assignee changed from sajolida to cbrownstein
  • Feature Branch set to doc/10347-broken-after-automatic-upgrade

Here is a branch.

#29 Updated by CyrilBrulebois 2 months ago

  • Target version changed from Tails_3.16 to Tails_3.17

#30 Updated by intrigeri 2 months ago

  • Target version changed from Tails_3.17 to Tails_4.0

#31 Updated by sajolida about 2 months ago

@cbrownstein: Ping on this review. I'll need it merged to work on #10885.

#32 Updated by cbrownstein about 2 months ago

  • Status changed from Needs Validation to In Progress
  • Assignee changed from cbrownstein to sajolida

I've pushed a few changes to my branch. Otherwise, looks good!

https://0xacab.org/cbrownstein/tails/commits/doc/10347-broken-after-automatic-upgrade

#33 Updated by sajolida about 2 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

Thanks for all the small fixes!

Same as #15718#note-18: I merged it locally and will push it soon.

Also available in: Atom PDF