Project

General

Profile

Feature #10345

Run the automated test suite's VNC server forever

Added by anonym over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
10/06/2015
Due date:
% Done:

100%

Feature Branch:
test/10345-run-vnc-server-forever
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Well, with the -forever option, which will conveniently quit when we kill Xvfb at the end of the run (or when aborting). This way one can reconnect over vnc if the connection was killed for whatever reason.

Associated revisions

Revision edfd79ef (diff)
Added by anonym over 4 years ago

Run the automated test suite's vnc server forever.

Will-fix: #10345

Revision c138c2f3
Added by intrigeri about 4 years ago

Merge remote-tracking branch 'origin/test/10345-run-vnc-server-forever' into devel

Fix-committed: #10345

History

#1 Updated by anonym over 4 years ago

  • Status changed from Confirmed to In Progress

#2 Updated by anonym over 4 years ago

  • Assignee changed from anonym to kytv
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to test/10345-run-vnc-server-forever

#3 Updated by kytv about 4 years ago

  • Assignee changed from kytv to intrigeri
  • QA Check changed from Ready for QA to Dev Needed

Review/code passed.

#4 Updated by kytv about 4 years ago

  • Target version changed from Tails_1.7 to Tails_1.8
  • QA Check changed from Dev Needed to Ready for QA

#5 Updated by intrigeri about 4 years ago

  • Subject changed from Run the automated test suite's vnc server forever to Run the automated test suite's VNC server forever

#6 Updated by intrigeri about 4 years ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

#7 Updated by intrigeri about 4 years ago

  • Assignee changed from intrigeri to anonym
  • Target version changed from Tails_1.8 to 246
  • QA Check changed from Ready for QA to Pass

Merged into devel since this branch was based on it. This conflicts with the 1.8 target version that kytv has set (I can't merge this for 1.8 since it'll be a point release and this branch is based on devel, which should not be merged into stable before the 1.7 release -- see what I mean?) => unless we do something special this will be for 1.9 in 3 months.

I suspect this mayyyybe wasn't exactly the idea. So, anonym: if you think this should go into 1.7, feel free to cherry-pick edfd79e into stable, set target version to 1.7, update changelog, you know the drill.

#8 Updated by anonym about 4 years ago

  • Target version changed from 246 to Tails_1.7

intrigeri wrote:

Merged into devel since this branch was based on it. This conflicts with the 1.8 target version that kytv has set (I can't merge this for 1.8 since it'll be a point release and this branch is based on devel, which should not be merged into stable before the 1.7 release -- see what I mean?) => unless we do something special this will be for 1.9 in 3 months.

I suspect this mayyyybe wasn't exactly the idea. So, anonym: if you think this should go into 1.7, feel free to cherry-pick edfd79e into stable, set target version to 1.7, update changelog, you know the drill.

Well the plan was to have it merged in before the 1.7 freeze, but given the amount of tickets kytv still had some days before that, I thought postponing this ticket would be nice to him. That's why we are in this "situation", but I must say I don't see the problem you are seeing in it. I mean, this branch was based on devel at some point, but after the freeze testing has that state of devel merged into it so this branch can be considered based on testing (and after releasing 1.7, stable has that state and this branch can be considered based on it).

For something more concrete, look at git log origin/testing..origin/test/10345-run-vnc-server-forever -- there's no problem merging this branch it into testing, so I've just done that.

#9 Updated by anonym about 4 years ago

  • Assignee deleted (anonym)

#10 Updated by intrigeri about 4 years ago

I must say I don't see the problem you are seeing in it. I mean, this branch was based on devel at some point, but after the freeze testing has that state of devel merged into it so this branch can be considered based on testing (and after releasing 1.7, stable has that state and this branch can be considered based on it).

Right, my bad. Sorry for the noise.

there's no problem merging this branch it into testing, so I've just done that.

Thank you.

#11 Updated by anonym about 4 years ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF