Project

General

Profile

Feature #10332

Feature #8546: Write regression tests and tests for new features

Write initial Icedove tests

Added by kytv about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
Start date:
10/03/2015
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
kytv:feature/5663-return-to-icedove
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

Since Icedove will soon be in Tails there should be some tests written for it.

Initially, we should probably check that Icedove is configured as per https://tails.boum.org/blueprint/Return_of_Icedove__63__/#index5h2


Related issues

Related to Tails - Feature #6304: Automate the most important bits of the Icedove tests Resolved 09/26/2013
Blocked by Tails - Feature #6151: Basic Icedove configuration Resolved 08/02/2015

Associated revisions

Revision 2a05e0b5 (diff)
Added by kytv about 3 years ago

Initial set of tests for Icedove

Will-fix: #10332

Revision d6045ce7
Added by anonym about 3 years ago

Merge branch 'feature/5663-return-to-icedove' into devel

Fix-committed: #6151, #9498, #10285, #10332

History

#1 Updated by kytv about 3 years ago

  • Parent task set to #8546

#2 Updated by kytv about 3 years ago

#3 Updated by intrigeri about 3 years ago

kytv, please clarify how this ticket relates to #6304, which you have on your plate already (deadline = January 15).

#4 Updated by kytv about 3 years ago

  • Assignee changed from kytv to anonym
  • QA Check set to Ready for QA
  • Feature Branch set to kytv:test/10332-initial-tests-for-icedove

To be clear, I don't know. Perhaps this should be closed as a duplicate of that one? Since that one is blocked by writing the manual tests I thought, perhaps wrongly, that a second ticket would be more appropriate.

I just wanted to have some tests for this release and what I came up with things that I think are important but didn't take a lot of time to do.

#5 Updated by anonym about 3 years ago

  • Assignee changed from anonym to kytv
  • QA Check changed from Ready for QA to Dev Needed

#6 Updated by kytv about 3 years ago

  • QA Check changed from Dev Needed to Ready for QA

#7 Updated by kytv about 3 years ago

  • Assignee changed from kytv to anonym

#8 Updated by kytv about 3 years ago

#9 Updated by anonym about 3 years ago

  • Feature Branch changed from kytv:test/10332-initial-tests-for-icedove to kytv:feature/5663-return-to-icedove

The feature branch was merged into the icedove "integration" branch.

#10 Updated by anonym about 3 years ago

  • Assignee changed from anonym to kytv
  • QA Check changed from Ready for QA to Dev Needed

#12 Updated by intrigeri about 3 years ago

kytv wrote:

To be clear, I don't know. Perhaps this should be closed as a duplicate of that one? Since that one is blocked by writing the manual tests I thought, perhaps wrongly, that a second ticket would be more appropriate.

I just wanted to have some tests for this release and what I came up with things that I think are important but didn't take a lot of time to do.

OK. I don't really get it, but as long as it helps you organize your work I'm fine with it.

#13 Updated by intrigeri about 3 years ago

  • Related to Feature #6304: Automate the most important bits of the Icedove tests added

#14 Updated by kytv about 3 years ago

  • QA Check changed from Dev Needed to Ready for QA

#15 Updated by kytv about 3 years ago

  • Assignee changed from kytv to anonym

#16 Updated by anonym about 3 years ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 0 to 100

#17 Updated by anonym about 3 years ago

  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#18 Updated by anonym about 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF