Project

General

Profile

Feature #10190

Install OpenPGP Applet from Debian

Added by intrigeri almost 4 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/16/2016
Due date:
% Done:

100%

Feature Branch:
feature/10190-OpenPGP-applet-from-Debian
Type of work:
Code
Blueprint:
Starter:
Affected tool:
OpenPGP Applet

Description

It's now in testing and sid, let's replace our embedded version with that one.


Subtasks

Feature #11244: Update our documentation to OpenPGP Applet in DebianResolved


Related issues

Blocks Tails - Bug #7742: Non-DFSG compliant images in the Tails OpenPGP Applet Resolved 08/04/2014
Blocks Tails - Bug #10042: Wrong name in OpenPGP Applet .desktop file Resolved 08/15/2015
Blocks Tails - Bug #8319: OpenPGP Applet: Add a confirmation dialog on exit Resolved 11/26/2014
Blocks Tails - Bug #6850: Consistently use "Tails OpenPGP Applet" in all occurrences Resolved 03/05/2014
Blocks Tails - Feature #7435: Add Tails OpenPGP Applet to the Applications menu Confirmed 06/22/2014
Blocks Tails - Feature #7711: Port the OpenPGP applet to GTK+ 3 Resolved 08/01/2014

Associated revisions

Revision 149c43d4 (diff)
Added by intrigeri about 3 years ago

Install OpenPGP Applet from Debian.

refs: #10190

Revision bf8a8e43 (diff)
Added by intrigeri about 3 years ago

Test suite: update image for new OpenPGP applet.

refs: #10190

Revision 0c2b12f7 (diff)
Added by intrigeri about 3 years ago

Test suite: update more images for new OpenPGP applet.

refs: #10190

Revision bd961bd8
Added by anonym almost 3 years ago

Merge remote-tracking branch 'origin/feature/from-intrigeri-for-2.6' into devel

Fix-committed: #5650, #6729, #6850, #8485, #10190, #10298, #10733, #10733, #11281, #11588, #11582, #11590

History

#1 Updated by intrigeri almost 4 years ago

  • Blocks Bug #7742: Non-DFSG compliant images in the Tails OpenPGP Applet added

#2 Updated by nodens almost 4 years ago

From the top of my head, the notable differences between the package in Tails in Debian :
- script name (openpgp-applet in debian, gpgApplet in Tails)
- paths (obviously)
- .desktop file in Tails launches the applet with torsocks (needed to retrieve keys from key servers)

#3 Updated by nodens almost 4 years ago

  • Related to Bug #10042: Wrong name in OpenPGP Applet .desktop file added

#4 Updated by nodens almost 4 years ago

  • Related to deleted (Bug #10042: Wrong name in OpenPGP Applet .desktop file)

#5 Updated by nodens almost 4 years ago

  • Blocks Bug #10042: Wrong name in OpenPGP Applet .desktop file added

#6 Updated by intrigeri almost 4 years ago

  • Assignee changed from intrigeri to nodens
  • QA Check set to Info Needed

From the top of my head, the notable differences between the package in Tails in Debian :

Thanks :)

- script name (openpgp-applet in debian, gpgApplet in Tails)
- paths (obviously)

Add to that:

  • git grep -w gpgApplet also reveals some other stuff that needs clean ups.
  • the screenshots in the doc might need to be updated

Also, what's the status wrt. Transifex? Is OpenPGP Applet translatable there, or?

- .desktop file in Tails launches the applet with torsocks (needed to retrieve keys from key servers)

Seems like we'll have to sed the .desktop at ISO build time. That should go into config/chroot_local-hooks/09-torsocks-apps (on the feature/jessie branch).

#7 Updated by intrigeri almost 4 years ago

  • Assignee deleted (nodens)
  • Priority changed from Normal to Low
  • QA Check deleted (Info Needed)

intrigeri wrote:

Also, what's the status wrt. Transifex? Is OpenPGP Applet translatable there, or?

Apparently it's not so I just asked Colin.

Downgrading to low prio, meaning: not a blocker for the Tails 2.0 release, formally speaking. But it would be awesome to have it in there!

#8 Updated by intrigeri over 3 years ago

intrigeri wrote:

intrigeri wrote:

Also, what's the status wrt. Transifex? Is OpenPGP Applet translatable there, or?

Apparently it's not so I just asked Colin.

It's been added, and completed translations can be found in the tails-openpgp-applet_completed branch in the https://git.torproject.org/translation repo.
See https://tails.boum.org/contribute/release_process/#index8h2 for hints about how to refresh, import and merge translations from there.

#9 Updated by intrigeri over 3 years ago

  • Assignee set to nodens
  • Target version changed from Tails_2.0 to Tails_2.2

nodens, any plan to work on this before the end of February?

#10 Updated by nodens over 3 years ago

Yes ! At least a first pass. I need to setup a complete build system and to understand it ;)

Help welcome, though, if anyone want to work on this to be sure it's included in tails 2.2.

Cheers

#11 Updated by anonym over 3 years ago

  • Target version changed from Tails_2.2 to Tails_2.3

#12 Updated by anonym over 3 years ago

  • Target version changed from Tails_2.3 to Tails_2.4

#13 Updated by anonym about 3 years ago

  • Target version changed from Tails_2.4 to Tails_2.5

#14 Updated by BitingBird about 3 years ago

  • Status changed from Confirmed to In Progress

#15 Updated by BitingBird about 3 years ago

  • Blocks Bug #8319: OpenPGP Applet: Add a confirmation dialog on exit added

#16 Updated by nodens about 3 years ago

  • Blocks Bug #6850: Consistently use "Tails OpenPGP Applet" in all occurrences added

#17 Updated by nodens about 3 years ago

Maybe we should change the priority to "normal" since it blocks "normal" bugs.

#18 Updated by intrigeri about 3 years ago

  • Assignee changed from nodens to intrigeri
  • Target version changed from Tails_2.5 to Tails_2.6

As discussed with nodens, he's going to focus on the port to GTK+ 3.x while I do this part.

#19 Updated by intrigeri about 3 years ago

  • Feature Branch set to feature/10190-OpenPGP-applet-from-Debian

#20 Updated by intrigeri about 3 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check set to Ready for QA

Once merged, all "fix committed" tasks that this ticket blocks should get "Target version" = 2.6, to indicate that these fixes are going to be in Tails 2.6.

#21 Updated by intrigeri about 3 years ago

I'd like to ease reviewing for the 2.6 RM, and to get automated tests running about the combination of all these changes ASAP in the 2.6 dev cycle. So, I've merged this work, along with the other major branches I'm proposing for 2.6, into the feature/from-intrigeri-for-2.6 integration branch (Jenkins builds and tests).

#22 Updated by anonym almost 3 years ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • QA Check changed from Ready for QA to Pass

#23 Updated by nodens almost 3 years ago

  • Blocks Feature #7435: Add Tails OpenPGP Applet to the Applications menu added

#24 Updated by nodens almost 3 years ago

#25 Updated by anonym almost 3 years ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF